source: projects/specs/trunk/g/glade3/glade3-vl.spec @ 8060

Revision 8060, 6.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define helpdir glade3
2
3Version: 3.16.1
4Release: 1%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.16/glade-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk3-devel >= 3.0.2
16BuildRequires: libxml2-devel >= 2.4.0
17BuildRequires: python-devel
18BuildRequires: pygobject3-devel
19BuildRequires: libSM-devel
20BuildRequires: yelp-tools
21BuildRequires: docbook-style-xsl
22
23Requires: gtk3 >= 3.0.2
24Requires: libxml2 >= 2.4.0
25Requires: pygobject3
26Requires: devhelp
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Glade is a RAD tool to enable quick & easy development of user interfaces
33for the Gtk+ toolkit and the GNOME desktop environment.
34The user interfaces designed in Glade are stored in XML format,
35enabling easy integration with external tools.
36In particular libglade can load the XML files and create the interfaces
37at runtime. The DTD for the XML files is included with libglade, and is
38also at http://glade.gnome.org/glade-2.0.dtd.
39Other tools are available which can turn the XML files into source code
40in languages such as C++, Perl and Python.
41
42%description -l ja
43Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
44発する事が可能なRADツールです。
45Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
46フォーマットで保存されます。
47特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
48ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
49http://glade.gnome.org/glade-2.0.dtdにもあります。
50このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
51ルも利用可能です。
52
53%package devel
54Summary:        the Glade UI Builder core library
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57
58%description devel
59the Glade UI Builder core library to integrate Glade into your application
60and integrate your custom (GTK+ based) widget toolkit into the Glade
61UI Builder.
62
63%prep
64%setup -q -n glade-%{version}
65pushd src
66## change gnome help directory
67mv glade-window.c glade-window.c.orig
68sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
69        glade-window.c.orig > glade-window.c
70popd
71
72
73%build
74%configure --disable-static
75%__make %{_smp_mflags}
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
83rm -f $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
84rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-2.la
85
86%find_lang glade --all-name --with-gnome
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
92/sbin/ldconfig
93touch --no-create %{_datadir}/icons/hicolor
94if [ -x /usr/bin/gtk-update-icon-cache ]; then
95  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
96fi
97
98%postun
99/sbin/ldconfig
100touch --no-create %{_datadir}/icons/hicolor
101if [ -x /usr/bin/gtk-update-icon-cache ]; then
102  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
103fi
104
105%files -f glade.lang
106%defattr(-,root,root)
107%{_bindir}/glade
108%{_bindir}/glade-previewer
109%{_libdir}/libgladeui-2.so.*
110%{_libdir}/glade/modules/*.so
111%{_libdir}/girepository-1.0/Gladeui-2.0.typelib
112%{_datadir}/appdata/glade.appdata.xml
113%{_datadir}/applications/glade.desktop
114%{_datadir}/glade
115%{_datadir}/icons/hicolor/*/apps/glade.png
116%{_mandir}/man1/glade-previewer.1.gz
117%{_mandir}/man1/glade.1.gz
118
119%files  devel
120%defattr(-,root,root)
121%{_includedir}/libgladeui-2.0/gladeui/*
122%{_libdir}/pkgconfig/*.pc
123%{_libdir}/libgladeui-2.so
124%{_datadir}/gir-1.0/Gladeui-2.0.gir
125%{_datadir}/gtk-doc/html/gladeui-2
126
127%changelog
128* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
129- new upstream release
130
131* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
132- new upstream release
133- add BuildRequires: docbook-style-xsl
134
135* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
136- new upstream release
137
138* Mon Oct 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
139- new upstream release
140- add BuildRequires: python-devel, pygobject3-devel
141
142* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
143- new upstream release
144- change BuildRequires: yelp-tools instead of gnome-doc-utils
145
146* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
147- new upstream release
148
149* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
150- new upstream release
151
152* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
153- new upstream release
154
155* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
156- new upstream release
157- change BuildRequires: gtk3-devel instead of gtk2-devel
158- delete BuildRequires: libgnomeui-devel, libbonoboui-devel
159
160* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
161- rebuild with rpm-4.8.1 for pkg-config file
162- add BuildRequires: libSM-devel
163
164* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
165- add gnome-doc-utils to BR
166- comment out desktop-file-install
167
168* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
169- rebuild with gtk2-2.18.2
170
171* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
172- new upstream release
173- care ld and icon cache
174- define helpdir
175
176* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
177- new upstream release
178- spec in utf-8 (fixed)
179
180* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
181- spec in utf-8
182
183* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
184- new upstream release
185
186* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
187- new upstream version.
188
189* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
190- new upstream version.
191- update Requires.
192- update description.
193
194* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
195- use macro for release
196
197* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
198- apply new virsioning policy.
199- remove *.la
200
201* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
202- new upstream version
203- added Requires: devhelp
204- added Prereq: scrollkeeper
205- added disable-scrollkeeper to configure
206- added scrollkeeper-update in %%post and %%postun sections
207- changed gnome help directory temporarily
208
209* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
210- build for VineSeed
211
Note: See TracBrowser for help on using the repository browser.