source: projects/specs/trunk/g/glade3/glade3-vl.spec @ 7294

Revision 7294, 6.1 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1%define helpdir glade3
2
3Version: 3.14.2
4Release: 1%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.14/glade-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk3-devel >= 3.0.2
16BuildRequires: libxml2-devel >= 2.4.0
17BuildRequires: python-devel
18BuildRequires: pygobject3-devel
19BuildRequires: libSM-devel
20BuildRequires: yelp-tools
21
22Requires: gtk3 >= 3.0.2
23Requires: libxml2 >= 2.4.0
24Requires: pygobject3
25Requires: devhelp
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Glade is a RAD tool to enable quick & easy development of user interfaces
32for the Gtk+ toolkit and the GNOME desktop environment.
33The user interfaces designed in Glade are stored in XML format,
34enabling easy integration with external tools.
35In particular libglade can load the XML files and create the interfaces
36at runtime. The DTD for the XML files is included with libglade, and is
37also at http://glade.gnome.org/glade-2.0.dtd.
38Other tools are available which can turn the XML files into source code
39in languages such as C++, Perl and Python.
40
41%description -l ja
42Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
43発する事が可能なRADツールです。
44Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
45フォーマットで保存されます。
46特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
47ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
48http://glade.gnome.org/glade-2.0.dtdにもあります。
49このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
50ルも利用可能です。
51
52%package devel
53Summary:        the Glade UI Builder core library
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56
57%description devel
58the Glade UI Builder core library to integrate Glade into your application
59and integrate your custom (GTK+ based) widget toolkit into the Glade
60UI Builder.
61
62%prep
63%setup -q -n glade-%{version}
64pushd src
65## change gnome help directory
66mv glade-window.c glade-window.c.orig
67sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
68        glade-window.c.orig > glade-window.c
69popd
70
71
72%build
73%configure --disable-static
74%__make %{_smp_mflags}
75
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make install DESTDIR=$RPM_BUILD_ROOT
80
81rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
82rm -f $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
83rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-2.la
84
85%find_lang glade --all-name --with-gnome
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post
91/sbin/ldconfig
92touch --no-create %{_datadir}/icons/hicolor
93if [ -x /usr/bin/gtk-update-icon-cache ]; then
94  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
95fi
96
97%postun
98/sbin/ldconfig
99touch --no-create %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
102fi
103
104%files -f glade.lang
105%defattr(-,root,root)
106%{_bindir}/glade
107%{_bindir}/glade-previewer
108%{_libdir}/libgladeui-2.so.*
109%{_libdir}/glade/modules/*.so
110%{_libdir}/girepository-1.0/Gladeui-2.0.typelib
111%{_datadir}/applications/glade.desktop
112%{_datadir}/glade
113%{_datadir}/icons/hicolor/*/apps/glade.png
114
115%files  devel
116%defattr(-,root,root)
117%{_includedir}/libgladeui-2.0/gladeui/*
118%{_libdir}/pkgconfig/*.pc
119%{_libdir}/libgladeui-2.so
120%{_datadir}/gir-1.0/Gladeui-2.0.gir
121%{_datadir}/gtk-doc/html/gladeui-2
122
123%changelog
124* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
125- new upstream release
126
127* Mon Oct 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
128- new upstream release
129- add BuildRequires: python-devel, pygobject3-devel
130
131* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
132- new upstream release
133- change BuildRequires: yelp-tools instead of gnome-doc-utils
134
135* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
136- new upstream release
137
138* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
139- new upstream release
140
141* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
142- new upstream release
143
144* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
145- new upstream release
146- change BuildRequires: gtk3-devel instead of gtk2-devel
147- delete BuildRequires: libgnomeui-devel, libbonoboui-devel
148
149* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
150- rebuild with rpm-4.8.1 for pkg-config file
151- add BuildRequires: libSM-devel
152
153* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
154- add gnome-doc-utils to BR
155- comment out desktop-file-install
156
157* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
158- rebuild with gtk2-2.18.2
159
160* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
161- new upstream release
162- care ld and icon cache
163- define helpdir
164
165* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
166- new upstream release
167- spec in utf-8 (fixed)
168
169* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
170- spec in utf-8
171
172* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
173- new upstream release
174
175* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
176- new upstream version.
177
178* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
179- new upstream version.
180- update Requires.
181- update description.
182
183* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
184- use macro for release
185
186* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
187- apply new virsioning policy.
188- remove *.la
189
190* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
191- new upstream version
192- added Requires: devhelp
193- added Prereq: scrollkeeper
194- added disable-scrollkeeper to configure
195- added scrollkeeper-update in %%post and %%postun sections
196- changed gnome help directory temporarily
197
198* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
199- build for VineSeed
200
Note: See TracBrowser for help on using the repository browser.