source: projects/specs/trunk/g/glade3/glade3-vl.spec @ 6890

Revision 6890, 5.9 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define helpdir glade3
2
3Version: 3.14.0
4Release: 1%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.14/glade-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk3-devel >= 3.0.2
16BuildRequires: libxml2-devel >= 2.4.0
17BuildRequires: libSM-devel
18BuildRequires: yelp-tools
19
20Requires: gtk3 >= 3.0.2
21Requires: libxml2 >= 2.4.0
22#Requires: libbonoboui
23Requires: devhelp
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29Glade is a RAD tool to enable quick & easy development of user interfaces
30for the Gtk+ toolkit and the GNOME desktop environment.
31The user interfaces designed in Glade are stored in XML format,
32enabling easy integration with external tools.
33In particular libglade can load the XML files and create the interfaces
34at runtime. The DTD for the XML files is included with libglade, and is
35also at http://glade.gnome.org/glade-2.0.dtd.
36Other tools are available which can turn the XML files into source code
37in languages such as C++, Perl and Python.
38
39%description -l ja
40Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
41発する事が可能なRADツールです。
42Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
43フォーマットで保存されます。
44特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
45ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
46http://glade.gnome.org/glade-2.0.dtdにもあります。
47このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
48ルも利用可能です。
49
50%package devel
51Summary:        the Glade UI Builder core library
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54
55%description devel
56the Glade UI Builder core library to integrate Glade into your application
57and integrate your custom (GTK+ based) widget toolkit into the Glade
58UI Builder.
59
60%prep
61%setup -q -n glade-%{version}
62pushd src
63## change gnome help directory
64mv glade-window.c glade-window.c.orig
65sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
66        glade-window.c.orig > glade-window.c
67popd
68
69
70%build
71%configure --disable-static
72%__make %{_smp_mflags}
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install DESTDIR=$RPM_BUILD_ROOT
78
79rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
80rm -f $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
81rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-2.la
82
83%find_lang glade --all-name --with-gnome
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post
89/sbin/ldconfig
90touch --no-create %{_datadir}/icons/hicolor
91if [ -x /usr/bin/gtk-update-icon-cache ]; then
92  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
93fi
94
95%postun
96/sbin/ldconfig
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x /usr/bin/gtk-update-icon-cache ]; then
99  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
100fi
101
102%files -f glade.lang
103%defattr(-,root,root)
104%{_bindir}/glade
105%{_bindir}/glade-previewer
106%{_libdir}/libgladeui-2.so.*
107%{_libdir}/glade/modules/*.so
108%{_libdir}/girepository-1.0/Gladeui-2.0.typelib
109%{_datadir}/applications/glade.desktop
110%{_datadir}/glade
111%{_datadir}/icons/hicolor/*/apps/glade.png
112
113%files  devel
114%defattr(-,root,root)
115%{_includedir}/libgladeui-2.0/gladeui/*
116%{_libdir}/pkgconfig/*.pc
117%{_libdir}/libgladeui-2.so
118%{_datadir}/gir-1.0/Gladeui-2.0.gir
119%{_datadir}/gtk-doc/html/gladeui-2
120
121%changelog
122* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
123- new upstream release
124- change BuildRequires: yelp-tools instead of gnome-doc-utils
125
126* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
127- new upstream release
128
129* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
130- new upstream release
131
132* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
133- new upstream release
134
135* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
136- new upstream release
137- change BuildRequires: gtk3-devel instead of gtk2-devel
138- delete BuildRequires: libgnomeui-devel, libbonoboui-devel
139
140* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
141- rebuild with rpm-4.8.1 for pkg-config file
142- add BuildRequires: libSM-devel
143
144* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
145- add gnome-doc-utils to BR
146- comment out desktop-file-install
147
148* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
149- rebuild with gtk2-2.18.2
150
151* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
152- new upstream release
153- care ld and icon cache
154- define helpdir
155
156* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
157- new upstream release
158- spec in utf-8 (fixed)
159
160* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
161- spec in utf-8
162
163* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
164- new upstream release
165
166* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
167- new upstream version.
168
169* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
170- new upstream version.
171- update Requires.
172- update description.
173
174* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
175- use macro for release
176
177* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
178- apply new virsioning policy.
179- remove *.la
180
181* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
182- new upstream version
183- added Requires: devhelp
184- added Prereq: scrollkeeper
185- added disable-scrollkeeper to configure
186- added scrollkeeper-update in %%post and %%postun sections
187- changed gnome help directory temporarily
188
189* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
190- build for VineSeed
191
Note: See TracBrowser for help on using the repository browser.