source: projects/specs/trunk/g/glade3/glade3-vl.spec @ 521

Revision 521, 6.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define helpdir glade3
2
3Version: 3.6.7
4Release: 3%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade3/3.6/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk2-devel >= 2.14.0
16BuildRequires: libxml2-devel >= 2.4.0
17BuildRequires: libbonoboui-devel
18BuildRequires: libgnomeui-devel
19#BuildRequires(install): desktop-file-utils
20BuildRequires: gnome-doc-utils
21
22Requires: gtk2 >= 2.14.0
23Requires: libxml2 >= 2.4.0
24Requires: libbonoboui
25Requires: libgnomeui
26Requires: devhelp
27Prereq: scrollkeeper
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33Glade is a RAD tool to enable quick & easy development of user interfaces
34for the Gtk+ toolkit and the GNOME desktop environment.
35The user interfaces designed in Glade are stored in XML format,
36enabling easy integration with external tools.
37In particular libglade can load the XML files and create the interfaces
38at runtime. The DTD for the XML files is included with libglade, and is
39also at http://glade.gnome.org/glade-2.0.dtd.
40Other tools are available which can turn the XML files into source code
41in languages such as C++, Perl and Python.
42
43%description -l ja
44Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
45発する事が可能なRADツールです。
46Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
47フォーマットで保存されます。
48特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
49ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
50http://glade.gnome.org/glade-2.0.dtdにもあります。
51このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
52ルも利用可能です。
53
54%package devel
55Summary:        the Glade UI Builder core library
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       gtk2-devel >= 2.12.0
59Requires:       libxml2-devel >= 2.4.0
60Requires:       libbonoboui-devel
61Requires:       libgnomeui-devel
62
63%description devel
64the Glade UI Builder core library to integrate Glade into your application
65and integrate your custom (GTK+ based) widget toolkit into the Glade
66UI Builder.
67
68%prep
69%setup -q
70pushd src
71## change gnome help directory
72mv glade-window.c glade-window.c.orig
73sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
74        glade-window.c.orig > glade-window.c
75popd
76
77
78%build
79%configure --disable-scrollkeeper --disable-static
80%__make %{_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%makeinstall
86
87#desktop-file-install \
88#       --vendor gnome \
89#       --delete-original \
90#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
91#       $RPM_BUILD_ROOT%{_datadir}/applications/*
92
93rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
94rm -f $RPM_BUILD_ROOT%{_libdir}/glade3/modules/*.la
95rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-1.la
96
97## change gnome help directory
98mv $RPM_BUILD_ROOT%{_datadir}/gnome/help/glade $RPM_BUILD_ROOT%{_datadir}/gnome/help/%{helpdir}
99mv $RPM_BUILD_ROOT%{_datadir}/omf/glade $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
100pushd $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
101files=`ls *.omf`
102for omf in $files; do
103        mv $omf $omf.orig
104        sed "s|help/glade/|help/%{helpdir}/|g" $omf.orig > $omf
105        rm $omf.orig
106done
107popd
108     
109%find_lang %{name}
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post
115/sbin/ldconfig
116scrollkeeper-update -p /var/lib/scrollkeeper -o %{_datadir}/omf/%{helpdir}
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121
122%postun
123/sbin/ldconfig
124scrollkeeper-update > /dev/null 2>&1 || :
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_bindir}/glade-3
133%{_libdir}/libgladeui-1.so.*
134%{_libdir}/glade3/modules/*.so
135%{_datadir}/applications/*
136%{_datadir}/glade3
137%{_datadir}/gtk-doc/html/gladeui
138%{_datadir}/gnome/help/%{helpdir}
139%{_datadir}/icons/hicolor/*/apps/glade-3.png
140%{_datadir}/icons/hicolor/scalable/apps/glade-3.svg
141%{_datadir}/omf/%{helpdir}
142
143%files  devel
144%defattr(-,root,root)
145%{_includedir}/libgladeui-1.0/gladeui/*
146%{_libdir}/pkgconfig/*.pc
147%{_libdir}/libgladeui-1.so
148
149%changelog
150* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
151- add gnome-doc-utils to BR
152- comment out desktop-file-install
153
154* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
155- rebuild with gtk2-2.18.2
156
157* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
158- new upstream release
159- care ld and icon cache
160- define helpdir
161
162* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
163- new upstream release
164- spec in utf-8 (fixed)
165
166* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
167- spec in utf-8
168
169* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
170- new upstream release
171
172* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
173- new upstream version.
174
175* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
176- new upstream version.
177- update Requires.
178- update description.
179
180* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
181- use macro for release
182
183* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
184- apply new virsioning policy.
185- remove *.la
186
187* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
188- new upstream version
189- added Requires: devhelp
190- added Prereq: scrollkeeper
191- added disable-scrollkeeper to configure
192- added scrollkeeper-update in %%post and %%postun sections
193- changed gnome help directory temporarily
194
195* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
196- build for VineSeed
197
Note: See TracBrowser for help on using the repository browser.