source: projects/specs/trunk/g/glade3/glade3-vl.spec @ 5038

Revision 5038, 6.5 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.1

Line 
1%define helpdir glade3
2
3Version: 3.10.2
4Release: 1%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.10/glade-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk3-devel >= 3.0.2
16BuildRequires: libxml2-devel >= 2.4.0
17#BuildRequires: libbonoboui-devel
18#BuildRequires: libgnomeui-devel
19BuildRequires: libSM-devel
20BuildRequires: gnome-doc-utils
21
22Requires: gtk3 >= 3.0.2
23Requires: libxml2 >= 2.4.0
24#Requires: libbonoboui
25#Requires: libgnomeui
26Requires: devhelp
27Requires(pre): scrollkeeper
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33Glade is a RAD tool to enable quick & easy development of user interfaces
34for the Gtk+ toolkit and the GNOME desktop environment.
35The user interfaces designed in Glade are stored in XML format,
36enabling easy integration with external tools.
37In particular libglade can load the XML files and create the interfaces
38at runtime. The DTD for the XML files is included with libglade, and is
39also at http://glade.gnome.org/glade-2.0.dtd.
40Other tools are available which can turn the XML files into source code
41in languages such as C++, Perl and Python.
42
43%description -l ja
44Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
45発する事が可能なRADツールです。
46Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
47フォーマットで保存されます。
48特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
49ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
50http://glade.gnome.org/glade-2.0.dtdにもあります。
51このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
52ルも利用可能です。
53
54%package devel
55Summary:        the Glade UI Builder core library
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       gtk2-devel >= 2.12.0
59Requires:       libxml2-devel >= 2.4.0
60Requires:       libbonoboui-devel
61Requires:       libgnomeui-devel
62
63%description devel
64the Glade UI Builder core library to integrate Glade into your application
65and integrate your custom (GTK+ based) widget toolkit into the Glade
66UI Builder.
67
68%prep
69%setup -q -n glade-%{version}
70pushd src
71## change gnome help directory
72mv glade-window.c glade-window.c.orig
73sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
74        glade-window.c.orig > glade-window.c
75popd
76
77
78%build
79%configure --disable-scrollkeeper --disable-static
80%__make %{_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%makeinstall
86
87#desktop-file-install \
88#       --vendor gnome \
89#       --delete-original \
90#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
91#       $RPM_BUILD_ROOT%{_datadir}/applications/*
92
93rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
94rm -f $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
95rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-2.la
96
97## change gnome help directory
98mv $RPM_BUILD_ROOT%{_datadir}/gnome/help/glade $RPM_BUILD_ROOT%{_datadir}/gnome/help/%{helpdir}
99mv $RPM_BUILD_ROOT%{_datadir}/omf/glade $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
100pushd $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
101files=`ls *.omf`
102for omf in $files; do
103        mv $omf $omf.orig
104        sed "s|help/glade/|help/%{helpdir}/|g" $omf.orig > $omf
105        rm $omf.orig
106done
107popd
108     
109%find_lang glade
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post
115/sbin/ldconfig
116scrollkeeper-update -p /var/lib/scrollkeeper -o %{_datadir}/omf/%{helpdir}
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121
122%postun
123/sbin/ldconfig
124scrollkeeper-update > /dev/null 2>&1 || :
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
129
130%files -f glade.lang
131%defattr(-,root,root)
132%{_bindir}/glade
133%{_bindir}/glade-previewer
134%{_libdir}/libgladeui-2.so.*
135%{_libdir}/glade/modules/*.so
136%{_libdir}/girepository-1.0/Gladeui-2.0.typelib
137%{_datadir}/applications/glade.desktop
138%{_datadir}/glade
139%{_datadir}/gnome/help/%{helpdir}
140%{_datadir}/icons/hicolor/*/apps/glade.png
141%{_datadir}/omf/%{helpdir}
142
143%files  devel
144%defattr(-,root,root)
145%{_includedir}/libgladeui-2.0/gladeui/*
146%{_libdir}/pkgconfig/*.pc
147%{_libdir}/libgladeui-2.so
148%{_datadir}/gir-1.0/Gladeui-2.0.gir
149%{_datadir}/gtk-doc/html/gladeui-2
150
151%changelog
152* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
153- new upstream release
154
155* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
156- new upstream release
157- change BuildRequires: gtk3-devel instead of gtk2-devel
158- delete BuildRequires: libgnomeui-devel, libbonoboui-devel
159
160* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
161- rebuild with rpm-4.8.1 for pkg-config file
162- add BuildRequires: libSM-devel
163
164* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
165- add gnome-doc-utils to BR
166- comment out desktop-file-install
167
168* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
169- rebuild with gtk2-2.18.2
170
171* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
172- new upstream release
173- care ld and icon cache
174- define helpdir
175
176* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
177- new upstream release
178- spec in utf-8 (fixed)
179
180* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
181- spec in utf-8
182
183* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
184- new upstream release
185
186* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
187- new upstream version.
188
189* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
190- new upstream version.
191- update Requires.
192- update description.
193
194* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
195- use macro for release
196
197* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
198- apply new virsioning policy.
199- remove *.la
200
201* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
202- new upstream version
203- added Requires: devhelp
204- added Prereq: scrollkeeper
205- added disable-scrollkeeper to configure
206- added scrollkeeper-update in %%post and %%postun sections
207- changed gnome help directory temporarily
208
209* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
210- build for VineSeed
211
Note: See TracBrowser for help on using the repository browser.