source: projects/specs/trunk/g/glade3/glade3-vl.spec @ 11576

Revision 11576, 7.0 KB checked in by tomop, 6 years ago (diff)

glade3-3.20.3-1

Line 
1%define helpdir glade3
2
3Version: 3.20.3
4Release: 1%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.20/glade-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gnome-common
16BuildRequires: gtk3-devel >= 3.0.2
17BuildRequires: libxml2-devel >= 2.4.0
18BuildRequires: python-devel
19BuildRequires: pygobject3-devel
20BuildRequires: libSM-devel
21BuildRequires: yelp-tools
22BuildRequires: docbook-style-xsl
23
24Requires: gtk3 >= 3.0.2
25Requires: libxml2 >= 2.4.0
26Requires: pygobject3
27Requires: devhelp
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33Glade is a RAD tool to enable quick & easy development of user interfaces
34for the Gtk+ toolkit and the GNOME desktop environment.
35The user interfaces designed in Glade are stored in XML format,
36enabling easy integration with external tools.
37In particular libglade can load the XML files and create the interfaces
38at runtime. The DTD for the XML files is included with libglade, and is
39also at http://glade.gnome.org/glade-2.0.dtd.
40Other tools are available which can turn the XML files into source code
41in languages such as C++, Perl and Python.
42
43%description -l ja
44Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
45発する事が可能なRADツールです。
46Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
47フォーマットで保存されます。
48特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
49ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
50http://glade.gnome.org/glade-2.0.dtdにもあります。
51このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
52ルも利用可能です。
53
54%package devel
55Summary:        the Glade UI Builder core library
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58
59%description devel
60the Glade UI Builder core library to integrate Glade into your application
61and integrate your custom (GTK+ based) widget toolkit into the Glade
62UI Builder.
63
64%prep
65%setup -q -n glade-%{version}
66pushd src
67## change gnome help directory
68mv glade-window.c glade-window.c.orig
69sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
70        glade-window.c.orig > glade-window.c
71popd
72
73
74%build
75%configure --disable-static
76%__make %{_smp_mflags}
77
78
79%install
80rm -rf %{buildroot}
81make install DESTDIR=%{buildroot} appdatadir=%{_datadir}/appdata
82
83rm -rf %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
84rm -f %{buildroot}%{_libdir}/glade/modules/*.la
85rm -f %{buildroot}%{_libdir}/libgladeui-2.la
86
87%find_lang glade --all-name --with-gnome
88
89%clean
90rm -rf %{buildroot}
91
92%post
93/sbin/ldconfig
94touch --no-create %{_datadir}/icons/hicolor
95if [ -x /usr/bin/gtk-update-icon-cache ]; then
96  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
97fi
98
99%postun
100/sbin/ldconfig
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
104fi
105
106%files -f glade.lang
107%defattr(-,root,root)
108%{_bindir}/glade
109%{_bindir}/glade-previewer
110%{_libdir}/libgladeui-2.so.*
111%{_libdir}/glade/modules/*.so
112%{_libdir}/girepository-1.0/Gladeui-2.0.typelib
113%{_datadir}/appdata/glade.appdata.xml
114%{_datadir}/applications/glade.desktop
115%{_datadir}/glade
116%{_datadir}/icons/hicolor/*/apps/*
117%{_mandir}/man1/glade-previewer.1.gz
118%{_mandir}/man1/glade.1.gz
119
120%files  devel
121%defattr(-,root,root)
122%{_includedir}/libgladeui-2.0/gladeui/*
123%{_libdir}/pkgconfig/*.pc
124%{_libdir}/libgladeui-2.so
125%{_datadir}/gir-1.0/Gladeui-2.0.gir
126%{_datadir}/gtk-doc/html/gladeui-2
127
128%changelog
129* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.3-1
130- new upstream release.
131
132* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
133- new upstream release
134
135* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
136- new upstream release
137
138* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
139- new upstream release
140
141* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
142- new upstream release
143
144* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
145- new upstream release
146
147* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
148- new upstream release
149- add BuildRequires: docbook-style-xsl
150
151* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
152- new upstream release
153
154* Mon Oct 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
155- new upstream release
156- add BuildRequires: python-devel, pygobject3-devel
157
158* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
159- new upstream release
160- change BuildRequires: yelp-tools instead of gnome-doc-utils
161
162* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
163- new upstream release
164
165* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
166- new upstream release
167
168* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
169- new upstream release
170
171* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
172- new upstream release
173- change BuildRequires: gtk3-devel instead of gtk2-devel
174- delete BuildRequires: libgnomeui-devel, libbonoboui-devel
175
176* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
177- rebuild with rpm-4.8.1 for pkg-config file
178- add BuildRequires: libSM-devel
179
180* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
181- add gnome-doc-utils to BR
182- comment out desktop-file-install
183
184* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
185- rebuild with gtk2-2.18.2
186
187* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
188- new upstream release
189- care ld and icon cache
190- define helpdir
191
192* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
193- new upstream release
194- spec in utf-8 (fixed)
195
196* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
197- spec in utf-8
198
199* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
200- new upstream release
201
202* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
203- new upstream version.
204
205* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
206- new upstream version.
207- update Requires.
208- update description.
209
210* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
211- use macro for release
212
213* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
214- apply new virsioning policy.
215- remove *.la
216
217* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
218- new upstream version
219- added Requires: devhelp
220- added Prereq: scrollkeeper
221- added disable-scrollkeeper to configure
222- added scrollkeeper-update in %%post and %%postun sections
223- changed gnome help directory temporarily
224
225* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
226- build for VineSeed
227
Note: See TracBrowser for help on using the repository browser.