source: projects/specs/trunk/g/gl2ps/gl2ps-vl.spec @ 11738

Revision 11738, 7.0 KB checked in by ara_t, 6 years ago (diff)

gl2ps: update to 1.4.0

Line 
1%define pkg_name    gl2ps
2%define pkg_version 1.4.0
3%define pkg_release 1%{?_dist_release}
4
5Summary:           An OpenGL to PostScript printing library
6Summary(ja): OpenGL から PostScript を出力するライブラリ
7Summary(pl): Biblioteka drukowania z OpenGL-a do PostScriptu
8Name:        %{pkg_name}
9Version:     %{pkg_version}
10Release:     %{pkg_release}
11
12License: LGPLv2+ or GL2PS
13Group:   System Environment/Libraries
14URL:     http://www.geuz.org/gl2ps/
15
16Source0: http://www.geuz.org/gl2ps/src/%{name}-%{version}.tgz
17
18# # Vine Patch
19# Patch700:       gl2ps-1.3.8-nostatic.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: cmake >= 2.4
24BuildRequires: mesa-libGL-devel
25BuildRequires: libpng-devel
26BuildRequires: zlib-devel
27
28
29%description
30GL2PS is a C library providing high quality vector output for any
31OpenGL application. The main difference between GL2PS and other
32similar libraries is the use of sorting algorithms capable of handling
33intersecting and stretched polygons, as well as non manifold objects.
34GL2PS provides advanced smooth shading and text rendering, culling of
35invisible primitives, mixed vector/bitmap output, and much more...
36
37GL2PS can currently create PostScript (PS), Encapsulated PostScript
38(EPS) and Portable Document Format (PDF) files, as well as LaTeX files
39for the text fragments. Adding new vector output formats should be
40relatively easy (and amongst the formats we would be interested in
41adding, SVG is first in line). Meanwhile, you can use the excellent
42pstoedit program to transform the PostScript files generated by GL2PS
43into many other vector formats such as xfig, cgm, wmf, etc.
44
45%description -l ja
46GL2PSはOpenGLアプリケーションの高品質のベクトル出力を提供するCライブラリです。
47GL2PSは高度なスムーズなシェーディングとテキストのレンダリング、
48混在ベクター/ビットマップ出力、目に見えないプリミティブのカリングを提供して
49います。
50
51現在、PostScript (PS)、カプセル化PostScript (EPS)、ポータブルドキュメント
52フォーマット (PDF)、スケーラブルベクターグラフィックス (SVG) ファイルと
53LaTeXファイルを作成することができます。
54
55%description -l pl
56GL2PS to biblioteka C zapewniająca wysokiej jakości wyjście wektorowe
57dla dowolnej aplikacji OpenGL. Główna różnica między GL2PS a innymi
58podobnymi bibliotekami polega na użyciu algorytmów sortujących
59potrafiących obsłużyć przecinające się i rozciągnięte wielokąty, a
60także obiekty nie będące rozmaitościami. GL2PS zapewnia zaawansowane
61gładkie cieniowanie i renderowanie tekstu, usuwanie niewidocznych
62prymitywów, mieszane wyjście wektorowo-bitmapowe i wiele więcej.
63
64GL2PS aktualnie potrafi tworzyć pliki PostScript (PS), Encapsulated
65PostScript (EPS) oraz Portable Document Format (PDF), a także pliki
66LaTeXa dla fragmentów tekstowych. Dodanie nowych wyjściowych formatów
67wektorowych powinno być względnie łatwe (a spośród formatów, których
68dodanie zainteresowani byliby autorzy, pierwszym jest SVG). Tymczasem
69można używać świetnego programu pstoedit do przekształcania plików
70PostScript generowanych przez GL2PS na wiele innych formatów
71wektorowych, takich jak xfig, cgm, wmf itp.
72
73%package devel
74Summary:        Header files for GL2PS library
75Summary(ja): GL2PS ライブラリのヘッダファイル
76Summary(pl): Pliki nagłówkowe biblioteki GL2PS
77Group:    Development/Libraries
78Requires: %{name} = %{version}-%{release}
79Requires: mesa-libGL-devel
80
81%description devel
82Header files for GL2PS library.
83
84%description devel -l ja
85GL2PSのヘッダーファイル
86
87%description devel -l pl
88Pliki nagłówkowe biblioteki GL2PS.
89
90
91%prep
92%setup -q -n %{name}-%{version}-source
93# %patch700 -p1 -b .nostatic
94
95%build
96%cmake .
97%{__make} %{?_smp_mflags}
98
99%install
100%{__rm} -rf ${RPM_BUILD_ROOT}
101%{make_install}
102
103%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/libgl2ps.a
104%{__rm} -rf ${RPM_BUILD_ROOT}%{_docdir}/gl2ps
105
106%clean
107%{__rm} -rf ${RPM_BUILD_ROOT}
108
109%post -p %{_syssbindir}/ldconfig
110%postun -p %{_syssbindir}/ldconfig
111
112
113%files
114%defattr(644,root,root,755)
115%doc COPYING.GL2PS COPYING.LGPL README.txt gl2psTest*.c
116%attr(755,root,root) %{_libdir}/libgl2ps.so.*
117
118%files devel
119%defattr(644,root,root,755)
120%doc gl2ps.pdf gl2psTest*.c
121%{_libdir}/libgl2ps.so
122%{_includedir}/gl2ps.h
123
124
125%changelog
126* Sat Jul 07 2018 Toshiaki Ara <ara_t@384.jp> 1.4.0-1
127- update to 1.4.0
128- delete BuildRequires: texlive
129
130* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-3
131- merge with previous SPEC file
132
133* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-2
134- correct SPEC file
135
136* Fri Mar 18 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-1
137- update to 1.3.9
138
139* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.8-6
140- Initial build for Vine Linux
141- added Patch700
142
143* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-5
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
145
146* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-4
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
148
149* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-3
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
151
152* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-2
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
154
155* Tue Nov 27 2012 Orion Poplawski <orion@cora.nwra.com> 1.3.8-1
156- Updated to 1.3.8
157- Dropped soversion patch applied upstream
158- Don't need to move library on 64bit anymore
159
160* Sat Sep 01 2012 Dominik Mierzejewski <rpm@greysector.net> 1.3.6-1
161- updated to 1.3.6
162
163* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-5
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
165
166* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-4
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
168
169* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1.3.5-3
170- Rebuild for new libpng
171
172* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-2
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
174
175* Sat Dec 26 2009 Dominik Mierzejewski <rpm@greysector.net> 1.3.5-1
176- updated to 1.3.5
177- dropped upstreamed patches
178- fixed install in libdir
179- fixed missing SO version
180
181* Sun Aug 23 2009 Dominik Mierzejewski <rpm@greysector.net> 1.3.3-1
182- updated to 1.3.3
183- removed calls to exit(3)
184- added a simple build system (Makefile)
185- dropped libtool dependency
186- 1.3.3 added a new symbol, so made it versioned
187- added examples to -devel docs
188
189* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-3
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
191
192* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
194
195* Fri Jun 13 2008 Dominik Mierzejewski <rpm@greysector.net> 1.3.2-1
196- adapted PLD spec r1.2
197- dropped static package
Note: See TracBrowser for help on using the repository browser.