source: projects/specs/trunk/g/gkrellm/gkrellm-vl.spec @ 521

Revision 521, 6.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Multiple stacked system monitors: 1 process.
2Name:           gkrellm
3Version:        2.3.2
4Release:        1%{?_dist_release}
5License:        GPL
6Group:          Applications/System
7URL:            http://members.dslextreme.com/users/billw/gkrellm/gkrellm.html
8Source:         http://members.dslextreme.com/users/billw/gkrellm/%{name}-%{version}.tar.bz2
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12# styles for vine.
13Source1:        HW-Vine2.tar.bz2
14Patch0:         gkrellm-2.3.2.ja.po.patch
15Requires:       gtk2 >= 2.4, glib2 >= 2.0
16BuildRequires:  gtk2-devel >= 2.4, glib2-devel >= 2.0, gettext
17BuildRequires:  ImageMagick, bzip2
18%if %{?_dist_release} == "vl5"
19BuildRequires:  xorg-x11-devel
20%endif
21%if %{?_dist_release} == "vl4"
22BuildRequires:  XOrg-devel
23%endif
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26%description
27GKrellM charts SMP CPU, load, Disk, and all active net interfaces
28automatically. An on/off button and online timer for the PPP interface
29is provided. Monitors for memory and swap usage, file system, internet
30connections, APM laptop battery, mbox style mailboxes, and cpu temps.
31Also includes an uptime monitor, a hostname label, and a clock/calendar.
32Additional features are:
33
34  * Autoscaling grid lines with configurable grid line resolution.
35  * LED indicators for the net interfaces.
36  * A gui popup for configuration of chart sizes and resolutions.
37
38%description -l ja
39Gkrellm は、
40・SMP CPU、負荷、Disk、およびすべてのアクティブなネットインターフェース
41  のチャート表示。
42・PPP インターフェィスの on/off ボタンとオンラインタイマーの提供。
43・メモリ/swap の使用量、ファイルシステム、インターネット接続、
44  APM ラップトップバッテリー、mbox 形式メールボックス、cpu 温度の監視。
45・稼働時間、ホスト名、よび時計/カレンダーの表示。
46などを行います。
47付加機能は以下の通り:
48* 設定可能なグリッドラインの精度の自動調整。
49* ネットワークインターフェィスの LED インジケータ。
50* チャートのサイズと解像度設定の為のポップアップダイアログ。
51
52%prep
53rm -rf $RPM_BUILD_ROOT
54%setup -q
55%__tar jxf  %{SOURCE1}
56%patch0 -p1
57
58%build
59
60%__make \
61    CFLAGS="$RPM_OPT_FLAGS" \
62    SMC_LIBS="-L/usr/X11R6/%{_lib} -lSM -lICE" \
63    LOCALEDIR=%{_localedir} \
64    INCLUDEDIR=%{_includedir}
65
66%install
67%__rm -rf %{buildroot}
68%__mkdir -p %{buildroot}%{_bindir}
69%__mkdir -p %{buildroot}%{_mandir}/man1
70%__mkdir -p %{buildroot}%{_libdir}/pkgconfig 
71%__mkdir -p %{buildroot}%{_includedir}/gkrellm2
72%__mkdir -p %{buildroot}%{_libdir}/gkrellm2/plugins
73%__mkdir -p %{buildroot}%{_datadir}/gkrellm2
74%__mkdir -p %{buildroot}%{_datadir}/gkrellm2/themes
75
76make install \
77    INSTALLROOT=%{buildroot}%{_prefix} \
78    PKGCONFIGDIR=%{buildroot}%{_libdir}/pkgconfig \
79    LOCALEDIR=%{buildroot}%{_datadir}/locale \
80    MANDIR=%{buildroot}%{_mandir}/man1 \
81    INCLUDEDIR=%{buildroot}%{_includedir}
82
83%ifarch x86_64
84# convert program terminate with segmentation fault: fix me!
85convert gkrellm.ico gkrellm.png || [ -f gkrellm-0.png ]
86%else
87convert gkrellm.ico gkrellm.png
88%endif
89
90for i in gkrellm-*.png
91do
92%__install -D -p -m 644 $i \
93    %{buildroot}%{_datadir}/pixmaps/$i
94done
95pushd %{buildroot}%{_datadir}/pixmaps
96ln -s gkrellm-0.png gkrellm.png
97popd
98#    %{buildroot}%{_datadir}/pixmaps/gkrellm.png
99
100%__cp -a HW-Vine2 \
101    %{buildroot}%{_datadir}/gkrellm2/themes/
102
103# Install desktop menu entry
104%__mkdir -p %{buildroot}%{_datadir}/applications
105%__cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
106[Desktop Entry]
107Name=Gkrellm
108Name[ja]=Gkrellm
109Comment=GNU Krellm monitor
110Comment[ja]=GNU Krell モニタ
111Exec=gkrellm -w
112Icon=/usr/share/pixmaps/gkrellm-3.png
113Terminal=false
114Type=Application
115Categories=GTK;System;Monitor;
116EOF
117
118%clean
119%__rm -rf %{buildroot}
120
121%files
122%defattr(-,root,root)
123%doc COPYRIGHT Changelog README Themes.html
124%doc INSTALL
125%{_bindir}/*
126%{_mandir}/man1/*
127%dir %{_includedir}/gkrellm2
128%{_includedir}/gkrellm2/*
129%{_libdir}/pkgconfig/gkrellm.pc
130%{_datadir}/locale/*/LC_MESSAGES/gkrellm.mo
131%{_datadir}/pixmaps/*
132%{_datadir}/gkrellm2
133%{_datadir}/applications/%{name}.desktop
134%{_libdir}/gkrellm2
135
136%changelog
137* Fri Jul 17 2009 KATO Masashi <mkato@par.odn.ne.jp> 2.3.2-1
138- new upstream release
139- added desktop entry
140
141* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3.1-2
142- rebuilt with gnutls-2.6.x
143
144* Tue Aug 26 2008 KATO Masashi <mkato@par.odn.ne.jp> 2.3.1-1
145- applied new versioning policy
146- rebuilt with xorg-x11 7.3
147- spec in UTF-8
148- added "%description -l ja" section to spec file
149
150* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 2.3.1-0vl3
151- added option SMC_LIBS in make
152- added option PKGCONFIGDIR in make install
153- added adhoc convert script because segmentation fault occurred (for x86_64)
154
155* Wed Dec 19 2007 KATO Masashi <mkato@par.odn.ne.jp> 2.3.1-0vl1, 2
156- new upstream release
157
158* Sun Jun 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl2
159- rebuilt with new toolchain
160
161* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl1
162- new upstream release
163- s/Copyright/License/
164- updated URL
165
166* Mon Jun 28 2004 KATO Masashi <mkato@par.odn.ne.jp> 2.2.1-0vl1
167- new upstream release
168- add HW-Vine theme(test theme for gkrellm2)
169
170* Sun Jan 13 2002 Tomoya TAKA <taka@vinelinux.org> 1.2.8-0vl1
171- update to 1.2.8
172
173* Thu Aug 23 2001 Toru Sagami <sagami@vinelinux.org>
174- 1.2.2-0vl1
175
176* Thu Aug 02 2001 <sagami@vinelinux.org>
177- 1.2.1-0vl1: added more/less docs
178
179* Sun Jul 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
180- 1.0.8-0vl2
181- add %%defattr(-,root,root) in %files section
182- add %%{_libdir}/%{name}/plugins and %%{_datadir}/%{name}/themes
183  as system wide plugin and theme directories
184
185* Thu Jul 19 2001 <sagami@vinelinux.org>
186- 1.0.8-0vl1: enabled nls
187
188* Fri Oct  6 2000 Jun Nishii <jun@vinelinux.org>
189- 0.10.5-0vl1
190
191* Thu Apr 6 2000 Bill Wilson
192- added INCLUDEDIR to the make install
193
194* Fri Oct 29 1999 Gary Thomas <gdt@linuxppc.org>
195- .spec file still broken
196
197* Thu Oct 7 1999 David Mihm <davemann@ionet.net>
198- fixed spec.
Note: See TracBrowser for help on using the repository browser.