source: projects/specs/trunk/g/gkrellm/gkrellm-vl.spec @ 8066

Revision 8066, 6.5 KB checked in by tanakanata, 10 years ago (diff)

rebuild with gcc-2.4x

Line 
1Summary:        Multiple stacked system monitors: 1 process.
2Summary(ja):    縦積み型マルチシステムモニタ: 1 プロセス
3Name:           gkrellm
4Version:        2.3.5
5Release:        3%{?_dist_release}
6License:        GPL
7Group:          Applications/System
8URL:            http://members.dslextreme.com/users/billw/gkrellm/gkrellm.html
9Source:         http://members.dslextreme.com/users/billw/gkrellm/%{name}-%{version}.tar.bz2
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13# styles for vine.
14Source1:        HW-Vine2.tar.bz2
15Source2:        gkrellm-vine.svg
16Patch0:         gkrellm-%{version}.ja.po.patch
17Requires:       gtk2 >= 2.4, glib2 >= 2.0
18BuildRequires:  gtk2-devel >= 2.4, glib2-devel >= 2.0, gettext
19BuildRequires:  ImageMagick, bzip2
20BuildRequires:  xorg-x11-devel
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23%description
24GKrellM charts SMP CPU, load, Disk, and all active net interfaces
25automatically. An on/off button and online timer for the PPP interface
26is provided. Monitors for memory and swap usage, file system, internet
27connections, APM laptop battery, mbox style mailboxes, and cpu temps.
28Also includes an uptime monitor, a hostname label, and a clock/calendar.
29Additional features are:
30
31  * Autoscaling grid lines with configurable grid line resolution.
32  * LED indicators for the net interfaces.
33  * A gui popup for configuration of chart sizes and resolutions.
34
35%description -l ja
36Gkrellm は、
37* SMP CPU、負荷、Disk、およびすべてのアクティブなネットインターフェース
38  のチャート表示。
39* PPP インターフェィスの on/off ボタンとオンラインタイマーの提供。
40* メモリ/swap の使用量、ファイルシステム、インターネット接続、
41  APM ラップトップバッテリー、mbox 形式メールボックス、cpu 温度の監視。
42* 稼働時間、ホスト名、よび時計/カレンダーの表示。
43などを行います。
44付加機能は以下の通り:
45* 設定可能なグリッドラインの精度の自動調整。
46* ネットワークインターフェィスの LED インジケータ。
47* チャートのサイズと解像度設定の為のポップアップダイアログ。
48
49%prep
50rm -rf $RPM_BUILD_ROOT
51%setup -q
52%__tar jxf  %{SOURCE1}
53%patch0 -p1
54
55%build
56for i in gkrellmd.1 gkrellm.1 README Changelog Changelog-plugins.html \
57    src/gkrellm.h server/gkrellmd.h; do
58   sed -i -e "s@/usr/lib/gkrellm2*/plugins@%{_libdir}/gkrellm2/plugins@" $i
59   sed -i -e "s@/usr/local/lib/gkrellm2*/plugins@/usr/local/%{_lib}/gkrellm2/plugins@" $i
60done
61
62%__make \
63    CFLAGS="$RPM_OPT_FLAGS" \
64    SMC_LIBS="-L/usr/X11R6/%{_lib} -lSM -lICE" \
65    LOCALEDIR=%{_localedir} \
66    INCLUDEDIR=%{_includedir} \
67    LDFLAGS="$(pkg-config --libs gmodule-2.0) $RPM_LD_FLAGS"
68
69%install
70%__rm -rf %{buildroot}
71%__mkdir -p %{buildroot}%{_bindir}
72%__mkdir -p %{buildroot}%{_mandir}/man1
73%__mkdir -p %{buildroot}%{_libdir}/pkgconfig 
74%__mkdir -p %{buildroot}%{_includedir}/gkrellm2
75%__mkdir -p %{buildroot}%{_libdir}/gkrellm2/plugins
76%__mkdir -p %{buildroot}%{_datadir}/gkrellm2
77%__mkdir -p %{buildroot}%{_datadir}/gkrellm2/themes
78
79make install \
80    INSTALLROOT=%{buildroot}%{_prefix} \
81    PKGCONFIGDIR=%{buildroot}%{_libdir}/pkgconfig \
82    LOCALEDIR=%{buildroot}%{_datadir}/locale \
83    MANDIR=%{buildroot}%{_mandir}/man1 \
84    INCLUDEDIR=%{buildroot}%{_includedir}
85
86%__cp -a HW-Vine2 \
87    %{buildroot}%{_datadir}/gkrellm2/themes/
88
89# icons
90%__mkdir_p %{buildroot}%{_datadir}/pixmaps
91%__cp -a %{_sourcedir}/gkrellm-vine.svg %{buildroot}%{_datadir}/pixmaps
92
93# Install desktop menu entry
94%__mkdir -p %{buildroot}%{_datadir}/applications
95%__cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
96[Desktop Entry]
97Name=Gkrellm
98Name[ja]=Gkrellm
99Comment=GNU Krellm monitor
100Comment[ja]=GNU Krell モニタ
101Exec=gkrellm -w
102Icon=/usr/share/pixmaps/gkrellm-vine.svg
103Terminal=false
104Type=Application
105Categories=GTK;System;Monitor;
106EOF
107
108%clean
109%__rm -rf %{buildroot}
110
111%files
112%defattr(-,root,root)
113%doc COPYRIGHT Changelog README Themes.html
114%doc INSTALL
115%{_bindir}/*
116%{_mandir}/man1/*
117%dir %{_includedir}/gkrellm2
118%{_includedir}/gkrellm2/*
119%{_libdir}/pkgconfig/gkrellm.pc
120%{_datadir}/locale/*/LC_MESSAGES/gkrellm.mo
121%{_datadir}/pixmaps/gkrellm-vine.svg
122%{_datadir}/gkrellm2
123%{_datadir}/applications/%{name}.desktop
124%{_libdir}/gkrellm2
125
126%changelog
127* Fri Dec 27 2013 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 2.3.5-3
128- rebuild with gcc-4.8
129
130* Sun Apr 21 2013 TANAKA hiroaki<mosaicist@jcom.home.ne.jp>2.3.5-2
131- add icon.svg
132- explicitly link against gmodule-2.0 to fix building with current glib
133
134* Sat May 28 2011 TANAKA hiroaki<mosaicist@par.odn.ne.jp> 2.3.5
135- new upstream release
136- fix Patch0 for gkrellm-2.3.5
137
138* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.4-1
139- new upstream release
140- fix Patch0 for gkrellm-2.3.4
141
142* Fri Jul 17 2009 KATO Masashi <mkato@par.odn.ne.jp> 2.3.2-1
143- new upstream release
144- added desktop entry
145
146* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3.1-2
147- rebuilt with gnutls-2.6.x
148
149* Tue Aug 26 2008 KATO Masashi <mkato@par.odn.ne.jp> 2.3.1-1
150- applied new versioning policy
151- rebuilt with xorg-x11 7.3
152- spec in UTF-8
153- added "%description -l ja" section to spec file
154
155* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 2.3.1-0vl3
156- added option SMC_LIBS in make
157- added option PKGCONFIGDIR in make install
158- added adhoc convert script because segmentation fault occurred (for x86_64)
159
160* Wed Dec 19 2007 KATO Masashi <mkato@par.odn.ne.jp> 2.3.1-0vl1, 2
161- new upstream release
162
163* Sun Jun 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl2
164- rebuilt with new toolchain
165
166* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl1
167- new upstream release
168- s/Copyright/License/
169- updated URL
170
171* Mon Jun 28 2004 KATO Masashi <mkato@par.odn.ne.jp> 2.2.1-0vl1
172- new upstream release
173- add HW-Vine theme(test theme for gkrellm2)
174
175* Sun Jan 13 2002 Tomoya TAKA <taka@vinelinux.org> 1.2.8-0vl1
176- update to 1.2.8
177
178* Thu Aug 23 2001 Toru Sagami <sagami@vinelinux.org>
179- 1.2.2-0vl1
180
181* Thu Aug 02 2001 <sagami@vinelinux.org>
182- 1.2.1-0vl1: added more/less docs
183
184* Sun Jul 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
185- 1.0.8-0vl2
186- add %%defattr(-,root,root) in %files section
187- add %%{_libdir}/%{name}/plugins and %%{_datadir}/%{name}/themes
188  as system wide plugin and theme directories
189
190* Thu Jul 19 2001 <sagami@vinelinux.org>
191- 1.0.8-0vl1: enabled nls
192
193* Fri Oct  6 2000 Jun Nishii <jun@vinelinux.org>
194- 0.10.5-0vl1
195
196* Thu Apr 6 2000 Bill Wilson
197- added INCLUDEDIR to the make install
198
199* Fri Oct 29 1999 Gary Thomas <gdt@linuxppc.org>
200- .spec file still broken
201
202* Thu Oct 7 1999 David Mihm <davemann@ionet.net>
203- fixed spec.
Note: See TracBrowser for help on using the repository browser.