source: projects/specs/trunk/g/gitolite/gitolite-vl.spec @ 7555

Revision 7555, 3.9 KB checked in by daisuke, 11 years ago (diff)

gitolite: update to 3.4

Line 
1%global gitolite_homedir %{_var}/lib/%{name}
2
3Name:           gitolite
4Version:        3.4
5Release:        1%{?_dist_release}
6Summary:        Highly flexible git server
7Summary(ja):    柔軟性の高い Git サーバ
8Group:          Applications/System
9License:        GPLv2 and CC-BY-SA
10URL:            http://github.com/sitaramc/gitolite
11Source0:        %{name}-%{version}.tar.gz
12Source1:        gitolite-README-vine
13
14BuildArch:      noarch
15Provides:       perl(%{name}) = %{version}-%{release}
16Provides:       gitolite3 = %{version}
17Requires:       git
18Requires:       openssh-clients
19Requires:       perl(:MODULE_COMPAT_%(eval $(%{__perl} -V:version); echo $version))
20Requires(pre):  shadow-utils
21Requires:       subversion
22
23%description
24Gitolite allows a server to host many git repositories and provide access
25to many developers, without having to give them real userids on the server.
26The essential magic in doing this is ssh's pubkey access and the authorized
27keys file, and the inspiration was an older program called gitosis.
28
29Gitolite can restrict who can read from (clone/fetch) or write to (push) a
30repository. It can also restrict who can push to what branch or tag, which
31is very important in a corporate environment. Gitolite can be installed
32without requiring root permissions, and with no additional software than git
33itself and perl. It also has several other neat features described below and
34elsewhere in the doc/ directory.
35
36
37%prep
38%setup -q
39cp %{SOURCE1} .
40
41#%patch0 -p1
42
43%build
44#This page intentionally left blank.
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49# Directory structure
50install -d $RPM_BUILD_ROOT%{gitolite_homedir}
51install -d $RPM_BUILD_ROOT%{gitolite_homedir}/.ssh
52install -d $RPM_BUILD_ROOT%{_bindir}
53install -d $RPM_BUILD_ROOT%{perl_vendorlib}
54install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
55
56# Code
57cp -pr src/lib/Gitolite $RPM_BUILD_ROOT%{perl_vendorlib}
58echo "%{version}-%{release}" >src/VERSION
59cp -a src/* $RPM_BUILD_ROOT%{_datadir}/%{name}
60ln -s %{_datadir}/%{name}/gitolite $RPM_BUILD_ROOT%{_bindir}/gitolite
61
62# empty authorized_keys file
63touch $RPM_BUILD_ROOT%{gitolite_homedir}/.ssh/authorized_keys
64
65
66%pre
67getent group %{name} >/dev/null || groupadd -r %{name}
68getent passwd %{name} >/dev/null || \
69useradd -r -g %{name} -d %{gitolite_homedir} -s /bin/sh \
70        -c "git repository hosting" %{name}
71exit 0
72
73
74%files
75%{_bindir}/*
76%{perl_vendorlib}/*
77%{_datadir}/%{name}
78# make homedir non world readable
79%attr(750,%{name},%{name}) %dir %{gitolite_homedir}
80%attr(750,%{name},%{name}) %dir %{gitolite_homedir}/.ssh
81%config(noreplace) %attr(640,%{name},%{name}) %{gitolite_homedir}/.ssh/authorized_keys
82%doc gitolite3-README-fedora COPYING README.txt CHANGELOG
83
84
85%changelog
86* Thu Mar 14 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4-1
87- update to 3.4
88
89* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
90- initial build for Vine Linux
91
92* Wed Oct 10 2012 Jon Ciesla <limburgher@gmail.com> - 1:3.1-1
93- 3.1, rewuiring Epoch bump.
94
95* Tue Oct 09 2012 Jon Ciesla <limburgher@gmail.com> - 3.04-4
96- Patch for directory traversal bug.
97
98* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.04-3
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
100
101* Thu Jun 28 2012 Petr Pisar <ppisar@redhat.com> - 3.04-2
102- Perl 5.16 rebuild
103
104* Wed Jun 27 2012 Jon Ciesla <limburgher@gmail.com> - 3.04-1
105- Latest upstream, docs now includable.
106
107* Thu Jun 07 2012 Petr Pisar <ppisar@redhat.com> - 3.03-3
108- Perl 5.16 rebuild
109
110* Thu Jun 07 2012 Petr Pisar <ppisar@redhat.com> - 3.03-2
111- Perl 5.16 rebuild
112
113* Wed May 23 2012 Jon Ciesla <limburgher@gmail.com> - 3.03-1
114- Latest upstream.
115
116* Mon May 21 2012 Jon Ciesla <limburgher@gmail.com> - 3.02-1
117- Latest upstream.
118
119* Tue May 15 2012 Jon Ciesla <limburgher@gmail.com> - 3.01-2
120- Added license file, fixed duplicate files, dropped defattr.
121- Dropped clean and buildroot.
122- Added script to generate tarball in comments.
123
124* Thu May 03 2012 Jon Ciesla <limburgher@gmail.com> - 3.01-1
125- Initial packaging based on gitolite 2.3-2.
Note: See TracBrowser for help on using the repository browser.