source: projects/specs/trunk/g/gitflow/gitflow-vl.spec @ 7358

Revision 7358, 2.9 KB checked in by iwaim, 11 years ago (diff)

gitflow-4.2.0-1.pre20120723git53e9c76

Line 
1%global githash 53e9c76
2%global gitdate 20120723
3%global checkout %{gitdate}git%{githash}
4
5%define ver 4.2.0
6%define rel 1.pre%{checkout}
7
8Name:       gitflow
9Version:    %{ver}
10Release:    %{rel}%{?_dist_release}
11Summary:    Extensions providing operations for V. Driessen's branching model
12
13Group:      Development/Tools
14License:    BSD
15URL:        https://github.com/nvie/gitflow
16# You can get this tarball by cloning the repository from github and checking
17# out revision %%{githash}
18Source0:    gitflow-0.4.2.%{checkout}.tar.gz
19# There is no upstream ticket for this patch, but instead just hardcodes the
20# directory we're installing to for Fedora.
21Patch0:     gitflow-Appropriate-GITFLOW_DIR.patch
22
23BuildArch:  noarch
24
25Requires:       shflags
26Requires:       git
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: iwaim
31
32%description
33A collection of Git extensions to provide high-level repository operations
34for Vincent Driessen's [branching model](http://nvie.com/git-model "original
35blog post").
36
37For the best introduction to get started with `git flow`, please read Jeff
38Kreeftmeijer's blog post:
39
40  http://jeffkreeftmeijer.com/2010/why-arent-you-using-git-flow/
41
42Or have a look at one of these screen casts:
43
44* [A short introduction to git-flow]
45  (http://vimeo.com/16018419) (by Mark Derricutt)
46* [On the path with git-flow]
47  (http://codesherpas.com/screencasts/on_the_path_gitflow.mov) (by Dave Bock)
48
49%prep
50%setup -q -n %{name}
51%patch0 -p1 -b .gitflowdir
52
53%build
54# This section is empty because this package ccontains shell scripts
55# to be sourced: there's nothing to build
56
57%install
58mkdir -p %{buildroot}/%{_bindir}
59install -v -m 0755 git-flow %{buildroot}/%{_bindir}
60
61mkdir -p %{buildroot}/%{_datadir}/%{name}
62install -v -m 0644 git-flow-init %{buildroot}/%{_datadir}/%{name}
63install -v -m 0644 git-flow-feature %{buildroot}/%{_datadir}/%{name}
64install -v -m 0644 git-flow-hotfix %{buildroot}/%{_datadir}/%{name}
65install -v -m 0644 git-flow-release %{buildroot}/%{_datadir}/%{name}
66install -v -m 0644 git-flow-support %{buildroot}/%{_datadir}/%{name}
67install -v -m 0644 git-flow-version %{buildroot}/%{_datadir}/%{name}
68install -v -m 0644 gitflow-common %{buildroot}/%{_datadir}/%{name}
69
70ln -s %{_datadir}/shflags/shflags %{buildroot}/%{_datadir}/%{name}/gitflow-shFlags
71
72%files
73%doc README.mdown LICENSE AUTHORS Changes.mdown
74%{_bindir}/git-flow*
75%{_datadir}/%{name}
76
77%changelog
78* Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 4.2.0-1.pre20120723git53e9c76
79- initial build for Vine Linux
80
81* Mon Jul 23 2012 Ralph Bean <rbean@redhat.com> - 0.4.2.20120723git53e9c76-1
82- New checkout from upstream git for review process.
83
84* Mon Jul 23 2012 Ralph Bean <rbean@redhat.com> - 0.4.2.20120626gitab7fda2-2
85- Changed License field to BSD
86- Dropped requirement on util-linux.
87- Added comments for Source0 and Patch0
88- Using macro for %%{gitdate} as well as %%{githash}
89
90* Tue Jun 26 2012 Ralph Bean <rbean@redhat.com> - 0.4.2.20120626gitab7fda2-1
91- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.