source: projects/specs/trunk/g/giggle/giggle-vl.spec @ 5043

Revision 5043, 5.4 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1Name:          giggle
2Version:       0.6.1
3Release:       1%{?_dist_release}
4Summary:       A Gtk frontend to git
5
6Group:         Development/Tools
7License:       GPLv2+
8URL:           http://live.gnome.org/giggle
9
10Source0:       http://ftp.gnome.org/pub/GNOME/sources/giggle/0.6/%{name}-%{version}.tar.xz
11
12BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildRequires: intltool
15BuildRequires: gettext
16BuildRequires: gtksourceview3-devel
17BuildRequires: glib2-devel
18BuildRequires: gtk3-devel
19BuildRequires: desktop-file-utils
20BuildRequires: git-core
21BuildRequires: evolution-data-server-devel
22BuildRequires: vte3-devel
23BuildRequires: yelp-tools
24BuildRequires: gnome-common
25BuildRequires: libtool autoconf automake
26
27Requires:      git
28
29
30%description
31Giggle is a graphical frontend for the git directory tracker (think of gitk on
32GTK+).
33
34%package devel
35Summary:        Headers for Giggle plugin development
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38
39%description devel
40Headers for developing plugins for Giggle.
41
42%prep
43%setup -q
44
45%build
46libtoolize
47aclocal
48autoconf
49autoheader
50automake
51%configure --disable-static
52sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
53sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
54make %{?_smp_mflags}
55
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install DESTDIR=$RPM_BUILD_ROOT
60find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
61
62desktop-file-install --vendor="fedora"                     \
63  --delete-original                                        \
64  --dir=%{buildroot}%{_datadir}/applications               \
65  %{buildroot}%{_datadir}/applications/giggle.desktop
66
67%find_lang %{name}
68
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73
74%post
75/sbin/ldconfig
76touch --no-create %{_datadir}/icons/hicolor
77if [ -x %{_bindir}/gtk-update-icon-cache ]; then
78  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
79fi
80
81%postun
82/sbin/ldconfig
83touch --no-create %{_datadir}/icons/hicolor
84if [ -x %{_bindir}/gtk-update-icon-cache ]; then
85  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
86fi
87
88
89%files -f %{name}.lang
90%defattr(-,root,root,-)
91%doc AUTHORS COPYING README
92
93%{_bindir}/giggle
94%{_libdir}/*.so.*
95%{_libdir}/giggle/plugins/%{version}/*.so*
96%{_libdir}/giggle/plugins/%{version}/*.xml
97
98%dir %{_datadir}/giggle
99%dir %{_datadir}/giggle/glade
100
101%{_datadir}/giggle/glade/main-window.ui
102%{_datadir}/applications/fedora-giggle.desktop
103
104%{_datadir}/icons/hicolor/16x16/apps/*.png
105%{_datadir}/icons/hicolor/22x22/apps/*.png
106%{_datadir}/icons/hicolor/24x24/apps/*.png
107%{_datadir}/icons/hicolor/32x32/apps/*.png
108%{_datadir}/icons/hicolor/48x48/apps/*.png
109%{_datadir}/icons/hicolor/scalable/apps/*.svg
110
111%{_datadir}/help
112
113%files devel
114%defattr(-,root,root,-)
115%{_includedir}/giggle/
116%{_libdir}/*.so
117
118%changelog
119* Tue Oct 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.1-1
120- new upstream release
121
122* Sun Oct 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6-1
123- new upstream release
124
125* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-4
126- rebuild with evolution-data-server-3.1.90
127
128* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-3
129- rebuild with evolution-data-server-3.1.4
130
131* Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
132- initial build for Vine Linux
133
134
135* Mon Jun 26 2010 Caolán McNamara <caolanm@redhat.com> 0.5-3
136- bump for dependencies
137
138* Fri Jun 11 2010 Mike McGrath <mmcgrath@redhat.com> 0.5-2
139- Release bump for rebuild to fix broken libedataserver dep
140
141* Wed May 05 2010 James Bowes <jbowes@redhat.com> 0.5-1
142- Update to 0.5
143
144* Fri Feb 12 2010 Tomas Bzatek <tbzatek@redhat.com> - 0.4.96-1
145- Update to 0.4.96
146
147* Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.4.91-3
148- Use bzipped upstream tarball.
149
150* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.91-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Fri Apr 10 2009 Lennart Poettering <lpoetter@redhat.com> - 0.4.91-1
154- Update to 0.4.91
155
156* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.90-3
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
158
159* Fri Feb 13 2009 Lennart Poettering <lpoetter@redhat.com> - 0.4.90-2
160- Add missing dep
161
162* Fri Feb 13 2009 Lennart Poettering <lpoetter@redhat.com> - 0.4.90-1
163- Update to 0.4.90
164
165* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4-2
166- Autorebuild for GCC 4.3
167
168* Wed Dec 12 2007 James Bowes <jbowes@redhat.com> - 0.4-1
169- Update to 0.4
170
171* Sun Oct 14 2007 James Bowes <jbowes@redhat.com> 0.3-5
172- Update gtksourceview2 patch to build against current code.
173
174* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> - 0.3-4
175- Add BR for gtksourceview2-devel
176
177* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> - 0.3-3
178- Mark license as GPLv2+
179
180* Fri Jul  6 2007 Jeremy Katz <katzj@redhat.com> - 0.3-2
181- fix to build against gtksourceview2
182
183* Wed May 09 2007 James Bowes <jbowes@redhat.com> - 0.3-1
184- Update to 0.3
185
186* Thu Mar 29 2007 James Bowes <jbowes@redhat.com> - 0.2-2
187- Add buildrequires for git-core
188
189* Thu Mar 29 2007 James Bowes <jbowes@redhat.com> - 0.2-1
190- Update to 0.2
191
192* Sat Mar 17 2007 James Bowes <jbowes@redhat.com> - 0.1-3
193- Minor specfile fixes from the initial review.
194
195* Fri Mar 09 2007 James Bowes <jbowes@redhat.com> - 0.1-2
196- Use desktop-file-install for the desktop file.
197
198* Wed Mar 07 2007 James Bowes <jbowes@redhat.com> - 0.1-1
199- Initial packaging.
Note: See TracBrowser for help on using the repository browser.