source: projects/specs/trunk/g/giflib4/giflib4-vl.spec @ 12204

Revision 12204, 7.8 KB checked in by tomop, 5 years ago (diff)

for backward compatibility

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:     A library for manipulating GIF format image files.
4Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
5Name: giflib4
6Version: 4.2.3
7Release: 2%{_dist_release}
8License: MIT
9URL: http://sourceforge.net/projects/giflib/
10Source: http://jaist.dl.sourceforge.net/sourceforge/giflib/giflib-%{version}.tar.bz2
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Vendor: Project Vine
14Distribution: Vine Linux
15
16Obsoletes: libungif < 4.1.6-1
17Provides:  libungif = %{version}-%{release}
18
19
20%description
21The giflib package contains a shared library of functions for
22loading and saving GIF format image files. It is API and ABI compatible
23with libungif, the library which supported uncompressed GIFs while the
24Unisys LZW patent was in effect.
25
26Install the giflib package if you need to write programs that use GIF files.
27You should also install the giflib-utils package if you need some simple
28utilities to manipulate GIFs.
29
30%description -l ja
31giflib パッケージには GIF 形式の画像ファイルを読み書きするために必要な
32共有ライブラリが収録されています。この giflib は、Unisys LZW 特許が有効で
33あった時期に、非圧縮形式の GIF ファイルを扱うために使われていたライブラリで
34ある libungif と API / ABI 互換性があります。
35
36GIF ファイルを扱うプログラムを作成される場合は giflib パッケージを
37インストールして下さい。また、GIF ファイルを操作する簡単なユーティリティが
38必要な場合には giflib-utils パッケージも一緒にインストールする必要があります。
39
40
41
42## to build compat32 for x86_64 architecture support
43%package -n compat32-%{name}
44Summary:     A library for manipulating GIF format image files.
45Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
46Group: System Environment/Libraries
47Obsoletes: compat32-libungif <= %{version}-%{release}
48Provides: compat32-libungif = %{version}-%{release}
49
50%description -n compat32-%{name}
51The giflib package contains a shared library of functions for
52loading and saving GIF format image files. It is API and ABI compatible
53with libungif, the library which supported uncompressed GIFs while the
54Unisys LZW patent was in effect.
55
56Install the giflib package if you need to write programs that use GIF files.
57You should also install the giflib-utils package if you need some simple
58utilities to manipulate GIFs.
59
60
61%prep
62%setup -q -n giflib-%{version}
63
64
65%build
66sed -i "s|allhtml manpages|manpages|" doc/Makefile.am
67./autogen.sh
68%configure
69make all
70
71MAJOR=`echo '%{version}' | sed 's/\([0-9]\+\)\..*/\1/'`
72%{__cc} $RPM_OPT_FLAGS -shared -Wl,-soname,libungif.so.$MAJOR -Llib/.libs -lgif -o libungif.so.%{version}
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%makeinstall
79install -m 0755 -p libungif.so.%{version} $RPM_BUILD_ROOT%{_libdir}
80ln -sf libungif.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libungif.so.4
81ln -sf libungif.so.4 ${RPM_BUILD_ROOT}%{_libdir}/libungif.so
82
83chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so*
84chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
85chmod 644 COPYING README NEWS
86chmod 644 ChangeLog TODO BUGS AUTHORS
87chmod 644 doc/* util/giffiltr.c util/gifspnge.c
88
89## remove unuse files
90rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
91rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.so
92rm -f ${RPM_BUILD_ROOT}%{_includedir}/*.h
93rm -f ${RPM_BUILD_ROOT}%{_bindir}/*
94
95
96%post -p /sbin/ldconfig
97
98
99%postun -p /sbin/ldconfig
100
101
102%if %{build_compat32}
103%post -n compat32-%{name} -p /sbin/ldconfig
104%postun -n compat32-%{name} -p /sbin/ldconfig
105%endif
106
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111
112%files
113%defattr(-,root,root)
114%license COPYING
115%doc README NEWS
116%doc ChangeLog TODO BUGS AUTHORS
117%{_libdir}/lib*.so.*
118
119## to build compat32 for x86_64 architecture support
120%if %{build_compat32}
121%files -n compat32-%{name}
122%defattr(-,root,root)
123%{_libdir}/lib*.so.*
124%endif
125
126
127%changelog
128* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.3-2
129- changed %%name for compatibility.
130
131* Sun Sep 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.3-1
132- new upstream release
133
134* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 4.1.6-4
135- rebuilt with rpm-4.8.1-3
136
137* Sat Feb 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-3
138- rebuild with new environment
139- remove static lib
140
141* Thu Aug 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-2
142- Obsolete specific version of libungif
143
144* Sun Jan 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.6-1
145- switch from the obsoleted libungif to the ongoing giflib
146  due to LZW's patent expiration which happend a few years ago
147
148* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-2vl5
149- removed *.la
150- spec in utf-8
151
152* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-1vl5
153- applied new versioning policy
154- updated URL
155
156* Sun Feb 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-0vl1
157- new upstream release
158
159* Sat Sep 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl3
160- changed libungif-progs Group to Applications/Graphics
161
162* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.3-3vl2
163- added compat32-* packages for x86_64 architecture support
164
165* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl1
166- new upstream release
167- not generate libungif.so.3* any more
168- fixed spec file based on 4.1.3-3 from Fedora development
169- s/Copyright/License/
170- updated URL
171
172* Fri Dec 13 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.0-13vl1
173- based on 4.1.0-13 from Rawhide
174  - Clean up spec file
175  - Fix build with current auto* tools
176
177* Sat Jul 14 2001 <sagami@vinelinux.org>
178- 4.1.0-9vl1
179- follow up with 4.1.0-9 which has a fix to build against new libtool
180
181* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
182- 4.1.0-7vl2
183- build with netpbm
184
185* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
186- 4.1.0-7vl1
187- based on 4.1.0-7 from Rawhide
188- added Japanese summary and description
189
190* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
191- Make the subpackages require the base package (Bug #14697)
192- update URL
193- add fixes from the homepage
194
195* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
196- automatic rebuild
197
198* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
199- FHS adjustments (release 5)
200
201* Mon Feb 14 2000 Elliot Lee <sopwith@redhat.com> 4.1.0-4
202- Add giflibcvs-small2crash.patch, which changes lib/dgif_lib.c to be
203  whatever is currently in the libungif CVS, thus fixing bug number 9315.
204
205* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
206- strip libraries
207- update URL
208- some specfile tweaks
209
210* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
211- auto rebuild in the new build environment (release 2)
212
213* Sun Mar 14 1999 Preston Brown <pbrown@redhat.com>
214- include libungif 4.1.0 as standard library, with 3.1.0 backwards compat.
215
216* Mon Jan 11 1999 Cristian Gafton <gafton@redhat.com>
217- build for 6.0
218- call libtoolize to make sure it will build on the arm
219
220* Sat Oct 31 1998 Jeff Johnson <jbj@redhat.com>
221- package for RH 5.2.
222
223* Mon Sep 14 1998 Arne Coucheron <arneco@online.no>
224  [3.1.0-3]
225- major cleanups and changes to the spec file
226
227* Mon Sep 7 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
228- Upgrade to version 3.1.0 (which incorporates the patches in 3.0-4)
229- Updated Source: and URL: to reflect change in directories/pages.
230
231* Tue May 26 1998 Dick Porter <dick@cymru.net>
232- Fixed some "warning: cast to pointer from integer of different size" on Alpha
233
234* Tue May 5 1998 Marc Ewing <marc@redhat.com>
235- Made it obsolete giflib and provide libgif.so and giflib (previous
236  giflib packages were built incorrectly and packages built against
237  it require libgif.so but work fine with this package)
238- cleaned buildroot
239- Removed Toshio as packager so he doesn't get yelled at when Red Hat
240  breaks it :-)
241
242* Fri Apr 24 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
243- Initial revision of libungif, a giflib derivative modified to not use LZW
244  compression.
Note: See TracBrowser for help on using the repository browser.