source: projects/specs/trunk/g/ghex/ghex-vl.spec @ 8369

Revision 8369, 4.3 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1%define ver     3.10.1
2%define rel     1%{?_dist_release}
3
4Summary:        Binary file editor for GNOME
5Summary(ja):    GNOME用バイナリ・ファイル・エディタ
6Name:           ghex
7Version:        %{ver}
8Release:        %{rel}
9License:        GPL
10Group:          Applications/Editors
11
12Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{ver}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gtk3-devel
17BuildRequires:  gnome-doc-utils
18BuildRequires:  yelp-tools
19
20Packager:       ryoichi, daisuke, kazutaka, Takemikaduchi
21
22%description
23GHex allows the user to load data from any file, view and edit
24it in either hex or ascii. A must for anyone playing games that
25use non-ascii format for saving.
26
27%description -l ja
28GHex は16進と ASCIIのどちらのモードでもファイルの読み込み、
29表示及び編集が可能です。また 非 ASCII 形式のデータを保存する
30機能も備えています。
31
32
33%package        devel
34Summary:        Development files for %{name}
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37
38%description    devel
39The %{name}-devel package contains libraries and header files for
40developing applications that use %{name}.
41
42
43%prep
44%setup -q
45
46%build
47%configure --disable-static --disable-scrollkeeper
48make
49
50%install
51[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
52
53make install DESTDIR=$RPM_BUILD_ROOT
54
55find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
56
57%find_lang %{name}-3.0 --with-gnome
58
59%clean
60[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
61
62
63%post
64/sbin/ldconfig
65touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
66
67%postun
68/sbin/ldconfig
69if [ $1 -eq 0 ] ; then
70    glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
71    touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
72    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
73fi
74
75%posttrans
76glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
77gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
78
79
80%files -f %{name}-3.0.lang
81%defattr(-,root,root)
82%doc README COPYING NEWS AUTHORS
83%{_bindir}/ghex
84%{_libdir}/libgtkhex-3.so.*
85%{_datadir}/GConf/gsettings/ghex.convert
86%{_datadir}/appdata/ghex.appdata.xml
87%{_datadir}/applications/ghex.desktop
88%{_datadir}/glib-2.0/schemas/org.gnome.GHex.gschema.xml
89%{_datadir}/icons/hicolor/*/apps/*
90%{_datadir}/icons/HighContrast/*/apps/*
91%{_datadir}/help/*/%{name}
92
93%files devel
94%{_includedir}/gtkhex-3
95%{_libdir}/libgtkhex-3.so
96%{_libdir}/pkgconfig/gtkhex-3.pc
97
98%changelog
99* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
100- new upstream release
101
102* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
103- new upstream release
104
105* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
106- new upstream release
107- add BuildRequires: yelp-tools
108
109* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
110- new upstream release
111
112* Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
113- new upstream release
114
115* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
116- new upstream release
117
118* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
119- new upstream release
120- change BuildRequires: gtk3-devel instead of gtk2-devel
121
122* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.0-2
123- rebuilt with rpm-4.8.1 for pkg-config
124
125* Wed May 13 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.24.0-1
126- new upstream release
127- add japanese description
128
129* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@@bc.wakwak.com> 2.22.0-1vl5
130- new upstream release
131
132* Thu Sep 25 2008 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1vl5
133- applied new versioning policy, spec in utf-8
134
135* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
136- new upstream release
137
138* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
139- new upstream release
140
141* Thu Sep 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0.1-0vl1
142- new upstream release
143
144* Sun Jun 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.1-0vl1
145- rebuild with new toolchains and Gnome2
146
147* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.1-0vl1
148- New upstream release.
149- Fixed the font names for printing.
150
151* Wed Mar 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2-0vl1
152- New upstream release.
153- Use rpmmacros.
154
155* Sun Mar 12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
156- first release for vine
157
Note: See TracBrowser for help on using the repository browser.