source: projects/specs/trunk/g/ghc/ghc-vl.spec @ 11759

Revision 11759, 5.1 KB checked in by ara_t, 6 years ago (diff)

ghc: add Patch2

Line 
1%define pkg_name    ghc
2%define pkg_version 8.4.3
3# %define pkg_subversion b
4%define pkg_release 2%{?_dist_release}
5
6%ifarch %{ix86}
7%define rpmarch i386
8%endif
9%ifarch x86_64
10%define rpmarch x86_64
11%endif
12
13
14Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
15Name:    %{pkg_name}
16Version: %{pkg_version}
17Release: %{pkg_release}
18
19License: BSD-like
20Group:   Applications/Languages
21URL:     https://www.haskell.org/ghc
22
23# Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
24Source0: %{name}-%{version}-src.tar.xz
25Source1: macros.ghc
26
27# # https://phabricator.haskell.org/D4159
28# # ghc-pkg: recompute `abi-depends` for updated packages
29# Patch1: ghc-8.2.2-fix-shadowed_dependencies.patch
30
31# https://ghc.haskell.org/trac/ghc/ticket/15260
32# Xmobar crashes with segmentation fault
33Patch2: ghc.git-3ec1d931218e603ba1622faa2b52884b2477a7db.patch
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36
37BuildRequires: ghc
38BuildRequires: gmp-devel
39BuildRequires: libffi-devel
40BuildRequires: ncurses-devel readline-devel freeglut-devel
41BuildRequires: gtk2-devel
42BuildRequires: python-sphinx
43
44Requires: gmp-devel
45Requires: libffi-devel
46Requires: freeglut
47
48Conflicts: ghc-bootstrap
49Conflicts: haskell-platform-base
50
51Vendor: Project Vine
52Distribution: Vine Linux
53Packager: ara_t
54
55
56%description
57The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
58compiler and interactive environment for the functional language Haskell.
59Highlights:
60- GHC supports the entire Haskell 2010 language plus a wide variety of
61  extensions.
62- GHC has particularly good support for concurrency and parallelism,
63   including support for Software Transactional Memory (STM).
64- GHC generates fast code, particularly for concurrent programs.
65- Take a look at GHC's performance on The Computer Language Benchmarks Game.
66  GHC works on several platforms including Windows, Mac, Linux,
67   most varieties of Unix, and several different processor architectures.
68  There are detailed instructions for porting GHC to a new platform.
69- GHC has extensive optimisation capabilities, including inter-module
70  optimisation.
71- GHC compiles Haskell code either directly to native code or using LLVM
72  as a back-end.
73  GHC can also generate C code as an intermediate target for porting to
74  new platforms.
75  The interactive environment compiles Haskell to bytecode,
76   and supports execution of mixed bytecode/compiled programs.
77- Profiling is supported, both by time/allocation and various kinds of heap
78  profiling.
79- GHC comes with several libraries, and thousands more are available on Hackage.
80#'
81
82
83%prep
84%{__rm} -rf ${RPM_BUILD_ROOT}
85%setup -q
86# %patch1 -p1 -b .fix-shadowed_dependencies
87%patch2 -p1 -b .fix-xmobar_segfault
88
89%build
90%{_configure} \
91    --prefix=%{_prefix} \
92    --libdir=%{_libdir} \
93    --docdir=%{_docdir}/%{name}-%{version} \
94    --with-system-libffi
95%{__make} %{?_smp_mflags}
96
97%install
98%{make_install}
99%{__cp} ANNOUNCE LICENSE \
100        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
101
102# macros for building haskell-platform-related packages
103%{__mkdir_p} ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
104%{__sed} -e "s/@GHC_VERSION@/%{version}/" %{SOURCE1} \
105 > ${RPM_BUILD_ROOT}/%{_sysconfdir}/rpm/macros.ghc
106
107%clean
108%{__rm} -rf ${RPM_BUILD_ROOT}
109
110%post -p %{_syssbindir}/ldconfig
111%postun -p %{_syssbindir}/ldconfig
112
113
114%files
115%defattr(-, root, root)
116%{_bindir}/
117%{_libdir}/ghc-%{version}/
118%{_docdir}/ghc-%{version}/
119%{_mandir}/man1/
120%{_sysconfdir}/rpm/
121
122
123%changelog
124* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 8.4.3-2
125- add Patch2 (fixed that xmobar crashes with segmentation fault)
126
127* Thu Jul 19 2018 Toshiaki Ara <ara_t@384.jp> 8.4.3-1
128- update to 8.4.3
129- drop Patch1 (fixed at upstream)
130
131* Thu May 17 2018 Toshiaki Ara <ara_t@384.jp> 8.4.2-1
132- update to 8.4.2
133- add /etc/rpm/macros.ghc
134
135* Sat Jan 06 2018 Toshiaki Ara <ara_t@384.jp> 8.2.2-1
136- update to 8.2.2
137- add Patch1 (ghc-8.2.2-fix-shadowed_dependencies.patch)
138
139* Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
140- update to 8.0.1
141- add Requires: libffi-devel
142- add Requires: freeglut
143- add BuildRequires: python-sphinx for building HTML documents
144- add Conflicts: ghc-bootstrap
145- add Conflicts: haskell-platform-base
146- delete BuildRequires: hscolour
147- delete bindist subpackage
148
149* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
150- add Requires: gmp-devel
151
152* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
153- correct SPEC file
154
155* Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
156- update to 7.10.3
157- add BuildRequires: texlive-collection-fontutils
158- add Requires: libffi
159- add Requires: freeglut
160- provide binary tarball for building haskell-platform
161
162* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
163- rebuild with ghc-7.6.3-4
164
165* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
166- add Patchs to use --with-system-libffi option
167
168* Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
169- empty
170
171* Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
172- add BuildRequires: dblatex
173- add BuildRequires: texlive-collection-bibtexextra
174- add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
175- change BuildRequires from ghc-bootstrap to ghc
176
177* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
178- new package
Note: See TracBrowser for help on using the repository browser.