source: projects/specs/trunk/g/ghc/ghc-vl.spec @ 11381

Revision 11381, 4.4 KB checked in by ara_t, 6 years ago (diff)

ghc: update to 8.2.2

Line 
1%define pkg_name    ghc
2%define pkg_version 8.2.2
3# %define pkg_subversion b
4%define pkg_release 1%{?_dist_release}
5
6%ifarch %{ix86}
7%define rpmarch i386
8%endif
9%ifarch x86_64
10%define rpmarch x86_64
11%endif
12
13
14Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
15Name:    %{pkg_name}
16Version: %{pkg_version}
17Release: %{pkg_release}
18
19License: BSD-like
20Group:   Applications/Languages
21URL:     https://www.haskell.org/ghc
22
23# Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
24Source0: %{name}-%{version}-src.tar.xz
25
26# https://phabricator.haskell.org/D4159
27# ghc-pkg: recompute `abi-depends` for updated packages
28Patch1: ghc-8.2.2-fix-shadowed_dependencies.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31
32BuildRequires: ghc
33BuildRequires: gmp-devel
34BuildRequires: libffi-devel
35BuildRequires: ncurses-devel readline-devel freeglut-devel
36BuildRequires: gtk2-devel
37BuildRequires: python-sphinx
38
39Requires: gmp-devel
40Requires: libffi-devel
41Requires: freeglut
42
43Conflicts: ghc-bootstrap
44Conflicts: haskell-platform-base
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: ara_t
49
50
51%description
52The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
53compiler and interactive environment for the functional language Haskell.
54Highlights:
55- GHC supports the entire Haskell 2010 language plus a wide variety of
56  extensions.
57- GHC has particularly good support for concurrency and parallelism,
58   including support for Software Transactional Memory (STM).
59- GHC generates fast code, particularly for concurrent programs.
60- Take a look at GHC's performance on The Computer Language Benchmarks Game.
61  GHC works on several platforms including Windows, Mac, Linux,
62   most varieties of Unix, and several different processor architectures.
63  There are detailed instructions for porting GHC to a new platform.
64- GHC has extensive optimisation capabilities, including inter-module
65  optimisation.
66- GHC compiles Haskell code either directly to native code or using LLVM
67  as a back-end.
68  GHC can also generate C code as an intermediate target for porting to
69  new platforms.
70  The interactive environment compiles Haskell to bytecode,
71   and supports execution of mixed bytecode/compiled programs.
72- Profiling is supported, both by time/allocation and various kinds of heap
73  profiling.
74- GHC comes with several libraries, and thousands more are available on Hackage.
75#'
76
77
78%prep
79%{__rm} -rf ${RPM_BUILD_ROOT}
80%setup -q
81%patch1 -p1 -b .fix-shadowed_dependencies
82
83%build
84./configure \
85    --prefix=%{_prefix} \
86    --libdir=%{_libdir} \
87    --docdir=%{_docdir}/%{name}-%{version} \
88    --with-system-libffi
89%{__make} %{?_smp_mflags}
90
91%install
92%{make_install}
93%{__cp} ANNOUNCE LICENSE \
94        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
95
96%clean
97%{__rm} -rf ${RPM_BUILD_ROOT}
98
99%post -p %{_syssbindir}/ldconfig
100%postun -p %{_syssbindir}/ldconfig
101
102
103%files
104%defattr(-, root, root)
105%{_bindir}/
106%{_libdir}/ghc-%{version}/
107%{_docdir}/ghc-%{version}/
108%{_mandir}/man1/
109
110
111%changelog
112* Sat Jan 06 2018 Toshiaki Ara <ara_t@384.jp> 8.2.2-1
113- update to 8.2.2
114- add Patch1 (ghc-8.2.2-fix-shadowed_dependencies.patch)
115
116* Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
117- update to 8.0.1
118- add Requires: libffi-devel
119- add Requires: freeglut
120- add BuildRequires: python-sphinx for building HTML documents
121- add Conflicts: ghc-bootstrap
122- add Conflicts: haskell-platform-base
123- delete BuildRequires: hscolour
124- delete bindist subpackage
125
126* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
127- add Requires: gmp-devel
128
129* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
130- correct SPEC file
131
132* Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
133- update to 7.10.3
134- add BuildRequires: texlive-collection-fontutils
135- add Requires: libffi
136- add Requires: freeglut
137- provide binary tarball for building haskell-platform
138
139* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
140- rebuild with ghc-7.6.3-4
141
142* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
143- add Patchs to use --with-system-libffi option
144
145* Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
146- empty
147
148* Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
149- add BuildRequires: dblatex
150- add BuildRequires: texlive-collection-bibtexextra
151- add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
152- change BuildRequires from ghc-bootstrap to ghc
153
154* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
155- new package
Note: See TracBrowser for help on using the repository browser.