source: projects/specs/trunk/g/ghc/ghc-vl.spec @ 10912

Revision 10912, 4.0 KB checked in by ara_t, 7 years ago (diff)

ghc: update to 8.0.1

Line 
1%define pkg_name    ghc
2%define pkg_version 8.0.1
3# %define pkg_subversion b
4%define pkg_release 1%{?_dist_release}
5
6%ifarch %{ix86}
7%define rpmarch i386
8%endif
9%ifarch x86_64
10%define rpmarch x86_64
11%endif
12
13
14Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
15Name:    %{pkg_name}
16Version: %{pkg_version}
17Release: %{pkg_release}
18
19License: BSD-like
20Group:   Applications/Languages
21URL:     https://www.haskell.org/ghc
22
23# Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
24Source0: %{name}-%{version}-src.tar.xz
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27
28BuildRequires: ghc
29BuildRequires: gmp-devel
30BuildRequires: libffi-devel
31BuildRequires: ncurses-devel readline-devel freeglut-devel
32BuildRequires: gtk2-devel
33BuildRequires: python-sphinx
34
35Requires: gmp-devel
36Requires: libffi-devel
37Requires: freeglut
38
39Conflicts: ghc-bootstrap
40Conflicts: haskell-platform-base
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: ara_t
45
46
47%description
48The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
49compiler and interactive environment for the functional language Haskell.
50Highlights:
51- GHC supports the entire Haskell 2010 language plus a wide variety of
52  extensions.
53- GHC has particularly good support for concurrency and parallelism,
54   including support for Software Transactional Memory (STM).
55- GHC generates fast code, particularly for concurrent programs.
56- Take a look at GHC's performance on The Computer Language Benchmarks Game.
57  GHC works on several platforms including Windows, Mac, Linux,
58   most varieties of Unix, and several different processor architectures.
59  There are detailed instructions for porting GHC to a new platform.
60- GHC has extensive optimisation capabilities, including inter-module
61  optimisation.
62- GHC compiles Haskell code either directly to native code or using LLVM
63  as a back-end.
64  GHC can also generate C code as an intermediate target for porting to
65  new platforms.
66  The interactive environment compiles Haskell to bytecode,
67   and supports execution of mixed bytecode/compiled programs.
68- Profiling is supported, both by time/allocation and various kinds of heap
69  profiling.
70- GHC comes with several libraries, and thousands more are available on Hackage.
71#'
72
73
74%prep
75%{__rm} -rf ${RPM_BUILD_ROOT}
76%setup -q
77
78%build
79./configure \
80    --prefix=%{_prefix} \
81    --libdir=%{_libdir} \
82    --docdir=%{_docdir}/%{name}-%{version} \
83    --with-system-libffi
84%{__make} %{?_smp_mflags}
85
86%install
87%{make_install}
88%{__cp} ANNOUNCE LICENSE \
89        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
90
91%clean
92%{__rm} -rf ${RPM_BUILD_ROOT}
93
94%post -p %{_syssbindir}/ldconfig
95%postun -p %{_syssbindir}/ldconfig
96
97
98%files
99%defattr(-, root, root)
100%{_bindir}/
101%{_libdir}/ghc-%{version}/
102%{_docdir}/ghc-%{version}/
103%{_mandir}/man1/
104
105
106%changelog
107* Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
108- update to 8.0.1
109- add Requires: libffi-devel
110- add Requires: freeglut
111- add BuildRequires: python-sphinx for building HTML documents
112- add Conflicts: ghc-bootstrap
113- add Conflicts: haskell-platform-base
114- delete BuildRequires: hscolour
115- delete bindist subpackage
116
117* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
118- add Requires: gmp-devel
119
120* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
121- correct SPEC file
122
123* Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
124- update to 7.10.3
125- add BuildRequires: texlive-collection-fontutils
126- add Requires: libffi
127- add Requires: freeglut
128- provide binary tarball for building haskell-platform
129
130* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
131- rebuild with ghc-7.6.3-4
132
133* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
134- add Patchs to use --with-system-libffi option
135
136* Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
137- empty
138
139* Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
140- add BuildRequires: dblatex
141- add BuildRequires: texlive-collection-bibtexextra
142- add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
143- change BuildRequires from ghc-bootstrap to ghc
144
145* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
146- new package
Note: See TracBrowser for help on using the repository browser.