source: projects/specs/trunk/g/ghc/ghc-vl.spec @ 10153

Revision 10153, 4.3 KB checked in by ara_t, 8 years ago (diff)

A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell

Line 
1%define pkg_name    ghc
2%define pkg_version 7.10.3
3%define pkg_subversion b
4%define pkg_release 2%{?_dist_release}
5
6%ifarch %{ix86}
7%define rpmarch i386
8%endif
9%ifarch x86_64
10%define rpmarch x86_64
11%endif
12
13
14Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
15Name:    %{pkg_name}
16Version: %{pkg_version}
17Release: %{pkg_release}
18
19License: BSD-like
20Group:   Applications/Languages
21URL:     https://www.haskell.org/ghc
22
23Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27BuildRequires: ghc-bootstrap
28# BuildRequires: ghc
29BuildRequires: gmp-devel
30BuildRequires: libffi-devel
31BuildRequires: ncurses-devel readline-devel freeglut-devel
32BuildRequires: gtk2-devel
33BuildRequires: dblatex
34BuildRequires: texlive-collection-bibtexextra
35BuildRequires: texlive-collection-fontutils
36BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
37BuildRequires: hscolour
38
39Requires: libffi
40Requires: freeglut
41
42Obsoletes: ghc-bootstrap
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: ara_t
47
48
49%description
50The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
51compiler and interactive environment for the functional language Haskell.
52Highlights:
53- GHC supports the entire Haskell 2010 language plus a wide variety of
54  extensions.
55- GHC has particularly good support for concurrency and parallelism,
56   including support for Software Transactional Memory (STM).
57- GHC generates fast code, particularly for concurrent programs.
58- Take a look at GHC's performance on The Computer Language Benchmarks Game.
59  GHC works on several platforms including Windows, Mac, Linux,
60   most varieties of Unix, and several different processor architectures.
61  There are detailed instructions for porting GHC to a new platform.
62- GHC has extensive optimisation capabilities, including inter-module
63  optimisation.
64- GHC compiles Haskell code either directly to native code or using LLVM
65  as a back-end.
66  GHC can also generate C code as an intermediate target for porting to
67  new platforms.
68  The interactive environment compiles Haskell to bytecode,
69   and supports execution of mixed bytecode/compiled programs.
70- Profiling is supported, both by time/allocation and various kinds of heap
71  profiling.
72- GHC comes with several libraries, and thousands more are available on Hackage.
73#'
74
75
76%package bindist
77Version:     %{version}
78Summary:     ghc binary tarball to building haskell-platform
79License:     BSD-like
80Group:       Applications/Languages
81
82%description bindist
83ghc binary tarball to building haskell-platform
84
85
86%prep
87%{__rm} -rf ${RPM_BUILD_ROOT}
88%setup -q
89
90%build
91./configure \
92    --prefix=%{_prefix} --libdir=%{_libdir} \
93    --docdir=%{_docdir}/%{name}-%{version} \
94    --with-system-libffi
95%{__make} %{?_smp_mflags}
96%{__make} binary-dist
97
98%install
99%{make_install}
100%{__cp} ANNOUNCE LICENSE \
101        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
102
103%{__mkdir_p} ${RPM_BUILD_ROOT}%{_usrsrc}
104%{__mv} ghc-%{version}-%{rpmarch}-unknown-linux.tar.bz2 \
105        ghc-%{version}-%{rpmarch}-vine-linux.tar.bz2
106%{__cp} ghc-%{version}-%{rpmarch}-vine-linux.tar.bz2 \
107        ${RPM_BUILD_ROOT}%{_usrsrc}
108
109%clean
110%{__rm} -rf ${RPM_BUILD_ROOT}
111
112%post -p %{_syssbindir}/ldconfig
113%postun -p %{_syssbindir}/ldconfig
114
115
116%files
117%defattr(-, root, root)
118%{_bindir}/
119%{_libdir}/ghc-%{version}/
120%{_docdir}/ghc-%{version}/
121%{_mandir}/man1/
122
123%files bindist
124%defattr(-, root, root)
125%{_usrsrc}/
126
127
128%changelog
129* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
130- correct SPEC file
131
132* Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
133- update to 7.10.3
134- add BuildRequires: texlive-collection-fontutils
135- add Requires: libffi
136- add Requires: freeglut
137- provide binary tarball for building haskell-platform
138
139* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
140- rebuild with ghc-7.6.3-4
141
142* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
143- add Patchs to use --with-system-libffi option
144
145* Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
146- empty
147
148* Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
149- add BuildRequires: dblatex
150- add BuildRequires: texlive-collection-bibtexextra
151- add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
152- change BuildRequires from ghc-bootstrap to ghc
153
154* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
155- new package
Note: See TracBrowser for help on using the repository browser.