source: projects/specs/trunk/g/ghc/ghc-vl.spec @ 11629

Revision 11629, 4.7 KB checked in by ara_t, 6 years ago (diff)

ghc: update to 8.4.2

RevLine 
[10153]1%define pkg_name    ghc
[11629]2%define pkg_version 8.4.2
[10912]3# %define pkg_subversion b
4%define pkg_release 1%{?_dist_release}
[10153]5
6%ifarch %{ix86}
7%define rpmarch i386
8%endif
9%ifarch x86_64
10%define rpmarch x86_64
11%endif
12
13
14Summary: A state-of-the-art, open source, compiler and interactive environment for the functional language Haskell
15Name:    %{pkg_name}
16Version: %{pkg_version}
17Release: %{pkg_release}
18
19License: BSD-like
20Group:   Applications/Languages
21URL:     https://www.haskell.org/ghc
22
[10912]23# Source0: %{name}-%{version}%{pkg_subversion}-src.tar.bz2
24Source0: %{name}-%{version}-src.tar.xz
[11629]25Source1: macros.ghc
[10153]26
[11381]27# https://phabricator.haskell.org/D4159
28# ghc-pkg: recompute `abi-depends` for updated packages
29Patch1: ghc-8.2.2-fix-shadowed_dependencies.patch
30
[10153]31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
[10912]33BuildRequires: ghc
[10153]34BuildRequires: gmp-devel
35BuildRequires: libffi-devel
36BuildRequires: ncurses-devel readline-devel freeglut-devel
37BuildRequires: gtk2-devel
[10912]38BuildRequires: python-sphinx
[10153]39
[10231]40Requires: gmp-devel
[10912]41Requires: libffi-devel
[10153]42Requires: freeglut
43
[10912]44Conflicts: ghc-bootstrap
45Conflicts: haskell-platform-base
[10153]46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: ara_t
50
51
52%description
53The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
54compiler and interactive environment for the functional language Haskell.
55Highlights:
56- GHC supports the entire Haskell 2010 language plus a wide variety of
57  extensions.
58- GHC has particularly good support for concurrency and parallelism,
59   including support for Software Transactional Memory (STM).
60- GHC generates fast code, particularly for concurrent programs.
61- Take a look at GHC's performance on The Computer Language Benchmarks Game.
62  GHC works on several platforms including Windows, Mac, Linux,
63   most varieties of Unix, and several different processor architectures.
64  There are detailed instructions for porting GHC to a new platform.
65- GHC has extensive optimisation capabilities, including inter-module
66  optimisation.
67- GHC compiles Haskell code either directly to native code or using LLVM
68  as a back-end.
69  GHC can also generate C code as an intermediate target for porting to
70  new platforms.
71  The interactive environment compiles Haskell to bytecode,
72   and supports execution of mixed bytecode/compiled programs.
73- Profiling is supported, both by time/allocation and various kinds of heap
74  profiling.
75- GHC comes with several libraries, and thousands more are available on Hackage.
76#'
77
78
79%prep
80%{__rm} -rf ${RPM_BUILD_ROOT}
81%setup -q
[11381]82%patch1 -p1 -b .fix-shadowed_dependencies
[10153]83
84%build
[11629]85%{_configure} \
[10912]86    --prefix=%{_prefix} \
87    --libdir=%{_libdir} \
[10153]88    --docdir=%{_docdir}/%{name}-%{version} \
89    --with-system-libffi
90%{__make} %{?_smp_mflags}
91
92%install
93%{make_install}
94%{__cp} ANNOUNCE LICENSE \
95        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
96
[11629]97# macros for building haskell-platform-related packages
98%{__mkdir_p} ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
99%{__sed} -e "s/@GHC_VERSION@/%{version}/" %{SOURCE1} \
100 > ${RPM_BUILD_ROOT}/%{_sysconfdir}/rpm/macros.ghc
101
[10153]102%clean
103%{__rm} -rf ${RPM_BUILD_ROOT}
104
105%post -p %{_syssbindir}/ldconfig
106%postun -p %{_syssbindir}/ldconfig
107
108
109%files
110%defattr(-, root, root)
111%{_bindir}/
112%{_libdir}/ghc-%{version}/
113%{_docdir}/ghc-%{version}/
114%{_mandir}/man1/
[11629]115%{_sysconfdir}/rpm/
[10153]116
117
118%changelog
[11629]119* Thu May 17 2018 Toshiaki Ara <ara_t@384.jp> 8.4.2-1
120- update to 8.4.2
121- add /etc/rpm/macros.ghc
122
[11381]123* Sat Jan 06 2018 Toshiaki Ara <ara_t@384.jp> 8.2.2-1
124- update to 8.2.2
125- add Patch1 (ghc-8.2.2-fix-shadowed_dependencies.patch)
126
[10912]127* Tue Jan 31 2017 Toshiaki Ara <ara_t@384.jp> 8.0.1-1
128- update to 8.0.1
129- add Requires: libffi-devel
130- add Requires: freeglut
131- add BuildRequires: python-sphinx for building HTML documents
132- add Conflicts: ghc-bootstrap
133- add Conflicts: haskell-platform-base
134- delete BuildRequires: hscolour
135- delete bindist subpackage
136
[10231]137* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-3
138- add Requires: gmp-devel
139
[10153]140* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
141- correct SPEC file
142
143* Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
144- update to 7.10.3
145- add BuildRequires: texlive-collection-fontutils
146- add Requires: libffi
147- add Requires: freeglut
148- provide binary tarball for building haskell-platform
149
150* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-5
151- rebuild with ghc-7.6.3-4
152
153* Sun Feb 14 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-4
154- add Patchs to use --with-system-libffi option
155
156* Fri Feb 12 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-3
157- empty
158
159* Mon Feb 08 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
160- add BuildRequires: dblatex
161- add BuildRequires: texlive-collection-bibtexextra
162- add BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
163- change BuildRequires from ghc-bootstrap to ghc
164
165* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
166- new package
Note: See TracBrowser for help on using the repository browser.