source: projects/specs/trunk/g/ghc-bootstrap/ghc-bootstrap-vl.spec @ 10144

Revision 10144, 1.6 KB checked in by ara_t, 8 years ago (diff)

ghc binary for build ghc

Line 
1%define pkg_name    ghc-bootstrap
2%define pkg_version 7.10.3
3%define pkg_release 1%{?_dist_release}
4
5%ifarch %{ix86}
6%define rpmarch i386
7%endif
8%ifarch x86_64
9%define rpmarch x86_64
10%endif
11
12%define dlurl https://www.haskell.org/ghc/dist
13%define filename ghc-%{pkg_version}-%{rpmarch}-deb8-linux.tar.bz2
14
15
16Summary: ghc binary for build ghc
17Name:    %{pkg_name}
18Version: %{pkg_version}
19Release: %{pkg_release}
20
21License: BSD-like
22Group:   Applications/Languages
23URL:     https://www.haskell.org/ghc
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: wget
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: ara_t
31
32
33%description
34The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
35compiler and interactive environment for the functional language Haskell.
36
37This package is ghc binary for building ghc.
38
39
40%prep
41%{__rm} -rf ${RPM_BUILD_ROOT}
42wget %{dlurl}/%{version}/%{filename}
43
44%build
45%{__tar} xf %{filename}
46cd ghc-%{version}
47./configure --prefix=%{_prefix} --libdir=%{_libdir}
48
49%install
50cd ghc-%{version}
51%{make_install}
52%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/ghc \
53        ${RPM_BUILD_ROOT}%{_docdir}/ghc-%{version} \
54
55%clean
56%{__rm} -rf ${RPM_BUILD_ROOT}
57
58%post -p %{_syssbindir}/ldconfig
59%postun -p %{_syssbindir}/ldconfig
60
61
62%files
63%defattr(-, root, root)
64%{_bindir}/
65%{_libdir}/ghc-%{version}/
66%{_docdir}/ghc-%{version}/
67%{_mandir}/man1/
68
69
70%changelog
71* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
72- update to 7.10.3-1
73
74* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
75- coorect SPEC file
76
77* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
78- new package
Note: See TracBrowser for help on using the repository browser.