source: projects/specs/trunk/g/ghc-bootstrap/ghc-bootstrap-vl.spec @ 10842

Revision 10842, 1.7 KB checked in by ara_t, 7 years ago (diff)

ghc-bootstrap: empty

Line 
1%define pkg_name    ghc-bootstrap
2%define pkg_version 7.10.3
3%define pkg_release 2%{?_dist_release}
4
5%ifarch %{ix86}
6%define rpmarch i386
7%endif
8%ifarch x86_64
9%define rpmarch x86_64
10%endif
11
12%define dlurl https://www.haskell.org/ghc/dist
13%define filename ghc-%{pkg_version}-%{rpmarch}-deb8-linux.tar.bz2
14
15
16Summary: ghc binary for build ghc
17Name:    %{pkg_name}
18Version: %{pkg_version}
19Release: %{pkg_release}
20
21License: BSD-like
22Group:   Applications/Languages
23URL:     https://www.haskell.org/ghc
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: wget
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: ara_t
31
32
33%description
34The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
35compiler and interactive environment for the functional language Haskell.
36
37This package is ghc binary for building ghc.
38
39
40%prep
41%{__rm} -rf ${RPM_BUILD_ROOT}
42# wget %{dlurl}/%{version}/%{filename}
43
44# %build
45# %{__tar} xf %{filename}
46# cd ghc-%{version}
47# ./configure --prefix=%{_prefix} --libdir=%{_libdir} \
48#             --with-system-libffi
49
50# %install
51# cd ghc-%{version}
52# %{make_install}
53# %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/ghc \
54#         ${RPM_BUILD_ROOT}%{_docdir}/ghc-%{version} \
55
56%clean
57%{__rm} -rf ${RPM_BUILD_ROOT}
58
59# %post -p %{_syssbindir}/ldconfig
60# %postun -p %{_syssbindir}/ldconfig
61
62
63%files
64# %defattr(-, root, root)
65# %{_bindir}/
66# %{_libdir}/ghc-%{version}/
67# %{_docdir}/ghc-%{version}/
68# %{_mandir}/man1/
69
70
71%changelog
72* Sun Dec 11 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-2
73- empty
74
75* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
76- update to 7.10.3-1
77
78* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
79- coorect SPEC file
80
81* Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
82- new package
Note: See TracBrowser for help on using the repository browser.