source: projects/specs/trunk/g/gfceux/gfceux-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: GFCE UltraX Nintendo Emulator frontend
2Name: gfceux
3Version: 2.0.0
4Release: 1%{?_dist_release}
5License: GPLv2+
6Group: Applications/Emulators
7URL: http://dietschnitzel.com/gfceu/
8Source: http://dietschnitzel.com/gfceu/%{name}-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10BuildArch: noarch
11BuildRequires: desktop-file-utils
12Requires: pygtk2-libglade
13# fceux package provided by self-build-fceux
14#Requires: fceux
15Requires: self-build-fceux
16Requires: hicolor-icon-theme
17
18%description
19GFCE Ultra is an intuitive interface for the popular Nintendo Emulator,
20FCE Ultra. It is designed for the GNOME desktop, and allows the user to
21easily play NES ROM images. Gfceu sports a number of features, including:
22
23* Network play
24* Custom input configuration
25* Fullscreen support
26* OpenGL support
27* Sound support
28* High compatibility, accurate emulation, and all the power of FCE Ultra!
29
30GNOME FCE Ultra is developed and maintained by Lukas Sabota.
31
32%prep
33%setup -q
34
35# Fix .desktop file Categories
36%__sed -i 's/GNOME;GTK;Game;/Game;Emulator;/' %{name}.desktop
37%__sed -i 's/Icon\=%{name}/Icon\=%{name}.png/' %{name}.desktop
38
39# # Patch to run fceultra instead of fceu
40# %__sed -i 's/'\''fceu'\''/'\''fceultra'\''/' %{name}
41
42%build
43
44%install
45rm -rf %{buildroot}
46install -d %{buildroot}%{_bindir}
47install -m 755 %{name} %{buildroot}%{_bindir}
48install -d %{buildroot}%{_datadir}/%{name}
49# No gfceux.glade archived!!!, but gfceux.xml archived
50install -m 644 {%{name}.xml,%{name}.png,%{name}_big.png} %{buildroot}%{_datadir}/%{name}
51# No gfceux.1 archived!!!
52# install -d %{buildroot}%{_mandir}/man1
53# install -m 644 %{name}.1 %{buildroot}%{_mandir}/man1
54
55# install desktop file and icon
56mkdir -p %{buildroot}%{_datadir}/applications
57desktop-file-install --vendor vine        \
58  --dir %{buildroot}%{_datadir}/applications \
59  %{name}.desktop
60install -d %{buildroot}%{_datadir}/icons/hicolor/48x48/apps
61install -p %{name}.png %{buildroot}%{_datadir}/icons/hicolor/48x48/apps
62
63%clean
64rm -rf %{buildroot}
65
66%post
67touch --no-create %{_datadir}/icons/hicolor
68if [ -x %{_bindir}/gtk-update-icon-cache ]; then
69    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
70fi
71
72%postun
73touch --no-create %{_datadir}/icons/hicolor
74if [ -x %{_bindir}/gtk-update-icon-cache ]; then
75    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
76fi
77
78%files
79%defattr(-,root,root)
80%{_bindir}/%{name}
81%{_datadir}/%{name}/*
82#%{_mandir}/man1/*
83%{_datadir}/applications/vine-%{name}.desktop
84%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
85%doc ChangeLog COPYING TODO INSTALL
86
87%changelog
88* Sun Nov 16 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0.0-1
89- initial build
90
91* Sun Nov 16 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.0-1
92- initial build
93
94* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.0-3
95- rebuild for buildsys cflags issue
96
97* Fri Nov 02 2007 Andrea Musuruane <musuruan@gmail.com> 0.6.0-2
98- Changed license due to new guidelines
99- Removed %%{?dist} tag from changelog
100- Updated icon cache scriptlets to be compliant to new guidelines
101
102* Thu Mar 01 2007 Andrea Musuruane <musuruan@gmail.com> 0.6.0-1
103- Updated to latest 0.6.0.
104- Added now required alsa-oss to BR
105- Updated URL and Source tag.
106- Dropped dribble-menus Requires.
107- Dropped --add-category X-Fedora from desktop-file-install.
108- Dropped .desktop file patch. Now using sed.
109- fceu has been renamed to fceultra to avoid conflicts (Dribble #77).
110
111* Mon Oct 23 2006 Andrea Musuruane <musuruan@gmail.com> 0.5.2-2
112- Added hicolor-icon-theme to Requires.
113- Package fceu has been renamed fceultra. Changed the Requires tag accorgingly.
114
115* Sat Oct 21 2006 Andrea Musuruane <musuruan@gmail.com> 0.5.2-1
116- First release for Dribble based on mde RPM
117- Updated to 0.5.2
118
119* Mon Aug 28 2006 Torbjorn Turpeinen <tobbe@nyvalls.se> 0.5-1
120- Rebuild for mde
121
Note: See TracBrowser for help on using the repository browser.