source: projects/specs/trunk/g/gengetopt/gengetopt-vl.spec @ 12203

Revision 12203, 8.4 KB checked in by tomop, 5 years ago (diff)

gengetopt-2.23-1

Line 
1Name:             gengetopt
2Version:          2.23
3Release:          1%{?_dist_release}
4Summary:          Tool to write command line option parsing code for C programs
5License:          GPLv3+
6URL:              https://www.gnu.org/software/gengetopt/
7
8Vendor:           Project Vine
9Distribution:     Vine Linux
10
11Source0:          https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
12
13BuildRequires:  gcc-c++
14BuildRequires:  gcc
15BuildRequires:  valgrind
16BuildRequires:  texinfo
17Provides:         bundled(gnulib)
18
19%description
20Gengetopt is a tool to generate C code to parse the command line arguments
21argc and argv that are part of every C or C++ program. The generated code uses
22the C library function getopt_long to perform the actual command line parsing.
23
24%prep
25%setup -q
26
27# Suppress rpmlint error.
28chmod 644 ./AUTHORS
29chmod 644 ./ChangeLog
30chmod 644 ./COPYING
31chmod 644 ./LICENSE
32chmod 644 ./NEWS
33chmod 644 ./README
34chmod 644 ./THANKS
35chmod 644 ./TODO
36chmod 644 ./doc/README.example
37chmod 644 ./doc/index.html
38chmod 644 ./src/parser.yy
39chmod 644 ./src/scanner.ll
40find . -name '*.c' -exec chmod 644 {} ';'
41find . -name '*.cc' -exec chmod 644 {} ';'
42find . -name '*.cpp' -exec chmod 644 {} ';'
43find . -name '*.h' -exec chmod 644 {} ';'
44find . -name '*.ggo' -exec chmod 644 {} ';'
45
46%build
47%configure
48# Parallel build doesn't work.
49make
50
51%install
52%make_install INSTALL="%{__install} -p"
53rm -frv %{buildroot}%{_infodir}/dir
54# Use %%doc macro to install instead.
55rm -frv %{buildroot}%{_docdir}/%{name}
56
57mkdir ./examples
58pushd ./doc
59  cp -p README.example ../examples
60  cp -p main1.cc sample1.ggo ../examples
61  cp -p main2.c sample2.ggo ../examples
62popd
63
64%check
65make check
66
67%files
68%doc AUTHORS ChangeLog NEWS README THANKS TODO
69%doc doc/index.html doc/%{name}.html
70%doc examples/
71%license COPYING LICENSE
72%{_bindir}/%{name}
73%{_datadir}/%{name}/
74%{_infodir}/*.info*
75%{_mandir}/man1/%{name}.1*
76
77%changelog
78* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.23-2
79- initial build for Vine Linux.
80
81* Mon Sep 9 2019 Mosaab Alzoubi <moceap[At]hotmail[Dot]com> - 2.23 -1
82- Update to 2.23
83
84* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-15
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
86
87* Thu Mar  7 2019 Tim Landscheidt <tim@tim-landscheidt.de> - 2.22.6-14%{dist}
88- Remove obsolete requirements for %%post/%%preun scriptlets
89
90* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-13
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
92
93* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-12
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
95
96* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-11
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
98
99* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-10
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
101
102* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-9
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
104
105* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-8
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
107
108* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.22.6-7
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
110
111* Mon Aug 24 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 2.22.6-6
112- Valgrind is not available only on s/390
113
114* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.6-5
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
116
117* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.22.6-4
118- Rebuilt for GCC 5 C++11 ABI change
119
120* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.6-3
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
122
123* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.6-2
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
125
126* Thu Feb 20 2014 Christopher Meng <rpm@cicku.me> - 2.22.6-1
127- Update to 2.22.6
128
129* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.5-4
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
131
132* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.5-3
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
134
135* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.5-2
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
137
138* Sat May  5 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.22.5-1
139- Update to 2.22.5-1 to fix FTBFS
140- valgrind supported on ARM too
141
142* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-4
143- Rebuilt for c++ ABI breakage
144
145* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-3
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
147
148* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-2
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
150
151* Wed Nov 04 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.22.3-1
152- Version bump to 2.22.3. (Red Hat Bugzilla #512414)
153  * enum option values can contain + and -.
154  * Fixed compilation problems due to macro FIX_UNUSED which was not in the
155    right place.
156  * New command line switches --header-output-dir and --src_output-dir to
157    store cmdline.h separately from cmdline.c.
158  * Use #include <getopt.h> in the generated files, instead of "getopt.h".
159  * Generated functions use prototypes with char ** instead of char *const *.
160  * Removed compilation warnings for generated files.
161  * Fixed a compilation problem for files generated with --include-getopt
162    with some versions of stdlib.h.
163  * Use PACKAGE_NAME, if defined, for printing help and version.
164- Encoding of ChangeLog and THANKS fixed by upstream.
165- Removed spurious executable permissions from a bunch of files.
166
167* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 2.22.1-3
168- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
169
170* Tue Feb 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 2.22.1-2
171- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
172
173* Mon Jun 02 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.22.1-1
174- Version bump to 2.22.1. (Red Hat Bugzilla #444335)
175  * Removed compilation warnings for generated files.
176  * Fixed a bug with --long-help and enum options.
177  * The outputs of --help and output of --show-help correspond with each other.
178  * Fixed a compilation problem in generated output with mode options.
179- Parallel build problems fixed by upstream.
180
181* Fri Mar 07 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.22-1
182- Version bump to 2.22. (Red Hat Bugzilla #428641)
183- Fixed build failure with gcc-4.3.
184- Trimmed the 'BuildRequires' list.
185- Changed character encodings from ISO8859-1 to UTF-8.
186- Disabled parallel make to prevent failure with -j2.
187- Added 'make check-valgrind' for ix86, x86_64, ppc and ppc64 in check stanza.
188- Fixed Texinfo scriptlets according to Fedora packaging guidelines.
189
190* Tue Aug 07 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.21-2
191- Removed 'BuildRequires: source-highlight' to prevent build failure.
192
193* Sat Aug 04 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.21-1
194- Version bump to 2.21. (Red Hat Bugzilla #250817)
195- License changed to GPLv3 or later.
196- Parallel build problems fixed by upstream.
197- README.example added by upstream.
198
199* Tue Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.20-1
200- Version bump to 2.20.
201
202* Tue Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-3
203- Added 'BuildRequires: ...' for check stanza.
204- Added a check stanza.
205- Removed -devel package.
206
207* Mon Jun 11 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-2
208- Used variables name and version in Source0.
209- Mentioned /sbin/install-info as a requirement for post and preun.
210- Used _datadir instead of defining sharedir.
211- Disabled parallel make to prevent failure with -j2.
212- Removing /usr/share/info/dir in the install stanza.
213- Replaced '$RPM_BUILD_DIR' with '.' in the install stanza.
214
215* Sun Jun 10 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-1
216- Initial build.
217- Added README.example from Debian.
218- Changed version and date in online manual page to 2.19.1 from 2.19rc.
Note: See TracBrowser for help on using the repository browser.