source: projects/specs/trunk/g/gedit-plugins/gedit-plugins-vl.spec @ 521

Revision 521, 6.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           gedit-plugins
2Version:        2.28.0
3Release:        2%{?_dist_release}
4Summary:        A collection Official Plugins for gedit
5Summary:        gedit の公式プラグイン集
6
7Group:          Applications/Editors
8License:        GPLv2+
9URL:            http://live.gnome.org/GeditPlugins
10Source0:        ftp://ftp.gnome.org/pub/gnome/sources/gedit-plugins/2.28/%{name}-%{version}.tar.bz2
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  intltool >= 0.35.0
14BuildRequires:  perl >= 5.8.1
15BuildRequires:  perl-XML-Parser
16BuildRequires:  gettext
17BuildRequires:  glib2-devel >= 2.16.0
18BuildRequires:  gtk2-devel >= 2.13.0
19BuildRequires:  GConf2-devel
20BuildRequires:  gtksourceview2-devel >= 2.5.1
21BuildRequires:  gedit-devel >= 2.25.4
22BuildRequires:  gucharmap-devel >= 2.23.0
23BuildRequires:  gnome-doc-utils
24BuildRequires:  vte-devel
25BuildRequires:  pygtk2-devel >= 2.12.0
26BuildRequires:  pygtksourceview-devel >= 2.2.0
27BuildRequires:  pygobject-devel >= 2.15.4
28Requires:       gedit
29Requires:       pygtk2
30Requires:       pygtksourceview
31Requires:       pygobject
32Requires(pre): GConf2
33Requires(post): GConf2
34Requires(preun): GConf2
35
36
37%description
38A collection of Official plugins for gedit.
39
40 * Bookmarks: Easy document navigation with bookmarks
41 * Bracket Completion: Automatically adds closing brackets.
42 * Character Map: Insert special characters just by clicking on them.
43 * Code comment: Comment out or uncomment a selected block of code.
44 * Color Picker: Pick a color from a dialog and insert its hexadecimal representation.
45 * Draw Spaces: Draw Spaces and Tabs
46 * Join/Split Lines: Join several lines or split long ones
47 * Session Saver: Save and restore your working sessions
48 * Show/Hide Tabbar: Add a menu entry to show/hide the tabbar.
49 * Smart Spaces: Forget you're not using tabulations.
50 * Embedded Terminal: Embed a terminal in the bottom pane.
51
52
53%description -l ja
54gedit の公式プラグイン集です。
55
56 * ブックマーク: ブックマークを使って簡単にドキュメントを閲覧できるようにします。
57 * 括弧の補完: 対応する閉じ括弧を自動的に追加します。
58 * 文字マップ: 特殊な文字をクリックしながら挿入していきます。
59 * コードのコメント: 選択した範囲をコメントアウトしたり解除します。
60 * 色の取得: 色選択ダイアログから色を取得して 16進形式の文字列として挿入します。
61 * 空白文字の表示: 空白やタブ文字を描画します。
62 * 行の結合・分割: 複数の行と結合したり一行を分割したりします。
63 * セッションの保存: 現在、作業中のセッションを保存したりリストアします。
64 * タブバーの表示/非表示: タブバーの表示切り替えエントリをメニューに追加します。
65 * スマート・スペース: 作表を使っていないことを忘れて下さい。
66 * 埋め込み式の端末: ボトム・ペインに端末を埋め込みます。
67
68
69%prep
70%setup -q
71grep '"import vte' configure && sed \
72    -i "s!import vte!import imp; imp.find_module('vte')!" configure
73
74%build
75%configure --disable-schemas-install --enable-python
76#--with-plugins=bracketcompletion,charmap,codecomment,colorpicker,drawspaces,joinlines,showtabbar,smartspaces,terminal,bookmarks
77make %{?_smp_mflags}
78
79
80%install
81rm -rf $RPM_BUILD_ROOT
82make install DESTDIR=$RPM_BUILD_ROOT
83%find_lang %{name}
84find $RPM_BUILD_ROOT/%{_libdir}/gedit-2/plugins -name "*.la" -exec rm {} \;
85
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90
91%pre
92if [ "$1" -gt 1 ]; then
93    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94    gconftool-2 --makefile-uninstall-rule \
95      %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas >/dev/null || :
96fi
97
98
99%post
100export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
101gconftool-2 --makefile-install-rule \
102  %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
103
104
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110      %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
111fi
112
113%check
114[ -f ${RPM_BUILD_ROOT}%{_libdir}/gedit-2/plugins/terminal.py ]
115
116
117%files -f %{name}.lang
118%defattr(-,root,root,-)
119%doc README NEWS AUTHORS COPYING
120%config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
121%{_libdir}/gedit-2/plugins/*
122%{_datadir}/gedit-2/plugins/*
123
124
125%changelog
126* Tue Dec  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.28.0-2
127- added BuildRequires: gedit-devel
128
129* Tue Nov  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.0-1
130- new upstream release
131
132* Sun Aug  2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.3-1
133- Update to upstream release
134
135* Fri Jun  5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.2-1
136- Update to upstream release
137
138* Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.1-1
139- initial build for VineSeed
140
141* Sat Apr 11 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.1-1
142- Update to upstream release 2..26.1
143- Fixes GNOME bugzilla bug #576766 - Crash when Configuring "Draw Spaces"
144- Make sure to remove all *.la files
145- Remove BuildRequire libgnomeui-devel as needless now
146
147* Fri Apr 10 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.0-1
148- Update to upstream release (2.26.1)
149- Add plugin files from %%{_datadir}
150- Don't check for vte anymore, the package checks it pkg-config
151- Add 'bookmarks' to the plugin set
152
153* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-4
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
155
156* Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.22.3-3
157- Rebuild for Python 2.6
158
159* Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-2
160- Fixed buildrequires
161
162* Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-1
163- Updated to 2.22.3
164
165* Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.0-2
166- rebuild to pick latest gucharmap
167
168* Tue Mar 18 2008 Trond Danielsen <trond.danielsen@gmail.com> - 2.22.0-1
169- Updated.
170
171* Mon Apr 30 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-2
172- Disable buggy session saver plugin.
173- Removed static libraries.
174
175* Sun Apr 01 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-1
176- Initial version.
Note: See TracBrowser for help on using the repository browser.