source: projects/specs/trunk/g/geany-plugins/geany-plugins-vl.spec @ 8445

Revision 8445, 36.9 KB checked in by kudoh, 10 years ago (diff)
Line 
1%global geany_plug_docdir %{_defaultdocdir}/%{name}-%{version}
2%global req_geany_ver 0.21
3
4Name:           geany-plugins
5Version:        1.24
6Release:        1%{?_dist_release}
7Summary:        Plugins for Geany
8Summary(ja):    Geany のプラグイン集
9
10Group:          Development/Tools
11License:        GPLv3
12URL:            http://plugins.geany.org/
13Source0:        http://plugins.geany.org/geany-plugins/geany-plugins-%{version}.tar.bz2
14#Patch0: fix_installation_path_of_geanylatex_documents.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  ctpl-devel >= 0.2
18#BuildRequires:  devhelp-devel
19BuildRequires:  enchant-devel
20BuildRequires:  geany-devel >= %{req_geany_ver}
21BuildRequires:  gettext
22BuildRequires:  gdk-pixbuf2-devel
23BuildRequires:  glib2-devel
24BuildRequires:  gpgme-devel
25BuildRequires:  gtk2-devel
26BuildRequires:  gtkspell-devel
27BuildRequires:  intltool
28BuildRequires:  libtool
29BuildRequires:  libsoup-devel >= 2.4
30BuildRequires:  lua-devel
31BuildRequires:  libxml2-devel >= 2.6.27
32BuildRequires:  pango-devel
33BuildRequires:  pkgconfig
34BuildRequires:  pygtk2-devel
35BuildRequires:  python-devel
36BuildRequires:  python-docutils
37BuildRequires:  vala-devel
38BuildRequires:  vte-devel
39BuildRequires:  WebKit-gtk-devel
40
41Requires:  %{name}-addons %{name}-geanydoc %{name}-geanylatex
42Requires:  %{name}-geanylipsum %{name}-geanylua %{name}-geanyprj %{name}-geanysendmail
43Requires:  %{name}-geanyvc %{name}-shiftcolumn %{name}-spellcheck
44Requires:  %{name}-codenav %{name}-treebrowser %{name}-geanyextrasel
45Requires:  %{name}-geanyinsertnum %{name}-pretty-printer %{name}-geanygendoc
46Requires:  %{name}-updatechecker %{name}-webhelper
47Requires:  %{name}-debugger %{name}-xmlsnippets %{name}-geanymacro %{name}-geanynumberedbookmarks
48Requires:  %{name}-geanypg %{name}-gproject %{name}-tableconvert
49Requires:  %{name}-geanyminiscript %{name}-geniuspaste %{name}-multiterm
50Requires:  %{name}-commander %{name}-markdown %{name}-scope
51
52Requires:  %{name}-pohelper %{name}-paritaghighlighter %{name}-autoclose %{name}-geanypy %{name}-defineformat
53
54%description
55Plugins for Geany. Plugins included are:
56* Addons (Various small Addons)
57* Code navigation (Navigate through your source code easily)
58* Commander (Provides a command panel for rapid access to any action)
59* Debugger (Enables debugging in Geany)
60* Geanydoc (Call specific documentation from within Geany)
61* Geanyextrasel (Additional features for selecting code)
62* GeanyGenDoc (Automatically generate documentation source code)
63#* GeanyGDB (Integration with GDB)
64* Geanyinsertnum (Insert huge number ranges with small efforts)
65* GeanyLaTeX (Improved Support for LaTeX documents)
66* GeanyLipsum (Inserting blocks of Lorem Ipsum text)
67* Geanylua (Support for Scripting with Lua)
68* GeanyMacro (User defined Macros for Geany)
69* GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
70* GeanyNumberedBookmarks (Provide users with 10 numbered Bookmarks)
71* GeniusPaste (Paste your code on your favorite pastebin)
72* GeanyPG (Encrypt, decrypt and verify signatures with GnuPG)
73* Geanyprj (Alternate project management for Geany)
74* GeanySendMail (Sending of documents from within Geany)
75* GeanyVC (Support for various Version Control Systems)
76* GProject (Extension of Geany's Project Management)
77* Markdown (provides a real-time preview of rendered Markdown)
78* MultiTerm (Multi-tabbed virtual terminal emulator)
79* Pretty-Print (XML Pretty Printer)
80* Scope (graphical GDB front-end with the normal functions)
81* Shiftcolumn (Moving blocks of text horizontally)
82* Spellcheck (Spell checking of documents or marked text)
83* Tableconvert (Helps on converting a tabulator separated selection into a table)
84* Treebrowser (Alternate file browser with tree view of folders)
85* Updatechecker (Automatically check for Geany updates)
86* Webhelper (Preview and Debug Web documents from within Geany using WebKit)
87* XMLSnippets (Extends XML/HTML tag autocompletion provided by Geany)
88
89
90This package is meta package to install all geany-plugins.
91
92%description -l ja
93Geany のプラグインです。プラグインには以下のものが含まれています。
94* Addons (色々な小さなアドオン)
95* Code navigation (ソースコード間を簡単に移動)
96* Commander (任意のアクションに迅速にアクセスするためのコマンドパネルを提供)
97* Debugger (Geany でデバッグを有効化)
98* Geanydoc (geany から固有のドキュメントを呼び出す)
99* Geanyextrasel (コード選択のための追加機能)
100* GeanyGenDoc (ソースコードから自動的にドキュメントの元を生成)
101#* GeanyGDB (GDB 統合環境を提供)
102* GeanyLaTex (LaTeX ドキュメントのサポートを改善)
103* GeanyLipsum (Lorem Ipsum テキストのブロックを挿入)
104* GeanySendMail (Geany からドキュメントの送信を許可)
105* GeanyVC (色々なバージョン管理システムのサポート)
106* GProject (Geany のプロジェクト管理拡張)
107* Geanyinsertnum (僅かな労力で膨大な範囲の番号を挿入)
108* Geanylua (lua スクリプトのサポートを提供)
109* GeanyMacro (Geany のユーザー定義マクロ)
110* GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
111* GeanyNumberedBookmarks (ユーザーに 10 個の番号付ブックマークを提供)
112* GeniusPaste (お気に入りの pastebin からコードを貼り付け)
113* GeanyPG (GnuPG で暗号化・復号化及び署名を検証する)
114* Geanyprj (geany の代替プロジェクト管理)
115* Markdown (provides a real-time preview of rendered Markdown)
116* MultiTerm (マルチタブの仮想端末エミュレーター)
117* Scope (graphical GDB front-end with the normal functions)
118* Shiftcolumn (テキストブロックを水平方向に移動)
119* Spellcheck (ドキュメントのスペルチェック)
120* Tableconvert (テーブルにタブで区切られた選択項目を変換する際役立つ)
121* Treebrowser (フォルダの内容をツリービューする代替ファイルブラウザ)
122* Pretty-Print (XML Pretty Printer)
123* Updatechecker (Geany の更新を自動的にチェック)
124* Webhelper (WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行)
125* XMLSnippets (Geany により提供される拡張 XML/HTML タグの自動補完)
126
127
128このパッケージは、geany-plugins をすべてインストールするための
129メタパッケージです。
130
131%package common
132Summary:   Common files used by all geany plugins
133Summary(ja): すべての Geany プラグインに用いられる共通ファイル
134Group:     Development/Tools
135Requires:  geany >= %{req_geany_ver}
136
137%description common
138This package contains some common files which are used by every Geany plugin,
139e.g. language translations.
140
141%description common -l ja
142このパッケージには、例えば翻訳ファイルなどの
143すべての Geany プラグイン で用いられる共通ファイルが含まれています。
144
145%package addons
146Summary:   Miscellaneous Addons for Geany
147Summary(ja): Geany のその他のアドオン
148Group:     Development/Tools
149Requires:  geany >= %{req_geany_ver}
150Requires:  geany-plugins-common = %{version}-%{release}
151Obsoletes: geany-plugin-addons
152
153%description addons
154This plugins consists of various small addons too small to justify their own
155plugin, but are useful to have. The following functionality is implemented:
156* Doclist: This addon places a new item in the toolbar and when clicked offers
157  a menu listing all open files plus the 'Close All' and 'Close Other
158  Documents' menu items. This can be useful to quickly access open files and
159  switch to them.
160* OpenURI: Adds 'Open URI' and 'Copy URI' menu items to the editor menu when
161  the word under the cursor looks like a URI. 'Open URI' uses the browser
162  command configured in Geany to open it.
163* Tasks:The tasks plugin goes through a file being edited and picks out lines
164  with "TODO" or "FIXME" in them. It collects the text after those words and
165  puts them in a new "Tasks" tab in the message window. Clicking on a task in
166  that tab takes you to the line in the file where the task was defined.
167* Systray: Adds a status icon to the notification area (systray) and provides
168  a simple popup menu with some basic actions. It can also be used to quickly
169  show and hide the Geany main window.
170
171
172%package autoclose
173Summary:   Intellectually helps you to write code
174Group:     Development/Tools
175Requires:  geany-plugins-common = %{version}-%{release}
176
177%description autoclose
178This plugin enables auto-closing features. Auto-closing works while you typing
179and intellectually helps you to write code.
180
181
182%package codenav
183Summary:    Navigate through your source code easily
184Summary(ja):  ソースコード間を簡単に移動
185Group:     Development/Tools
186Requires:  geany >= %{req_geany_ver}
187Requires:  geany-plugins-common = %{version}-%{release}
188
189%description codenav
190This plugin adds some facilities for navigating in the code.
191Actually, it will make it possible to:
192- switch between header and implementation
193- go to a file by typing its name
194
195
196%package commander
197Summary:    provides a command panel for rapid access to any action
198Summary(ja):  任意のアクションに迅速にアクセスするためのコマンドパネルを提供
199Group:     Development/Tools
200Requires:  geany >= %{req_geany_ver}
201Requires:  geany-plugins-common = %{version}-%{release}
202
203%description commander
204Commander is a plugin for Geany that provides a command panel
205for rapid access to any action.
206
207
208%package debugger
209Summary: enables debugging in Geany
210Group:      Development/Tools
211Requires:   geany-plugins-common = %{version}-%{release}
212Requires:   vte >= 0.24
213Obsoletes: geany-plugin-gdb
214Obsoletes: geany-plugins-geanygdb < %{version}-%{release}
215
216%description debugger
217Plugin enables debugging in Geany. Currently supports GDB only, but was
218developed with multiple debuggers support in mind, so the other backends
219support is planned as well.
220
221
222%package defineformat
223Summary:    Write multiline defines with aligned backslash
224Group:      Development/Tools
225Requires:   geany-plugins-common = %{version}-%{release}
226
227%description defineformat
228On-the-fly #define prettyprinter. This plugin will help you to
229write multiline defines with aligned backslash. After installed successfully,
230load the plugin in Geany's plugin manager. Try it: open C/C++ file and type:
231
232    #define A() do {
233
234
235%package geanydoc
236Summary:   Call documentation from within Geany
237Summary(ja): Geany 内からドキュメントを呼び出す
238Group:     Development/Tools
239Requires:  geany >= %{req_geany_ver}
240Requires:  geany-plugins-common = %{version}-%{release}
241
242%description geanydoc
243Geanydoc allows you to execute specific commands on the word under the cursor.
244This word is passed as an argument to the command. The output of the command
245can either be placed into a special buffer called "DOC" or can be used to
246execute an external program. Geanydoc is intended to be used for searching
247through API documentation.
248
249
250%package geanyextrasel
251Summary:   Additional features for selecting code
252Summary(ja): コード選択のための追加機能
253Group:     Development/Tools
254Requires:  geany >= %{req_geany_ver}
255Requires:  geany-plugins-common = %{version}-%{release}
256
257%description geanyextrasel
258Geanyextrasel provides some special features for selecting code, e.g. from
259opening brace to closed brace and so on. This plugin will be very useful for
260you if you're a programmer and working with much sourcecodes.
261
262
263#%package geanygdb
264#Summary:   Debugger Plugin for Geany using GDB
265#Summary(ja): GDB を使った Geany のデバッガプラグイン
266#Group:     Development/Tools
267#Requires:  geany >= %{req_geany_ver}
268#Requires:  geany-plugins-common = %{version}-%{release}
269#Requires:  gdb
270#Obsoletes: geany-plugin-gdb
271
272#%description geanygdb
273#GeanyGDB plugin provides an integrated debugging environment for the
274#GNU debugger (gdb).
275
276#%description geanygdb -l ja
277#GeanyGDB プラグインは GNU debugger (gdb) のための
278#統合的デバッグ環境を提供します。
279
280
281%package geanygendoc
282Summary:   Automatically generate documentation source code
283Group:     Development/Tools
284Requires:  geany >= %{req_geany_ver}
285Requires:  geany-plugins-common = %{version}-%{release}
286
287%description geanygendoc
288GeanyGenDoc is a plugin for Geany that aims to automatically generate
289documentation comment basis from the source code.
290
291You may also want to install the following packages which enable
292some extra features:
293 - Docutils (http://docutils.sourceforge.net/) -- or another implementation of
294   rst2html -- is needed to (re)generate the HTML manual.
295
296
297%package geanyinsertnum
298Summary:   Insert huge number ranges with small efforts
299Summary(ja):   僅かな労力で膨大な範囲の番号を挿入
300Group:     Development/Tools
301Requires:  geany >= %{req_geany_ver}
302Requires:  geany-plugins-common = %{version}-%{release}
303
304%description geanyinsertnum
305Geanyinsertnum replaces a (possibly zero-width) rectangular selection with
306integer numbers, using start/step/base etc. specified by the user. For
307practical reasons, the number of lines is limited to 500000.
308
309
310%package geanylatex
311Summary:   to improve LaTeX support plugin for Geany
312Summary(ja): Geany のための LaTeX サポート改善プラグイン
313Group:     Development/Tools
314Requires:  geany >= %{req_geany_ver}
315Requires:  geany-plugins-common = %{version}-%{release}
316Requires:  texlive
317Obsoletes: geany-plugin-latex
318
319%description geanylatex
320This plugin improves LaTeX support in Geany. It provides several templates for
321new documents, help with adding labels and inserting special characters,
322and much more.
323
324%description geanylatex -l ja
325このプラグインは Geany で LaTeX のサポートを改善するプラグインです。
326新しい文書のためのいくつかのテンプレート、
327ラベルの追加や特殊文字の挿入機能などを提供します。
328
329
330%package geanylipsum
331Summary:   Lorem Ipsum generator for Inserting Placeholder Text
332Group:     Development/Tools
333Requires:  geany >= %{req_geany_ver}
334Requires:  geany-plugins-common = %{version}-%{release}
335
336%description geanylipsum
337GeanyLipsum is a Lorem Ipsum generator for inserting placeholder text into a
338document.
339
340
341%package geanylua
342Summary:   Support developing Lua Scripting for Geany
343Summary(ja): Geany で Lua スクリプト開発をサポート
344Group:     Development/Tools
345Requires:  geany >= %{req_geany_ver}
346Requires:  geany-plugins-common = %{version}-%{release}
347Requires:  lua
348
349%description geanylua
350This plugin provides extensive support for developing in the lua programming
351language.
352
353%description geanylua -l ja
354このプラグインは、lua プログラミング言語で開発するための
355広範なサポートを提供します。
356
357
358%package geanymacro
359Summary:   User defined Macros for Geany
360Group:     Development/Tools
361Requires:  geany-plugins-common = %{version}-%{release}
362
363%description geanymacro
364GeanyMacro is a plugin to provide user defined macros for Geany. It started
365out as part of the ConText feature parity plugin, which was split into
366individual plugins to better suit Geany's ethos of being as light as
367possible while allowing users to select which features they want to add to
368the core editor. The idea was taken from a Text Editor for Windows called
369ConText.
370
371This plugin alows you to record and use your own macros. Macros are
372sequences of actions that can then be repeated with a single key
373combination. So if you had dozens of lines where you wanted to delete the
374last 2 characters, you could simple start recording, press End, Backspace,
375Backspace, down line and then stop recording. Then simply trigger the macro
376and it would automaticaly edit the line and move to the next. You could then
377just repeatedly trigger the macro to do as many lines as you want.
378
379
380%package geanyminiscript
381Summary:   Geany Mini-Script filter plugin
382Group:     Development/Tools
383Requires:  geany-plugins-common = %{version}-%{release}
384
385%description geanyminiscript
386gms is a Geany Mini-Script filter plugin.
387
388
389%package geanynumberedbookmarks
390Summary:   Provide users 10 numbered Bookmarks
391Group:     Development/Tools
392Requires:  geany-plugins-common = %{version}-%{release}
393
394%description geanynumberedbookmarks
395GeanyNumberedBookmarks is a plugin to provide users with 10 numbered
396bookmarks (in addition to the usual bookmarks). It started out as part of
397the ConText feature parity plugin, which was split into individual plugins
398to better suit Geany's ethos of being as light as possible while allowing
399users to select which features they want to add to the core editor. The idea
400was taken from a Text Editor for Windows called ConText.
401
402Normally if you had more than one bookmark, you would have to cycle through
403them until you reached the one you wanted. With this plugin you can go
404straight to the bookmark that you want with a single key combination.
405
406
407%package geanypg
408Summary:   encrypt, decrypt and verify signatures with GnuPG
409Group:     Development/Tools
410Requires:  geany-plugins-common = %{version}-%{release}
411Requires:  gpgme
412
413%description geanypg
414GeanyPG is a plugin for Geany that allows the user to encrypt, decrypt and
415verify signatures with GnuPG.
416
417
418%package geanyprj
419Summary:   Provides an alternate project management tool for Geany
420Summary(ja): Geany で代替プロジェクト管理ツールを提供
421Group:     Development/Tools
422Requires:  geany >= %{req_geany_ver}
423Requires:  geany-plugins-common = %{version}-%{release}
424
425%description geanyprj
426Geanyprj provides an alternate project management approach to Geany's built-in
427project facility. The idea is to be less a "session manager" as the built-in
428project management does: It allows/requires you to manually open and close
429project and allows you to store project files in different locations from
430project sources.
431
432Geanyprj takes a different approach:
433It never saves session information, so that project files can be stored in
434version control without constant noise from changes of opened files or cursor
435position. You also will never have to open/close projects manually. If a
436*.geanyprj file is found somewhere up in path it will be opened automatically.
437
438
439%package geanypy
440Summary:   Provides Python bindings for Geany
441Group:     Development/Tools
442Requires:  geany-plugins-common = %{version}-%{release}
443
444%description geanypy
445GeanyPy is based on the upstream at https://github.com/codebrainz/geanypy which
446is still under development, however it is useful as is. Parts of the existing
447API which mirror the Geany C API will probably not change unless the Geany API
448changes, however new API may be added. Also documentation is needed, contributions
449are welcome.
450
451Detailed information can be found in the documentation directory and at
452http://plugins.geany.org/geanypy.html
453
454
455%package geanysendmail
456Summary:   Send E-Mails from within Geany
457Summary(ja): Geany 内から E-Mail を送信するプラグイン
458Group:     Development/Tools
459Requires:  geany >= %{req_geany_ver}
460Requires:  geany-plugins-common = %{version}-%{release}
461
462%description geanysendmail
463GeanySendMail is a little plugin to send a document as attachment using the
464preferred mail client from inside Geany. It is similar to the envelope symbol
465of most office tools and requires a mail client that supports remote calls.
466
467
468%package geanyvc
469Summary:   Version Control plugin for Geany
470Summary(ja): Geany のバージョン管理プラグイン
471Group:     Development/Tools
472Requires:  geany >= %{req_geany_ver}
473Requires:  geany-plugins-common = %{version}-%{release}
474Obsoletes: geany-plugin-vc
475Provides:  geanyvc = %{version}-%{release}
476
477%description geanyvc
478Geanyvc is a plugin that provides a uniform way of accessing different version
479control systems from within the Geany IDE. Currently, support for the following
480version control systems is provided:
481
482* Bazaar
483* Git
484* Mercurial
485* Subversion
486* SVK
487* CVS
488
489%description geanyvc -l ja
490Geanyvc は Geany IDE から異なるバージョン管理システムにアクセスする
491均一的方法を提供するプラグインです。
492現在、サポートするバージョン管理システムは以下の通りです。
493
494* Bazaar
495* Git
496* Mercurial
497* Subversion
498* SVK
499* CVS
500
501
502%package geniuspaste
503Summary:   allows the user to paste the code from Geany into five different pastebins
504Group:     Development/Tools
505Requires:  geany-plugins-common = %{version}-%{release}
506
507%description geniuspaste
508This plugin allows the user to paste the code from Geany into five different
509pastebins. At the moment it supports this services:
510
511* codepad.org
512* tinypaste.com
513* pastebin.geany.org
514* dpaste.de
515* sprunge.us
516
517
518%package gproject
519Summary:   Extension of Geany's project management
520Group:     Development/Tools
521Requires:  geany-plugins-common = %{version}-%{release}
522
523%description gproject
524GProject is an extension of Geany's project management displaying a tree of
525files belonging to the project in the sidebar. In addition, it enables quick
526swapping between header and source files, searching project files by name
527and more. The plugin was created with big projects in mind so everything
528works fast enough even with projects consisting of hundreds of thousands of
529files.
530
531
532%package markdown
533Summary:   provides a real-time preview of rendered Markdown
534Group:     Development/Tools
535Requires:  geany-plugins-common = %{version}-%{release}
536
537%description markdown
538This plugin provides a real-time preview of rendered Markdown, that is,
539`Markdown <http://daringfireball.net/projects/markdown>`_ converted to HTML
540and inserted into an HTML template and loaded into a
541`WebKit <http://www.webkit.org>`_ view.
542
543
544%package multiterm
545Summary:   supports multiple terminals
546Group:     Development/Tools
547Requires:  geany-plugins-common = %{version}-%{release}
548
549%description multiterm
550MultiTerm is similar to Geany's built-in VTE terminal except that it
551supports multiple terminals in tabs and supports different shells in
552each of the terminal tabs.
553
554
555%package pairtaghighlighter
556Summary:   Extension of Geany's project management
557Group:     Development/Tools
558Requires:  geany-plugins-common = %{version}-%{release}
559
560%description pairtaghighlighter
561Find and highlight matching opening/closing HTML tags by clicking or moving the
562cursor inside a tag.
563
564
565%package pohelper
566Summary:   Translation Helper is a plugin for Geany
567Group:     Development/Tools
568Requires:  geany-plugins-common = %{version}-%{release}
569
570%description pohelper
571A plugin for Geany that improves the support for GetText translation files, by
572providing various features specific to this format and to translators.
573
574Features:
575
576* Navigation between all, untranslated or fuzzy messages;
577* Reformatting of the translation (reflow);
578* Toggling the fuzziness of a translation;
579* Pasting of the untranslated string to the translation;
580* Automatic updating of the translation metadata.
581
582
583%package pretty-printer
584Summary:   XML pretty printing plugin for Geany
585Group:     Development/Tools
586Requires:  geany >= %{req_geany_ver}
587Requires:  geany-plugins-common = %{version}-%{release}
588Requires:  libxml2 >= 2.6.27
589Obsoletes: %{name}-pretty-print
590
591%description pretty-printer
592Plugin for Geany to easily beautify XML code.
593
594
595%package scope
596Summary:   graphical GDB front-end with the normal functions
597Group:     Development/Tools
598Requires:  geany >= %{req_geany_ver}
599Requires:  geany-plugins-common = %{version}-%{release}
600Requires:  gdb
601
602%description scope
603Scope is a graphical GDB front-end with the normal functions you would
604expect (stepping, breakpoints...), and a few notable features:
605
606- The comminication between Scope and gdb is asynchronous.
607- You can enter any gdb command, at any time (of course, for the command to
608  be executed, gdb must be[come] available).
609- All gdb I/O (along with some other messages) is displayed in a
610  terminal-like "Debug Console".
611  Whenever you find the GUI lacking, simply switch to that console and work
612  directly with gdb.
613- 7-bit/Locale/UTF-8 support for values.
614
615
616%package shiftcolumn
617Summary:   Move Blocks of Text horizontally
618Summary(ja): テキストブロックを水平方向に移動
619Group:     Development/Tools
620Requires:  geany >= %{req_geany_ver}
621Requires:  geany-plugins-common = %{version}-%{release}
622
623%description shiftcolumn
624Shiftcolumn allows you to move blocks of text horizontally in Geany.
625
626%description shiftcolumn -l ja
627Shiftcolumn は Geany 内でテキストブロックを水平方向に移動させることが
628できます。
629
630%package spellcheck
631Summary:   Spellcheck Text in Geany using the Enchant Library
632Summary(ja): Enchant ライブラリを使い Geany でスペルチェック
633Group:     Development/Tools
634Requires:  geany >= %{req_geany_ver}
635Requires:  geany-plugins-common = %{version}-%{release}
636Requires:  enchant
637
638%description spellcheck
639Spellcheck checks the selected text (or the whole document) with the spellcheck
640library Enchant.
641
642%description spellcheck -l ja
643Spellcheck は、選択したテキスト(または文書全体)のスペルチェックを
644スペルチェックライブラリの Enchant で行います。
645
646
647%package treebrowser
648Summary:   Alternate file browser plugin providing a tree view of directories.
649Summary(ja): ディレクトリのツリービューを提供する代替ファイルブラウザプラグイン
650Group:     Development/Tools
651Requires:  geany >= %{req_geany_ver}
652Requires:  geany-plugins-common = %{version}-%{release}
653
654%description treebrowser
655The tree browser plugin for Geany provides an alternate way to browse through
656your files. It displays files and directories in a tree view and has more
657features than the file browser plugin delivered with Geany itself.
658
659
660%package tableconvert
661Summary:   Helps on converting a tabulator separated selection into a table
662Group:     Development/Tools
663Requires:  geany-plugins-common = %{version}-%{release}
664
665%description tableconvert
666Tableconvert is a plugin which helps on converting a tabulator separated
667selection into a table.
668
669
670%package updatechecker
671Summary:   Automatically check for Geany updates
672Summary(ja): Geany の更新を自動的にチェック
673Group:     Development/Tools
674Requires:  geany-plugins-common = %{version}-%{release}
675
676%description updatechecker
677UpdateChecker is a plugin for Geany, which is able to check whether there is
678a more recent version of Geany available.
679
680
681%package webhelper
682Summary:   Preview and Debug Web documents from within Geany using WebKit
683Summary(ja): WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行
684Group:     Development/Tools
685Requires:  geany-plugins-common = %{version}-%{release}
686
687%description webhelper
688WebHelper is a plugin for Geany that provides some web development
689facilities, such as a web page preview and some debugging tools (web
690inspector).
691
692Prominent features:
693
694* A basic web view, allowing to display any web page (using WebKit)
695* Possible automatic reloading of the web view upon document saving
696* A web inspector/debugging tool for the web view's content (including a
697  JavaScript console, a viewer and editor of processed HTML and CSS, a network
698  usage analysis tool and many more, thanks to WebKit).
699
700
701%package xmlsnippets
702Summary:   Extends XML/HTML tag autocompletion provided by Geany
703Group:     Development/Tools
704Requires:  geany-plugins-common = %{version}-%{release}
705
706%description xmlsnippets
707This plugin extends XML/HTML tag autocompletion provided by Geany. It
708automatically inserts a matching snippet after you type an opening tag.
709
710
711%prep
712%setup -q
713#%patch0 -p1
714
715
716%build
717%configure --docdir=%{geany_plug_docdir}
718make %{?_smp_mflags}
719
720
721%install
722rm -rf $RPM_BUILD_ROOT
723make install -p DESTDIR=$RPM_BUILD_ROOT
724
725# Remove static library *.la files
726find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' \;
727
728# Remove zero-length files
729find $RPM_BUILD_ROOT -type f -empty -delete
730
731# copy geanylatex document images
732cp -pr geanylatex/doc/img/ $RPM_BUILD_ROOT%{geany_plug_docdir}/geanylatex/
733
734%find_lang %{name}
735
736
737%clean
738rm -rf $RPM_BUILD_ROOT
739
740%files
741
742%files common -f %{name}.lang
743%defattr(-,root,root,-)
744%dir %{_libdir}/%{name}/
745%dir %{_datadir}/%{name}/
746
747
748%files addons
749%defattr(-,root,root,-)
750%doc %{geany_plug_docdir}/addons
751%{_libdir}/geany/addons.so
752
753
754%files autoclose
755%defattr(-,root,root,-)
756%doc %{geany_plug_docdir}/autoclose
757%{_libdir}/geany/autoclose.so
758
759
760%files codenav
761%defattr(-,root,root,-)
762%doc %{geany_plug_docdir}/commander
763%{_libdir}/geany/commander.so
764
765
766%files commander
767%defattr(-,root,root,-)
768%doc %{geany_plug_docdir}/codenav
769%{_libdir}/geany/codenav.so
770
771
772%files debugger
773%defattr(-,root,root,-)
774%doc %{geany_plug_docdir}/debugger
775%{_datadir}/%{name}/debugger/
776%{_libdir}/geany/debugger.so
777
778
779%files defineformat
780%defattr(-,root,root,-)
781%doc %{geany_plug_docdir}/defineformat
782%{_libdir}/geany/defineformat.so
783
784
785%files geanydoc
786%defattr(-,root,root,-)
787%doc %{geany_plug_docdir}/geanydoc/
788%{_libdir}/geany/geanydoc.so
789
790
791%files geanyextrasel
792%defattr(-,root,root,-)
793%doc %{geany_plug_docdir}/geanyextrasel/
794%{_libdir}/geany/geanyextrasel.so
795
796
797#%files geanygdb
798#%defattr(-,root,root,-)
799#%doc %{geany_plug_docdir}/geanygdb/
800#%{_libdir}/geany/geanygdb.so
801#%{_libexecdir}/geany-plugins/geanygdb/ttyhelper
802
803
804%files geanygendoc
805%defattr(-,root,root,-)
806%doc %{geany_plug_docdir}/geanygendoc/
807%{_libdir}/geany/geanygendoc.so
808%{_datadir}/%{name}/geanygendoc/
809
810
811%files geanyinsertnum
812%defattr(-,root,root,-)
813%doc %{geany_plug_docdir}/geanyinsertnum/
814%{_libdir}/geany/geanyinsertnum.so
815
816
817%files geanylatex
818%defattr(-,root,root,-)
819%doc %{geany_plug_docdir}/geanylatex/
820%{_libdir}/geany/geanylatex.so
821
822
823%files geanylipsum
824%defattr(-,root,root,-)
825%doc %{geany_plug_docdir}/geanylipsum/
826%{_libdir}/geany/geanylipsum.so
827
828
829%files geanylua
830%defattr(-,root,root,-)
831%doc %{geany_plug_docdir}/geanylua/
832%{_libdir}/geany/geanylua.so
833%{_datadir}/%{name}/geanylua/
834%{_libdir}/%{name}/geanylua/
835
836
837%files geanymacro
838%defattr(-,root,root,-)
839%doc %{geany_plug_docdir}/geanymacro/
840%{_libdir}/geany/geanymacro.so
841
842
843%files geanyminiscript
844%defattr(-,root,root,-)
845%doc %{geany_plug_docdir}/geanyminiscript/
846%{_libdir}/geany/geanyminiscript.so
847
848
849%files geanynumberedbookmarks
850%defattr(-,root,root,-)
851%doc %{geany_plug_docdir}/geanynumberedbookmarks/
852%{_libdir}/geany/geanynumberedbookmarks.so
853
854
855%files geanypg
856%defattr(-,root,root,-)
857%doc %{geany_plug_docdir}/geanypg/
858%{_libdir}/geany/geanypg.so
859
860
861%files geanyprj
862%defattr(-,root,root,-)
863%doc %{geany_plug_docdir}/geanyprj/
864%{_libdir}/geany/geanyprj.so
865
866
867%files geanypy
868%defattr(-,root,root,-)
869%doc %{geany_plug_docdir}/geanypy/
870%{_libdir}/geany/geanypy.so
871%{_libdir}/geany/geanypy/geany/*
872%{_datadir}/geany/geanypy/plugins/*
873
874
875%files geanysendmail
876%defattr(-,root,root,-)
877%doc %{geany_plug_docdir}/geanysendmail/
878%{_libdir}/geany/geanysendmail.so
879
880
881%files gproject
882%defattr(-,root,root,-)
883%doc %{geany_plug_docdir}/gproject/
884%{_datadir}/icons/hicolor/16x16/apps/gproject-*.png
885%{_libdir}/geany/gproject.so
886
887
888%files geanyvc
889%defattr(-,root,root,-)
890%doc %{geany_plug_docdir}/geanyvc/
891%{_libdir}/geany/geanyvc.so
892
893
894%files geniuspaste
895%defattr(-,root,root,-)
896%doc %{geany_plug_docdir}/geniuspaste/
897%{_libdir}/geany/geniuspaste.so
898
899
900%files markdown
901%defattr(-,root,root,-)
902%doc %{geany_plug_docdir}/markdown/
903%{_libdir}/geany/markdown.so
904
905
906%files multiterm
907%defattr(-,root,root,-)
908%doc %{geany_plug_docdir}/multiterm/
909%{_libdir}/geany/multiterm.so
910
911
912%files pairtaghighlighter
913%defattr(-,root,root,-)
914%doc %{geany_plug_docdir}/pairtaghighlighter/
915%{_libdir}/geany/pairtaghighlighter.so
916
917
918%files pohelper
919%defattr(-,root,root,-)
920%doc %{geany_plug_docdir}/pohelper/
921%{_libdir}/geany/pohelper.so
922%{_datadir}/geany-plugins/pohelper/menus.ui
923
924
925%files pretty-printer
926%defattr(-,root,root,-)
927%{_libdir}/geany/pretty-printer.so
928
929
930%files scope
931%defattr(-,root,root,-)
932%doc %{geany_plug_docdir}/scope/
933%{_libdir}/geany/scope.so
934%{_datadir}/%{name}/scope/
935
936
937%files shiftcolumn
938%defattr(-,root,root,-)
939%doc %{geany_plug_docdir}/shiftcolumn/
940%{_libdir}/geany/shiftcolumn.so
941
942
943%files spellcheck
944%defattr(-,root,root,-)
945%doc %{geany_plug_docdir}/spellcheck/
946%{_libdir}/geany/spellcheck.so
947
948
949%files tableconvert
950%defattr(-,root,root,-)
951%doc %{geany_plug_docdir}/tableconvert/
952%{_libdir}/geany/tableconvert.so
953
954
955%files treebrowser
956%defattr(-,root,root,-)
957%doc %{geany_plug_docdir}/treebrowser/
958%{_libdir}/geany/treebrowser.so
959
960
961%files updatechecker
962%defattr(-,root,root,-)
963%doc %{geany_plug_docdir}/updatechecker/
964%{_libdir}/geany/updatechecker.so
965
966
967%files webhelper
968%defattr(-,root,root,-)
969%doc %{geany_plug_docdir}/webhelper/
970%{_libdir}/geany/webhelper.so
971
972
973%files xmlsnippets
974%defattr(-,root,root,-)
975%doc %{geany_plug_docdir}/xmlsnippets/
976%{_libdir}/geany/xmlsnippets.so
977
978
979%changelog
980* Sat May 17 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.24-1
981- new upstream release
982- added new plugins
983  - Pohelper, PariTagHighlighter, Autoclose, Geanypy, Defineformat
984- added BuildRequires: python-devel, pygtk2-devel
985
986* Sat Mar 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.23-2
987- fixed meta package
988
989* Sat Mar 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.23-1
990- new upstream release
991- deleted Patch0
992- added new plugins
993  - Commander, Markdown, Scope
994
995* Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
996- new upstream release
997- added BuildRequires: vala-devel
998- added new plugins
999  - GeanyMiniScript, GeniusPaste, MultiTerm
1000- added Patch0 to fix installation path of geanylatex documents
1001- renamed pretty-print to pretty-printer
1002- obsoleted geany-plugins-geanygdb to provide same function as geany-plugins-debugger
1003
1004* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-2
1005- added BuildRequires: vte-devel, WebKit-gtk-devel, gtk2-devel, glib2-devel,
1006  gdk-pixbuf2-devel, pango-devel, python-docutils
1007- fixed %%changelog in Sat Oct 29 2011
1008
1009* Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-1
1010- new upstream release
1011- added new plugins
1012  - Debugger, GeanyPG, GeanyMacro, GeanyNumberedBookmarks, GProject, Tableconvert, XMLSnippets
1013- added BuildRequires: gpgme-devel
1014
1015* Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.20-1
1016- new upstream release
1017- added geany-plugins-updatechecker and geany-plugins-webhelper
1018
1019* Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-3
1020- added geany-plugins-geanygendoc
1021- added BuildRequires: ctpl-devel >= 0.2
1022- changed geany-plugins-latex Requires: tetex to Requires: texlive
1023- removed zero-length documentation files
1024
1025* Sun Jul 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-2
1026- correct license to GPLv3+
1027- added BuildRequires: libxml2-devel >= 2.6.27
1028- added Requires: geany-plugins-codenav, geany-plugins-treebrowser,
1029  geany-plugins-geanyextrasel, geany-plugins-geanyinsertnum, geany-plugins-pretty-print
1030
1031* Mon Jun 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-1
1032- new upstream release
1033
1034* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-3
1035- fixed Requires geany-plugins
1036- applied new naming policy to spec
1037
1038* Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-2
1039- fixed Obsoletes geany-plugin-addons, geany-plugin-gdb, geany-plugin-latex, geany-plugin-vc
1040  (see [BTS:VineLinux:0894])
1041- proved Summary(ja)
1042
1043* Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-1
1044- initial build for Vine Linux (instead of now provided some geany-plugins)
1045
1046* Sat Oct 31 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.18-1
1047- update to new upstream release
1048
1049* Sun Aug 16 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-6
1050- build against and require geany 0.18
1051
1052* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.17.1-5
1053- Use bzipped upstream tarball.
1054
1055* Sat Jul 25 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-4
1056- write BuildRequires at the beginning of this file
1057
1058* Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-3
1059- remove Requires: geany from the main package
1060- change Group to Development/Tools
1061- add release to the geanyvc Provides
1062- entirely remove %%files stanza for the main package
1063
1064* Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-2
1065- fix the required geany version also in the subpackages
1066- remove the requires to sub-packages to avoid building the metapackage since
1067  all geany plugins also can be installed by something like
1068  'yum install geany-plugins-*'
1069- fix the requires of geany-plugins-common to include the release
1070
1071* Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-1
1072- bump upstream version to 0.17.1
1073- fix required geany version to be 0.16 at the present
1074
1075* Sat Jul 18 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-5
1076- add Requires for metapackage
1077- rename subpackages back to geany-plugins-* instead of geany-plugin-*
1078
1079* Fri Jul 17 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-4
1080- readd the geany_plug_docdir global to fix the versioned directory issue for
1081  documentation files
1082- replace geany-plugins with %%{name} to be more consistent with macro usage
1083- remove zero-length documentation files
1084- fix the changelog
1085- remove static *.la-files
1086- split up packages
1087
1088* Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-3
1089- add %%{_datadir}/geany-plugins/geanylua/ to %%files-section
1090
1091* Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-2
1092- fix %%files-section again, thanks to Jonathan for the hint.
1093
1094* Tue Jul 14 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-1
1095- update URL to plugins.geany.org
1096
1097* Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.2
1098- Add Obsoletes for geanyvc
1099- Add more BuildRequires and Requires
1100
1101* Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.1
1102- Update to 0.17 (first upstream release of tarball)
1103- Fix handling of docs
1104- Spec file cleanups
1105
1106* Mon Jun 22 2009 Pingou <pingou@pingoured.fr> 0.1-1
1107- First RPM for Fedora
Note: See TracBrowser for help on using the repository browser.