source: projects/specs/trunk/g/gdome2/gdome2-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define nam     gdome2
2%define ver     0.8.1
3%define rel     1%{?_dist_release}
4
5Summary:        DOM level2 library for accessing XML files
6Summary(ja):    XML 用 DOM レベル 2 ライブラリ
7Name:           %nam
8Version:        %ver
9Release:        %rel
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://gdome2.cs.unibo.it/
13Source:         http://gdome2.cs.unibo.it/tarball/%{nam}-%{ver}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  libxml2-devel >= 2.4.26
17BuildRequires:  glib2-devel gtk-doc
18
19%description
20 gdome2 is a fast, light  and  complete  DOM level2  implementation
21based on libxml2. Although it has been written for the GNOME project,
22it can be used stand-alone.
23 A DOM implementation  (also called  a host implementation) is what
24makes a parsed XML or HTML document available for processing via the
25DOM interface.
26 gdome2  currently supports the "Core", "XML", "Events" and
27"MutationEvents" modules from the DOM2 Recommendation (see
28http://www.w3.org/TR/DOM-Level-2-Core/ and http://www.w3.org/TR/DOM-L
29evel-2-Events/), and is supposed to become  a full implementation of
30all the DOM Level2 standard.
31 Now gdome2 also partially  supports the XPath  module from the DOM
32level 3 drafts.
33
34%package devel
35Summary: Development files for gdome2
36Summary(ja): gdome2 の開発用ファイル
37Group: Development/Libraries
38Requires: gdome2 = %{ver}-%{rel}
39Requires: glib2-devel
40Requires: libxml2-devel >= 2.4.26
41
42%description devel
43 This  package  contains the header  files and static  libraries for
44developing with gdome2.
45 gdome2  is a fast, light  and  complete  DOM level2  implementation
46based on libxml2. Although it has been written for the GNOME project,
47it can be used stand-alone.
48 A  DOM implementation  (also called  a host implementation) is what
49makes a parsed  XML or HTML document available for processing via the
50DOM interface.
51 gdome2 currently supports the "Core", "XML", "Events" and
52"MutationEvents"  modules   from   the   DOM2   Recommendation   (see
53http://www.w3.org/TR/DOM-Level-2-Core/ and http://www.w3.org/TR/DOM-L
54evel-2-Events/), and  is supposed to become  a full implementation of
55all the DOM Level2 standard.
56 Now gdome2 also partially supports the XPath module from the DOM
57level 3 drafts.
58
59%prep
60%setup -q
61
62%build
63if [ ! -f configure ]; then
64  ./autogen.sh --prefix=%{_prefix}
65fi
66
67%configure
68
69if [ "$SMP" != "" ]; then
70  (make "MAKE=make -k -j $SMP"; exit 0)
71  make
72else
73  make
74fi
75
76make
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%makeinstall
81
82## remove unuse files
83rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
84
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(-, root, root)
95%doc AUTHORS MAINTAINERS ChangeLog INSTALL NEWS README COPYING COPYING.LIB
96%{_libdir}/lib*.so.*
97
98%files devel
99%defattr(-, root, root)
100#doc gtk-doc/html/*.html
101%{_mandir}/man1/gdome-config.1*
102%{_bindir}/gdome-config
103%{_includedir}/*
104%{_libdir}/lib*.so
105%{_libdir}/*a
106%{_libdir}/*.sh
107%{_datadir}/aclocal/gdome2.m4
108%{_datadir}/gtk-doc/html/*
109%{_libdir}/pkgconfig/gdome2.pc
110
111%changelog
112* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1vl5
113- applied new versioning policy, spec in utf-8
114- removed *.la
115- added japanease summary
116
117* Sat Dec 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.1-0vl2
118- updated BuildRequires
119- changed Group to System Environment/Libraries
120
121* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 0.8.1-0vl1
122- new upstream version
123
124* Sat Jan 17 2004 IWAI, Masaharu <iwai@alib.jp> 0.8.0-0vl1
125- build for VineSeed Plus
126- fix BuildRequires: glib-devel
127
128* Sun Dec 29 2002 Paolo Casarini <paolo@casarini.org>
129  patch provided by Oron Peled <oron@actcom.co.il>
130  - %defattr(-,root,root) wasn't set for documents in the devel
131    package. This cause wrong ownership of docs in non-root builds.
132  - Update URL: and Source: locations
133  - s/Copyright:/License:/
134* Sun Mar 31 2002 Paolo Casarini <paolo@casarini.org>
135  - updated descriptions and summaries
136* Sat Dec 15 2001 Paolo Casarini <paolo@casarini.org>
137  - updated descriptions and summaries
138* Tue Oct 23 2001 Paolo Casarini <paolo@casarini.org>
139  - added the gdome-config.1 man page
140* Mon Aug 6 2001 Paolo Casarini <paolo@casarini.org>
141  - Merge of the Andrew release with mine
142* Thu Aug 2 2001 Andrew Chatham <andrew.chatham@duke.edu>
143  - Spec file created
144* Tue Jul 3 2001 Paolo Casarini <paolo@casarini.org>
145  - Initial release
146
Note: See TracBrowser for help on using the repository browser.