source: projects/specs/trunk/g/gdm/gdm-vl.spec @ 521

Revision 521, 32.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pango_version 1.22.0
2%define gtk2_version 2.14.0
3%define libglade2_version 2.6.0
4%define librsvg2_version 2.22.0
5%define libxml2_version 2.5.10
6%define rarian 0.8
7%define pam_version 0.99.8
8%define desktop_file_utils_version 0.3
9%define gail_version 1.18.0
10%define consolekit_version 0.2.7
11%define hal_version 0.5.9
12
13Summary: The GNOME Display Manager.
14Summary(ja): GNOME ディスプレイマネージャ
15Name: gdm
16Version: 2.20.10
17Release: 6%{?_dist_release}
18License: LGPL/GPL
19Group: User Interface/X
20URL: ftp://ftp.gnome.org/pub/GNOME/sources/gdm/
21
22Source: %{name}-%{version}.tar.bz2
23Source1: gdm-pam
24Source2: gdm-autologin-pam
25Source3: gdmsetup-pam
26Source4: 90-grant-audio-devices-to-gdm.fdi
27Source10: gdm-theme-vine-5.2.tar.bz2
28Source12: gnome.desktop
29Source13: system-hibernate.png
30Source14: gdm-2.20.10-ja.po
31
32## patches from ubuntu
33Patch11: gdm-2.20.10-powermanagement.patch
34Patch18: gdm-2.20.10-combobox-language-selector.patch
35
36## patches for vine
37Patch100: gdm-2.20.10-vine.patch
38Patch101: gdm-2.20.8-gdmsetup-usermode.patch
39Patch110: gdm-2.18.1-vine-locale.patch
40
41# security fix
42
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45
46Prereq: shadow-utils
47Prereq: scrollkeeper >= %{scrollkeeper_version}
48Requires: pam >= %{pam_version}
49Requires: hal >= %{hal_version}
50Requires: ConsoleKit >= %{consolekit_version}
51Requires: usermode-gtk
52Requires: xinitrc
53Requires: xorg-x11-xdm
54Requires: util-linux
55Requires: vine-backgrounds >= 4.0
56BuildRequires: scrollkeeper >= %{scrollkeeper_version}
57BuildRequires: pango-devel >= %{pango_version}
58BuildRequires: gtk2-devel >= %{gtk2_version}
59BuildRequires: libglade2-devel >= %{libglade2_version}
60BuildRequires: librsvg2-devel >= %{librsvg2_version}
61BuildRequires: libxml2-devel >= %{libxml2_version}
62BuildRequires: usermode
63BuildRequires: pam-devel >= %{pam_version}
64BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
65BuildRequires: gail-devel >= %{gail_version}
66BuildRequires: libtool, automake, autoconf
67BuildRequires: ConsoleKit
68BuildRequires: libdmx-devel, audit-libs-devel
69
70Vendor: Project Vine
71Distribution: Vine Linux
72Packager: daisuke
73
74%description
75Gdm (the GNOME Display Manager) is a highly configurable
76reimplementation of xdm, the X Display Manager. Gdm allows you to log
77into your system with the X Window System running and supports running
78several different X sessions on your local machine at the same time.
79
80%prep
81%setup -q
82
83cp -f %{SOURCE1} config/gdm
84cp -f %{SOURCE2} config/gdm-autologin
85cp -f %{SOURCE3} utils/gdmsetup-pam
86
87cp -f %{SOURCE14} po/ja.po
88
89%patch11 -p1 -b .powermanagement
90%patch18 -p1 -b .combobox-language-selector
91
92%patch100 -p1 -b .vine
93%patch101 -p1 -b .gdmsetup-usermode
94%patch110 -p1 -b .vine-lcoale
95
96cp -f %{SOURCE13} pixmaps/24x24/
97
98%build
99intltoolize --force --copy
100aclocal
101libtoolize --force --copy
102automake --add-missing
103autoconf
104autoheader
105%configure --sysconfdir=%{_sysconfdir}/X11 \
106           --with-pam-prefix=%{_sysconfdir} \
107           --enable-console-helper --disable-scrollkeeper \
108           --with-console-kit
109%__make
110
111%install
112[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
113
114make install DESTDIR=$RPM_BUILD_ROOT
115
116# docs go elsewhere
117rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
118
119# change default Init script for :0 to be Vine Linux default
120ln -sf ../../xdm/Xsetup_0 $RPM_BUILD_ROOT/etc/X11/gdm/Init/:0
121
122# create log dir
123mkdir -p $RPM_BUILD_ROOT%{_var}/log/gdm
124
125# remove the gdm Xsession as we're using the xdm one
126rm -f $RPM_BUILD_ROOT%{_sysconfdir}/X11/gdm/Xsession
127
128rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.a
129rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
130
131## remove the other gnome session file, since we put it in gnome-session
132rm -rf $RPM_BUILD_ROOT%{_datadir}/xsessions
133
134# use consolehelper for gdmsetup
135ln -sf consolehelper $RPM_BUILD_ROOT%{_bindir}/gdmsetup
136
137# fix the "login photo" file
138desktop-file-install --vendor "" --delete-original          \
139  --dir $RPM_BUILD_ROOT%{_datadir}/gdm/applications         \
140  --remove-key NetShowIn                                    \
141  --add-category X-GNOME-PersonalSettings                   \
142  $RPM_BUILD_ROOT%{_datadir}/gdm/applications/gdmphotosetup.desktop
143
144# broken install-data-local in gui/Makefile.am makes this necessary
145(cd $RPM_BUILD_ROOT%{_bindir} && ln -sf gdmXnestchooser gdmXnest)
146
147# grant access to alsa and oss devices for the gdm user
148mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/20thirdparty
149cp %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/20thirdparty
150
151# use ja_JP.eucJP for Japanese Locale.
152#perl -pi -e 's/ja_JP.UTF-8/ja_JP.eucJP/g' $RPM_BUILD_ROOT%{_sysconfdir}/X11/gdm/locale.alias
153
154# install Vine Theme
155tar xzvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_datadir}/gdm/themes/
156
157# install WindowMaker.desktop, gnome.desktop
158# XXX: this should be included in each desktop environment package.
159mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/dm/Sessions/
160cp %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/X11/dm/Sessions/
161
162rm -rf $RPM_BUILD_ROOT%{_var}/lib/scrollkeeper
163
164%find_lang gdm
165
166%clean
167[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
168
169%pre
170/usr/sbin/useradd -M -u 42 -d %{_localstatedir}/gdm -s /sbin/nologin -r gdm > /dev/null 2>&1
171/usr/sbin/usermod -d %{_localstatedir}/gdm -s /sbin/nologin gdm >/dev/null 2>&1
172# ignore errors, as we can't disambiguate between gdm already existed
173# and couldn't create account with the current adduser.
174exit 0
175
176%post
177/sbin/ldconfig
178scrollkeeper-update >& /dev/null ||:
179
180touch --no-create %{_datadir}/icons/hicolor
181if [ -x /usr/bin/gtk-update-icon-cache ]; then
182  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
183fi
184
185# if the user already has a config file, then migrate it to the new
186# location; rpm will ensure that old file will be renamed
187
188custom=/etc/X11/gdm/custom.conf
189
190if [ $1 -ge 2 ] ; then
191    if [ -f /usr/share/gdm/config/gdm.conf-custom ]; then
192        oldconffile=/usr/share/gdm/config/gdm.conf-custom
193    elif [ -f /etc/X11/gdm/gdm.conf ]; then
194        oldconffile=/etc/X11/gdm/gdm.conf
195    fi
196
197    # Comment out some entries from the custom config file that may
198    # have changed locations in the update.  Also move various
199    # elements to their new locations.
200
201    [ -n "$oldconffile" ] && sed \
202    -e 's@^command=/usr/X11R6/bin/X@#command=/usr/bin/Xorg@' \
203    -e 's@^Xnest=/usr/X11R6/bin/Xnest@#Xnest=/usr/bin/Xnest@' \
204    -e 's@^BaseXsession=/etc/X11/xdm/Xsession@#BaseXsession=/etc/X11/xdm/Xsession@' \
205    -e 's@^BaseXsession=/etc/gdm/Xsession@#&@' \
206    -e 's@^Greeter=/usr/bin/gdmgreeter@#Greeter=/usr/libexec/gdmgreeter@' \
207    -e 's@^RemoteGreeter=/usr/bin/gdmlogin@#RemoteGreeter=/usr/libexec/gdmlogin@' \
208    -e 's@^GraphicalTheme=Vine@#&@' \
209    -e 's@^BackgroundColor=#27408b@#&@' \
210    -e 's@^DefaultPath=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin@#&@' \
211    -e 's@^RootPath=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin@#&@' \
212    -e 's@^HostImageDir=/usr/share/hosts/@#HostImageDir=/usr/share/pixmaps/faces/@' \
213    -e 's@^LogDir=/var/log/gdm@#&@' \
214    -e 's@^PostLoginScriptDir=/etc/X11/gdm/PostLogin@#&@' \
215    -e 's@^PreLoginScriptDir=/etc/X11/gdm/PreLogin@#&@' \
216    -e 's@^PreSessionScriptDir=/etc/X11/gdm/PreSession@#&@' \
217    -e 's@^PostSessionScriptDir=/etc/X11/gdm/PostSession@#&@' \
218    -e 's@^DisplayInitDir=/var/run/gdm.pid@#&@' \
219    -e 's@^RebootCommand=/sbin/reboot;/sbin/shutdown -r now;/usr/sbin/shutdown -r now;/usr/bin/reboot@#&@' \
220    -e 's@^HaltCommand=/sbin/poweroff;/sbin/shutdown -h now;/usr/sbin/shutdown -h now;/usr/bin/poweroff@#&@' \
221    -e 's@^ServAuthDir=/var/lib/gdm@#&@' \
222    -e 's@^ServAuthDir=/var/gdm@#&@' \
223    -e 's@^Greeter=/usr/bin/gdmlogin@Greeter=/usr/libexec/gdmlogin@' \
224    -e 's@^RemoteGreeter=/usr/bin/gdmgreeter@RemoteGreeter=/usr/libexec/gdmgreeter@' \
225    $oldconffile > $custom
226fi
227
228/usr/sbin/gdm-safe-restart >/dev/null 2>&1 || :
229
230exit 0
231
232%postun
233/sbin/ldconfig
234scrollkeeper-update >& /dev/null ||:
235touch --no-create %{_datadir}/icons/hicolor
236if [ -x /usr/bin/gtk-update-icon-cache ]; then
237  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
238fi
239
240%files -f gdm.lang
241%defattr(-, root, root)
242
243%doc AUTHORS COPYING ChangeLog NEWS README TODO
244
245%dir /etc/X11/gdm
246# Not sure which package /etc/X11/dm dir should belong to,
247# this dir was agreed on among KDM and GDM maintainer to host
248# the new session setup
249%config /etc/X11/dm/Sessions/*
250%config(noreplace) /etc/X11/gdm/custom.conf
251%config /etc/X11/gdm/XKeepsCrashing
252%config /etc/X11/gdm/locale.alias
253%config /etc/X11/gdm/Init/*
254%config /etc/X11/gdm/PostLogin/*
255%config /etc/X11/gdm/PreSession/*
256%config /etc/X11/gdm/PostSession/*
257%config /etc/X11/gdm/modules/*
258%config /etc/pam.d/gdm
259%config /etc/pam.d/gdmsetup
260%config /etc/pam.d/gdm-autologin
261%config /etc/security/console.apps/gdmsetup
262%dir /etc/X11/gdm/Init
263%dir /etc/X11/gdm/PreSession
264%dir /etc/X11/gdm/PostSession
265%dir /etc/X11/gdm/PostLogin
266%dir /etc/X11/gdm/modules
267%{_datadir}/pixmaps
268%{_datadir}/icons
269%{_datadir}/gdm
270#%{_datadir}/applications
271%{_datadir}/gnome/help/gdm
272%{_datadir}/omf/gdm
273%{_datadir}/hal/fdi/policy/20thirdparty/90-grant-audio-devices-to-gdm.fdi
274%{_libdir}/gtk-2.0/modules/*.so
275%{_bindir}/*
276%{_libexecdir}/*
277%{_mandir}/man*/*
278%{_sbindir}/*
279%dir %{_var}/log/gdm
280
281%attr(1770, root, gdm) %dir %{_localstatedir}/gdm
282
283%changelog
284* Sat Jul 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.20.10-6
285- update Patch100: fix typo & change BackgroundColor/GraphicalThemedColor
286  <BTS:VineLinux:0732>
287- add BuildRequires: libdmx-devel, audit-libs-devel
288
289* Thu May 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-5
290- add patch11: add hibernate button in GDM menu
291- add pathc18: use combo boxc for language selector
292
293* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-4
294- remove explicit dependency to gnome libraries
295- remove BR: libgnome{ui,canvas}-devel
296- add Requires: xorg-x11-xdm
297
298* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-3
299- update vine themes
300  - sync Vine-list with new Vine theme
301
302* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-2
303- update vine theme
304
305* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
306- update to 2.20.10
307- update vine themes
308  - add Requires: vine-backgrounds >= 4.0
309
310* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
311- update to 2.20.8
312  - gdm-2.22/24 still not mature, so We are staying
313    with gdm-2.20 branch.
314
315* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.5-2
316- rebuilt with --with-console-kit
317- TODO: update to 2.22.0 with PolicyKit support
318
319* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.5-1
320- update to 2.20.5
321  - TODO: update to 2.22.0
322  - TODO: update theme to support gdm-2.22.0
323- build with xorg-x11-7.3
324
325* Mon Jan 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-0vl4
326- added gdm-2.18.1-gdmphotosetup-desktop.patch
327
328* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
329- import some upstream patches
330
331* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
332- update Vine theme
333
334* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
335- new upstream release
336
337* Thu Dec 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.10-0vl5
338- rebuilt for VineSeed
339
340* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.14.10-0vl4.2
341- add Vendor/Distribution tag
342- fix changelog typo
343
344* Mon Dec 18 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.14.10-0vl4.1
345- add patch200 for fix CVE-2006-6105
346
347* Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.10-0vl4
348- update locale.alias
349  - remove unsupported langs, add ja_JP.UTF-8
350
351* Fri Sep 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.10-0vl3
352- update gdm-theme-vine
353  - shrink image size
354
355* Sun Aug 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.10-0vl2
356- update gdm-theme-vine
357  - add Face-browser version of Vine theme.
358
359* Sat Aug 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.10-0vl1
360- new upstream release
361- update gdm-theme-vine
362- drop Patch10 (merged in upstream)
363
364* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.8-0vl1
365- new upstream release
366- add Patch10 to fix autologin
367  (<BTS:63>, http://bugzilla.gnome.org/show_bug.cgi?id=344191)
368
369* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.7-0vl1
370- new upstream release
371
372* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.6-0vl1
373- new upstream release
374- remove xsri dependency
375
376* Sun May 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl2
377- use consolehelper for gdmsetup
378
379* Sat May 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl1
380- new upstream release
381
382* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
383- new upstream release
384
385* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
386- rebuild to change _localstatedir
387
388* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
389- new upstream release
390
391* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.0.10-0vl2
392- fix %%post script for Vine Linux
393- remove Patch17,18 which are not needed for Vine Linux
394
395* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.0.10-0vl1
396- new upstream release
397- updated %%post and %%postun script
398
399* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.4-0vl1
400- new upstream release
401- import gdm-theme-vine from Vine Linux 3.2
402
403* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0.6-0vl1
404- new upstream release
405- build with gnome-2.8.1
406
407* Sun Oct 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0.5-0vl1
408- new upstream release
409- update Vine patch
410- remove obsolete patch and ja.po
411
412* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl10
413- update Vine theme for Vine Linux 3.1
414
415* Mon Jul 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl9
416- rebuild to fix bogus consolehelper symlinks
417
418* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl8
419- revert 0vl7's change..
420
421* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl7
422- use 100dpi for X resolution instead of 96dpi
423
424* Mon Jun 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl6
425- Requires usermode-gtk instead of usermode
426
427* Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl5
428- move WindowMaker.desktop to WindowMaker package.
429
430* Fri Apr  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl4
431- add modified ja.po to fix a strange date notation in gdmlogin.
432
433* Wed Mar 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl3
434- add new Vine theme, rename old Vine theme to AquaVine
435- switch to new default Theme
436
437* Fri Mar  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl2
438- update GDM-Vine theme to change font size.
439
440* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.7-0vl1
441- new upstream release
442
443* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.4-0vl1
444- new upstream release
445
446* Sun Sep 28 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.3-0vl1
447- new upstream release
448- fix locale.alias to use ja_JP.eucJP instead of UTF-8 for Japanese locale.
449  (this was fixed in 2.4.0.12, but it does not works with 2.4.4.x)
450
451* Tue Sep 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.1-0vl1
452- new upstream release
453
454* Sat Sep 13 2003 KAZUKI SHIMURA <rito@pos.to> 2.4.4.0-0vl4
455- fix LogDir/ServAuthDir
456
457* Tue Sep 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.0-0vl3
458- add WindowMaker.desktop which should go to WindowMaker package.
459
460* Tue Sep 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.0-0vl2
461- update ja.po
462- modified gdm.conf
463
464* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4.0-0vl1
465- new upstream release
466- partially merged with rawhide package
467  * Thu Sep  4 2003 Alexander Larsson <alexl@redhat.com> 1:2.4.4.0-2
468  - Use the right default session (#103546)
469  * Wed Sep  3 2003 Alexander Larsson <alexl@redhat.com> 1:2.4.4.0-1
470  - update to 2.4.4.0
471  - update to georges new selinux patch
472  * Fri Aug 29 2003 Elliot Lee <sopwith@redhat.com> 1:2.4.2.102-2
473  - Remove scrollkeeper files
474  * Tue Aug 26 2003 George Lebl <jirka@5z.com> 1:2.4.2.102-1
475  - updated to 2.4.2.102
476  - removed outdated patches
477  - Use Xsetup_0 only for :0 since that's the way it works
478    for xdm
479  - remove the gnome.desktop file, its going into gnome-session
480  * Thu Aug 14 2003 Havoc Pennington <hp@redhat.com> 1:2.4.1.6-1
481  - update to latest bugfix version on george's advice
482  - remove setlocale patch that's upstream
483  - remove console setup patches that are upstream
484  * Thu Jun 12 2003 Dan Walsh <dwalsh@redhat.com> 2.4.1.3-9
485  - Port to SELinux
486  * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
487  - rebuilt
488  * Tue Jun  3 2003 Jeff Johnson <jbj@redhat.com>
489  - add explicit epoch's where needed.
490  * Sun May 04 2003 Florian La Roche <Florian.LaRoche@redhat.de>
491  - fix post: localstatedir -> _localstatedir
492  * Thu May  1 2003 Havoc Pennington <hp@redhat.com> 1:2.4.1.3-6
493  - enable UTF-8 for CJK
494  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
495  - debuginfo rebuild
496  * Thu Feb 20 2003 Owen Taylor <otaylor@redhat.com>
497  - Run the error dialogs under /bin/sh --login, so we
498    get lang.sh, and thus unicode_start running. Fixes
499    the X-doesn't-start dialog showing up as random
500    blinking characters.
501  * Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1:2.4.1.3-2
502  - nuke buildreq Xft
503  * Wed Feb  5 2003 Havoc Pennington <hp@redhat.com> 1:2.4.1.3-1
504  - upgrade to 2.4.1.3
505  * Mon Feb  3 2003 Matt Wilson <msw@redhat.com> 1:2.4.1.1-6
506  - added gdm-2.4.1.1-64bit.patch to fix 64 bit crash in cookie
507    generation (#83334)
508  * Mon Feb  3 2003 Owen Taylor <otaylor@redhat.com>
509  - Add patch to fix problem where setting LC_COLLATE=C would give LC_MESSAGES=wa_BE (#82019)
510  * Thu Jan 30 2003 Matt Wilson <msw@redhat.com> 1:2.4.1.1-3
511  - fix pam.d entry, pam_env wasn't properly patched
512  - disable optimizations on x86_64 to work around gcc bug
513  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
514  - rebuilt
515  * Mon Jan 20 2003 Owen Taylor <otaylor@redhat.com>
516  - Upgrade to 2.4.1.1 (Fixes #81907)
517  - Redirect stdout of kill to /dev/null (#80814)
518  * Thu Jan  9 2003 Havoc Pennington <hp@redhat.com>
519  - 2.4.1.0
520  - add patch from george to ask "are you sure?" for shutdown/reboot since
521    it's now just one click away
522  * Thu Dec 19 2002 Havoc Pennington <hp@redhat.com>
523  - 2.4.0.12
524  - update new patch for no-utf8-in-cjk
525  - drop patch to photo setup, now upstream
526  - drop confdocs patch now upstream
527  - move all the gdm.conf changes into single "rhconfig" patch
528  - remove "sid-fix" patch now upstream
529
530* Sun Jan 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1.2-0vl1
531- new upstream release
532- add '-dpi 96' to Xserver option. (change default to 96dpi)
533
534* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1.1-0vl1
535- new upstream release
536
537* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1.0-0vl1
538- new upstream release
539- update PreReq tag.
540- discard scrollkeeper outputs.
541
542* Fri Jan  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.12-0vl3
543- add Vine theme as default.
544- change ja locale from utf8 to eucJP
545- add Xsession/Xclients script for gdm.
546- add Sessions/* for Gnome/WindowMaker.
547
548* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.12-0vl2
549- remove redhat category
550
551* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.12-0vl1
552- merged with rawhide release for gnome2.
553
554* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.0.7-14
555- remove the directory part of module specifications from the PAM config files,
556  allowing the same PAM config to work for either arch on multilib boxes
557
558* Thu Sep  5 2002 Owen Taylor <otaylor@redhat.com>
559- Change zh_CN entry in language menu to zh_CN.GB18030
560
561* Thu Sep  5 2002 Akira TAGOH <tagoh@redhat.com> 2.4.0.7-12
562- copied gdm-ja.po to ja.po.
563
564* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
565- Fix problem where gdm was opening ~/.xsession-errors itself to bad effect
566
567* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
568- include ja.po with new date format
569
570* Wed Aug 28 2002 Havoc Pennington <hp@redhat.com>
571- remove noreplace on gdm.conf #71309
572- make gnome-gdmsetup absolute, #72910
573
574* Wed Aug 28 2002 Havoc Pennington <hp@redhat.com>
575- put /usr/X11R6/bin in path for now fixes #72781
576- use proper i18n algorithm for word wrap, #71937
577- remove greek text from language picker due to lack
578  of greek font
579- reorder PAM config file #72657
580
581* Wed Aug 28 2002 Havoc Pennington <hp@redhat.com>
582- improve gdmsetup icon
583- remove GNOME session, we will instead put it in gnome-session
584- apply patch from george to make gdmphotosetup file selector
585  work
586
587* Mon Aug 26 2002 Elliot Lee <sopwith@redhat.com> 2.4.0.7-6
588- Patches for #64902, #66486, #68483, #71308
589- post-install script changes from the gdm.spec mentioned in #70965
590- noreplace on gdm.conf for #71309
591
592* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
593- put in a patch from george to fix some setsid()/kill() confusion
594  possibly fixing #72295
595- turn off UseCirclesInEntry for now, fixes #72433
596
597* Tue Aug 20 2002 Alexander Larsson <alexl@redhat.com>
598- Set UseCirclesInEntry to true in config
599
600* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
601- rename Gnome session to GNOME, this was just bugging me
602
603* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
604- 2.4.0.7 with bugfixes George kindly did for me,
605  including mnemonics for the graphical greeter
606- use Wonderland gtk theme for the nongraphical greeter
607- remove patches that are now upstream
608
609* Tue Jul 30 2002 Havoc Pennington <hp@redhat.com>
610- update rhconfig patch
611- use pam_timestamp for the config tool
612- link to a desktop file in redhat-menus
613- update .gnome2 patch, filed upstream bug
614- 2.4.0.4
615- rebuild with new gail, librsvg2
616
617* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
618- Require redhat-artwork, make the default greeter theme Wonderland
619- Look for all configuration in .gnome2 not .gnome. This avoids problems
620  with changes in the set of session/lang.
621- Remove English from locale.alias, make most locales UTF-8
622-C all find_lang with the right name
623
624* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
625- rebuild for new libs
626- put gdm-autologin pam config file in file list, hope
627  its absence wasn't deliberate
628- use desktop-file-install
629
630* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
631- rebuild in different environment
632
633* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
634- 2.4.0.0
635
636* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
637- rebuild in different environment
638
639* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
640- 2.3.90.3
641
642* Tue May 14 2002 Matt Wilson <msw@redhat.com> 2.3.90.2.90-1
643- pulled from current CVS, named it 2.3.90.2.90-1
644
645* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
646- rebuild for new libs
647- add URL tag
648
649* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 2.3.90.1.90-1
650- Updated to a cvs snapshot that has the new greeter.
651
652* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
653- rebuild in rawhide
654
655* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
656- fix #52997 (ukrainian in language list)
657
658* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
659- Add po files from sources.redhat.com
660
661* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
662- Add po files from sources.redhat.com
663
664* Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com>
665- set SESSION to true in console.apps control file
666
667* Tue Aug 14 2001 Havoc Pennington <hp@redhat.com>
668- change default title font to work in CJK, #51698
669
670* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
671- fix %pre for using /var/gdm as home dir
672
673* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com>
674- Tweak PAM setup for gdmconfig to match other consolehelper users
675
676* Fri Aug  3 2001 Owen Taylor <otaylor@redhat.com>
677- Set RUNNING_UNDER_GDM when running display init script
678- Run xsri as the background program
679
680* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
681- Change how session switching works, #49480
682- don't offer to make Failsafe the default, #49479
683
684* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
685- clean up some format string mess, and don't
686  log username to syslog, #5681
687- own some directories #50692
688
689* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
690- require/buildrequire latest gnome-libs, to compensate
691  for upstream crackrock. #50554
692
693* Tue Jul 31 2001 Havoc Pennington <hp@redhat.com>
694- get rid of GiveConsole/TakeConsole, bug #33710
695
696* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
697- use Raleigh theme for gdm
698
699* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
700- depend on usermode, xinitrc
701 
702* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
703- build requires pam-devel, should fix #49448
704
705* Mon Jul 16 2001 Havoc Pennington <hp@redhat.com>
706- log to /var/log/gdm/*
707
708* Mon Jul 16 2001 Havoc Pennington <hp@redhat.com>
709- make Halt... power off
710
711* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
712- gdm user's homedir to /var/gdm not /home/gdm
713
714* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
715- put pam.d/gdm back in file list
716
717* Sun Jul 08 2001 Havoc Pennington <hp@redhat.com>
718- upgrade to 2.2.3.1, pray this fixes more than it breaks
719
720* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
721- add "rpm" user to those not to show in greeter
722
723* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
724- Upgrade to 2.2.3
725- require usermode since configure script now checks for it
726
727* Fri Jun 01 2001 Havoc Pennington <hp@redhat.com>
728- Prereq for scrollkeeper-update
729
730* Thu May 30 2001 Havoc Pennington <hp@redhat.com>
731- New CVS snap with the "no weird sessions" options;
732  more default settings changes
733
734* Wed May 30 2001 Havoc Pennington <hp@redhat.com>
735- Change a bunch of default settings; remaining fixes will involve C hacking
736
737* Wed May 30 2001 Havoc Pennington <hp@redhat.com>
738- After, oh, 2 years or so, finally upgrade version and set
739  release to 1. Remove all hacks and patches, pretty much;
740  this will break a few things, will be putting them back
741  via GNOME CVS. All changes should go in 'gdm2' module in
742  CVS for now.
743
744  This RPM enables all kinds of features that I'm going to turn
745  off shortly, so don't get excited about them. ;-)
746
747* Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
748- reinitialize pam credentials after calling initgroups() -- the
749  credentials may be group memberships
750
751* Mon Mar 19 2001 Owen Taylor <otaylor@redhat.com>
752- Fix colors patch
753
754* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
755- translations
756
757* Mon Mar  5 2001 Preston Brown <pbrown@redhat.com>
758- don't screw up color map on 8 bit displays
759
760* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
761- langify
762- Don't define and use "ver" and "nam" at the top of the spec file
763- use %%{_tmppath}
764
765* Tue Feb 13 2001 Tim Powers <timp@redhat.com>
766- don't allow gdm to show some system accounts in the browser bugzilla
767  #26898
768
769* Fri Jan 19 2001 Akira TAGOH <tagoh@redhat.com>
770- Updated Japanese translation.
771
772* Tue Jan 02 2001 Havoc Pennington <hp@redhat.com>
773- add another close() to the fdleak patch, bugzilla #22794
774
775* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
776- Return to toplevel main loop and start Xdcmp if enabled
777  (Bug #16106)
778
779* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
780- Up Epoch and release
781
782* Wed Aug 02 2000 Havoc Pennington <hp@redhat.com>
783- Requires Xsession script
784
785* Wed Jul 19 2000 Owen Taylor <otaylor@redhat.com>
786- Italian is better as it_IT than it_CH (bugzilla 12425)
787
788* Mon Jul 17 2000 Jonathan Blandford <jrb@redhat.com>
789- Don't instally gdmconfig as it doesn't work.
790
791* Fri Jul 14 2000 Havoc Pennington <hp@redhat.com>
792- Rearrange code to avoid calling innumerable system calls
793  in a signal handler
794
795* Fri Jul 14 2000 Havoc Pennington <hp@redhat.com>
796- Verbose debug spew for infinite loop stuff
797
798* Fri Jul 14 2000 Havoc Pennington <hp@redhat.com>
799- Try to fix infinite loops on X server failure
800
801* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
802- automatic rebuild
803
804* Thu Jun 29 2000 Havoc Pennington <hp@redhat.com>
805- Remove Docdir
806
807* Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
808- Fix file descriptor leak (Bugzilla 12301)
809
810* Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
811- Apply security errata patch we released for 6.2
812- Add Gnome.session back, don't know when it disappeared or why
813
814* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
815- modify PAM setup to use system-auth
816
817* Fri May 19 2000 Havoc Pennington <hp@redhat.com>
818- rebuild for the Winston tree
819
820* Fri Feb 04 2000 Havoc Pennington <hp@redhat.com>
821- Modify Default.session and Failsafe.session not to add -login option to bash
822- exec the session scripts with the user's shell with a hyphen prepended
823- doesn't seem to actually work yet with tcsh, but it doesn't seem to
824  break anything. needs a look to see why it doesn't work
825
826* Fri Feb 04 2000 Havoc Pennington <hp@redhat.com>
827- Link PreSession/Default to xdm/GiveConsole
828- Link PostSession/Default to xdm/TakeConsole
829
830* Fri Feb 04 2000 Havoc Pennington <hp@redhat.com>
831- Fix the fix to the fix (8877)
832- remove docs/gdm-manual.txt which doesn't seem to exist from %doc
833
834* Fri Feb 04 2000 Havoc Pennington <hp@redhat.com>
835- Enhance 8877 fix by not deleting the "Please login"
836  message
837
838* Fri Feb 04 2000 Havoc Pennington <hp@redhat.com>
839- Try to fix bug 8877 by clearing the message below
840  the entry box when the prompt changes. may turn
841  out to be a bad idea.
842
843* Mon Jan 17 2000 Elliot Lee <sopwith@redhat.com>
844- Fix bug #7666: exec Xsession instead of just running it
845
846* Mon Oct 25 1999 Jakub Jelinek <jakub@redhat.com>
847- Work around so that russian works (uses koi8-r instead
848  of the default iso8859-5)
849
850* Tue Oct 12 1999 Owen Taylor <otaylor@redhat.com>
851- Try again
852
853* Tue Oct 12 1999 Owen Taylor <otaylor@redhat.com>
854- More fixes for i18n
855
856* Tue Oct 12 1999 Owen Taylor <otaylor@redhat.com>
857- Fixes for i18n
858
859* Fri Sep 26 1999 Elliot Lee <sopwith@redhat.com>
860- Fixed pipewrite bug (found by mkj & ewt).
861
862* Fri Sep 17 1999 Michael Fulbright <drmike@redhat.com>
863- added requires for pam >= 0.68
864
865* Fri Sep 10 1999 Elliot Lee <sopwith@redhat.com>
866- I just update this package every five minutes, so any recent changes are my fault.
867
868* Thu Sep 02 1999 Michael K. Johnson <johnsonm@redhat.com>
869- built gdm-2.0beta2
870
871* Mon Aug 30 1999 Michael K. Johnson <johnsonm@redhat.com>
872- built gdm-2.0beta1
873
874* Tue Aug 17 1999 Michael Fulbright <drmike@redhat.com>
875- included rmeier@liberate.com patch for tcp socket X connections
876
877* Mon Apr 19 1999 Michael Fulbright <drmike@redhat.com>
878- fix to handling ancient gdm config files with non-standard language specs
879- dont close display connection for xdmcp connections, else we die if remote
880  end dies.
881
882* Fri Apr 16 1999 Michael Fulbright <drmike@redhat.com>
883- fix language handling to set GDM_LANG variable so gnome-session
884  can pick it up
885
886* Wed Apr 14 1999 Michael Fulbright <drmike@redhat.com>
887- fix so certain dialog boxes dont overwrite background images
888
889* Wed Apr 14 1999 Michael K. Johnson <johnsonm@redhat.com>
890- do not specify -r 42 to useradd -- it doesn't know how to fall back
891  if id 42 is already taken
892
893* Fri Apr 9 1999 Michael Fulbright <drmike@redhat.com>
894- removed suspend feature
895
896* Mon Apr 5 1999 Jonathan Blandford <jrb@redhat.com>
897- added patch from otaylor to not call gtk funcs from a signal.
898- added patch to tab when username not added.
899- added patch to center About box (and bring up only one) and ignore "~"
900  and ".rpm" files.
901
902* Fri Mar 26 1999 Michael Fulbright <drmike@redhat.com>
903- fixed handling of default session, merged all gdmgreeter patches into one
904
905* Tue Mar 23 1999 Michael Fulbright <drmike@redhat.com>
906- remove GNOME/KDE/AnotherLevel session scripts, these have been moved to
907  the appropriate packages instead.
908- added patch to make option menus always active (security problem otherwise)
909- added jrb's patch to disable stars in passwd entry field
910
911* Fri Mar 19 1999 Michael Fulbright <drmike@redhat.com>
912- made sure /usr/bin isnt in default path twice
913- strip binaries
914
915* Wed Mar 17 1999 Michael Fulbright <drmike@redhat.com>
916- fixed to use proper system path when root logs in
917
918* Tue Mar 16 1999 Michael Fulbright <drmike@redhat.com>
919- linked Init/Default to Red Hat default init script for xdm
920- removed logo from login dialog box
921
922* Mon Mar 15 1999 Michael Johnson <johnsonm@redhat.com>
923- pam_console integration
924
925* Tue Mar 09 1999 Michael Fulbright <drmike@redhat.com>
926- added session files for GNOME/KDE/AnotherLevel/Default/Failsafe
927- patched gdmgreeter to not complete usernames
928- patched gdmgreeter to not safe selected session permanently
929- patched gdmgreeter to center dialog boxes
930
931* Mon Mar 08 1999 Michael Fulbright <drmike@redhat.com>
932- removed comments from gdm.conf file, these are not parsed correctly
933
934* Sun Mar 07 1999 Michael Fulbright <drmike@redhat.com>
935- updated source line for accuracy
936
937* Fri Feb 26 1999 Owen Taylor <otaylor@redhat.com>
938- Updated patches for 1.0.0
939- Fixed some problems in 1.0.0 with installation directories
940- moved /usr/var/gdm /var/gdm
941
942* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
943- moved files from /usr/etc to /etc
944
945* Tue Feb 16 1999 Michael Johnson <johnsonm@redhat.com>
946- removed commented-out #1 definition -- put back after testing gnome-libs
947  comment patch
948
949* Sat Feb 06 1999 Michael Johnson <johnsonm@redhat.com>
950- initial packaging
Note: See TracBrowser for help on using the repository browser.