source: projects/specs/trunk/g/gdesklets/gdesklets-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# $Id: gdesklets.spec 2233 2004-10-01 11:52:13Z dries $
2# Authority: dag
3
4%define real_name gDesklets
5
6Summary: Advanced architecture for desktop applets
7Name: gdesklets
8Version: 0.36.1
9Release: 1%{?_dist_release}
10License: GPL
11Group: User Interface/Desktops
12URL: http://gdesklets.de/
13
14
15Source: http://archive.gdesklets.info/gDesklets/gDesklets-%{version}.tar.bz2
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18BuildRequires: libgtop2-devel >= 2.0.0, python-devel >= 2.0.0, gcc-c++
19BuildRequires: gnome-python-devel >= 2.12.0, pyorbit-devel >= 2.0.1
20BuildRequires: expat-devel >= 1.95.8
21BuildRequires: perl(XML::Parser), intltool, pygtk2-devel
22BuildRequires: gtk2-devel
23Requires: python >= 2.3, gnome-python >= 2.12.0, pyorbit >= 2.0.1
24
25%description
26gDesklets provides an advanced architecture for desktop applets - tiny
27displays sitting on your desktop in a symbiotic relationship of eye candy
28and usefulness.
29
30Populate your desktop with status meters, icon bars, weather sensors,
31news tickers... whatever you can imagine! Virtually anything is possible
32and maybe even available some day.
33
34
35%prep
36%setup -q -n %{real_name}-%{version}
37
38
39%build
40%configure \
41        --disable-dependency-tracking \
42        --disable-install-schemas
43%{__make} %{?_smp_mflags}
44
45
46%install
47%{__rm} -rf %{buildroot}
48export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
49make install DESTDIR=%{buildroot}
50%find_lang %{name}
51
52desktop-file-install --vendor="vine"  \
53        --dir %{buildroot}%{_datadir}/applications \
54        --add-category Application \
55        --add-category Utility \
56        data/%{name}.desktop
57
58mkdir -p  %{buildroot}{%{_bindir},%{_datadir}/%{name}/data/,%{_datadir}/%{name}/Displays/,%{_datadir}/%{name}/Controls/}
59
60rm -rf %{buildroot}%{_datadir}/mime/application
61rm -rf %{buildroot}%{_datadir}/mime/{globs,magic,XMLnamespaces,aliases,subclasses,mime.cache}
62rm -f %{buildroot}%{_datadir}/applications/{%{name}.desktop,mimeinfo.cache}
63rm -f %{buildroot}%{_datadir}/mime/{globs2,generic-icons,icons,treemagic,types}
64
65
66%post
67/usr/bin/update-mime-database %{_datadir}/mime &>/dev/null || :
68
69
70%postun
71/usr/bin/update-mime-database %{_datadir}/mime &>/dev/null || :
72
73
74%clean
75%{__rm} -rf %{buildroot}
76
77
78%files -f %{name}.lang
79%defattr(-,root,root,-)
80%doc AUTHORS ChangeLog COPYING NEWS README TODO
81%{_bindir}/%{name}
82%{_datadir}/mime/packages/%{name}.xml
83%{_datadir}/icons/gnome/48x48/mimetypes/*.png
84%{_datadir}/pixmaps/%{name}.png
85%{_datadir}/applications/*.desktop
86%{_datadir}/%{name}/
87%{_libdir}/%{name}/
88%{_mandir}/man1/*
89
90
91%changelog
92* Fri Mar 20 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.36.1-1
93- new upstream release
94- fix build/install/files section
95
96* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> - 0.32-1vl2
97- new upstream release 0.32.
98- import to Vine Linux
99
100* Wed Aug 28 2004 Dag Wieers <dag@wieers.com> - 0.30-1
101- Updated to release 0.30.
102
103* Wed May 05 2004 Dag Wieers <dag@wieers.com> - 0.26.2-1
104- Updated to release 0.26.2.
105
106* Sun Mar 28 2004 Dag Wieers <dag@wieers.com> - 0.26.1-0
107- Updated to release 0.26.1.
108
109* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 0.26-0
110- Updated to release 0.26.
111
112* Tue Dec 30 2003 Dag Wieers <dag@wieers.com> - 0.25.1-0
113- Updated to release 0.25.1.
114
115* Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 0.25-0
116- Updated to release 0.25.
117
118* Wed Dec 03 2003 Dag Wieers <dag@wieers.com> - 0.24.1-0
119- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.