source: projects/specs/trunk/g/gdbm/gdbm-vl.spec @ 12136

Revision 12136, 10.1 KB checked in by ara_t, 5 years ago (diff)

gdbm: rebuild with readline-8.0 and ncurses-6.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A GNU set of database routines which use extensible hashing.
4Summary(ja): 拡張可能なハッシングを利用した GNU データベースルーチン
5Name: gdbm
6Version: 1.18.1
7Release: 2%{?_dist_release}
8Source: ftp://ftp.gnu.org/gnu/gdbm-%{version}.tar.gz
9License: GPL
10Group: System Environment/Libraries
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: libtool gettext readline-devel
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17%description
18Gdbm is a GNU database indexing library, including routines which use
19extensible hashing.  Gdbm works in a similar way to standard UNIX dbm
20routines.  Gdbm is useful for developers who write C applications and
21need access to a simple and efficient database or who are building C
22applications which will use such a database.
23
24If you're a C developer and your programs need access to simple
25database routines, you should install gdbm.  You'll also need to
26install gdbm-devel.
27
28%description -l ja
29gdbm は,拡張可能なハッシングを利用したルーチンが含まれた
30GNU データベースインデックスライブラリです.gdbm は標準的な
31UNIX の dbm ルーチンと同様に機能します.C アプリケーションを
32開発する際に簡単で効率的なデータベースへのアクセスが必要になった時,
33この gdbm は非常に便利です.
34
35あなたが C プログラマで,プログラムに簡単なデータベースルーチンへの
36アクセスが必要になった場合,gdbm を是非インストールして下さい.
37その際 gdbm-devel パッケージも同時にインストールする必要があります.
38
39%package -n compat32-%{name}
40Summary: A GNU set of database routines which use extensible hashing.
41Summary(ja): 拡張可能なハッシングを利用した GNU データベースルーチン
42Group: System Environment/Libraries
43Requires: gdbm = %{version}
44
45%description -n compat32-%{name}
46Gdbm is a GNU database indexing library, including routines which use
47extensible hashing.  Gdbm works in a similar way to standard UNIX dbm
48routines.  Gdbm is useful for developers who write C applications and
49need access to a simple and efficient database or who are building C
50applications which will use such a database.
51
52If you're a C developer and your programs need access to simple
53database routines, you should install gdbm.  You'll also need to
54install gdbm-devel.
55
56%description -n compat32-%{name} -l ja
57gdbm は,拡張可能なハッシングを利用したルーチンが含まれた
58GNU データベースインデックスライブラリです.gdbm は標準的な
59UNIX の dbm ルーチンと同様に機能します.C アプリケーションを
60開発する際に簡単で効率的なデータベースへのアクセスが必要になった時,
61この gdbm は非常に便利です.
62
63あなたが C プログラマで,プログラムに簡単なデータベースルーチンへの
64アクセスが必要になった場合,gdbm を是非インストールして下さい.
65その際 gdbm-devel パッケージも同時にインストールする必要があります.
66
67%package devel
68Summary: Development libraries and header files for the gdbm library.
69Summary(ja): gdbm ライブラリ用の開発ライブラリとヘッダファイル
70Group: Development/Libraries
71Requires: gdbm = %{version}
72Requires(pre): /sbin/install-info
73
74%description devel
75Gdbm-devel contains the development libraries and header files for
76gdbm, the GNU database system.  These libraries and header files are
77necessary if you plan to do development using the gdbm database.
78
79Install gdbm-devel if you are developing C programs which will use the
80gdbm database library.  You'll also need to install the gdbm package.
81
82%description devel -l ja
83gdbm-devel パッケージには,GNU データベースシステムである gdbm 用の
84開発ライブラリとヘッダファイルが納められています.これらのライブラリと
85ヘッダファイルは,gdbm データベースを使ったプログラムを開発する際に
86必要となるものです.
87
88gdbm データベースライブラリを使う C プログラムを開発する場合は
89この gdbm-devel パッケージをインストールして下さい.同時に
90gdbm パッケージもインストールする必要があります.
91
92%package -n compat32-%{name}-devel
93Summary: Development libraries and header files for the gdbm library.
94Summary(ja): gdbm ライブラリ用の開発ライブラリとヘッダファイル
95Group: Development/Libraries
96Requires: gdbm = %{version}
97Requires: gdbm-devel = %{version}
98
99%description -n compat32-%{name}-devel
100Gdbm-devel contains the development libraries and header files for
101gdbm, the GNU database system.  These libraries and header files are
102necessary if you plan to do development using the gdbm database.
103
104Install gdbm-devel if you are developing C programs which will use the
105gdbm database library.  You'll also need to install the gdbm package.
106
107%description -n compat32-%{name}-devel -l ja
108gdbm-devel パッケージには,GNU データベースシステムである gdbm 用の
109開発ライブラリとヘッダファイルが納められています.これらのライブラリと
110ヘッダファイルは,gdbm データベースを使ったプログラムを開発する際に
111必要となるものです.
112
113gdbm データベースライブラリを使う C プログラムを開発する場合は
114この gdbm-devel パッケージをインストールして下さい.同時に
115gdbm パッケージもインストールする必要があります.
116
117%prep
118%setup -q
119
120%build
121%configure \
122    --disable-static \
123    --disable-rpath \
124    --enable-libgdbm-compat
125
126# get rid of rpath (as per https://fedoraproject.org/wiki/Packaging:Guidelines#Beware_of_Rpath)
127# currently --disable-rpath doesn't work for gdbm_dump|load, gdbmtool and libgdbm_compat.so.4
128# https://puszcza.gnu.org.ua/bugs/index.php?359
129sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
130sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
131
132make %{?_smp_mflags}
133
134%install
135rm -rf %{buildroot}
136
137make DESTDIR=%{buildroot} install
138
139%find_lang %{name}
140
141# create symlinks for compatibility
142mkdir -p %{buildroot}/%{_includedir}/gdbm
143ln -sf ../gdbm.h %{buildroot}/%{_includedir}/gdbm/gdbm.h
144ln -sf ../ndbm.h %{buildroot}/%{_includedir}/gdbm/ndbm.h
145ln -sf ../dbm.h %{buildroot}/%{_includedir}/gdbm/dbm.h
146
147# Remove libtool archives
148find %{buildroot} -type f -name "*.la" -delete
149
150rm -f %{buildroot}/%{_infodir}/dir
151
152%check
153export LD_LIBRARY_PATH=`pwd`/src/.libs/:`pwd`/compat/.libs/
154make check
155
156%post -p /sbin/ldconfig
157
158%postun -p /sbin/ldconfig
159
160%post -n compat32-%{name} -p /sbin/ldconfig
161
162%postun -n compat32-%{name} -p /sbin/ldconfig
163
164%post devel
165/sbin/install-info %{_infodir}/gdbm.info.gz %{_infodir}/dir --entry="* gdbm: (gdbm).                   The GNU Database."
166
167%preun devel
168if [ $1 = 0 ]; then
169   /sbin/install-info --delete %{_infodir}/gdbm.info.gz %{_infodir}/dir --entry="* gdbm: (gdbm).                   The GNU Database."
170fi
171
172%files -f %{name}.lang
173%license COPYING
174%doc NEWS README THANKS AUTHORS NOTE-WARNING
175%{_bindir}/gdbm*
176%{_mandir}/man1/gdbm*
177%{_libdir}/libgdbm.so.*
178%{_libdir}/libgdbm_compat.so.4*
179
180%files devel
181%defattr(-,root,root)
182%{_libdir}/libgdbm.so
183%{_libdir}/libgdbm_compat.so
184%{_includedir}/*
185%{_infodir}/*.info*
186%{_mandir}/man3/*
187
188%if %{build_compat32}
189%files -n compat32-%{name}
190%defattr(-,root,root)
191%{_libdir}/libgdbm.so.*
192%{_libdir}/libgdbm_compat.so.4*
193
194%files -n compat32-%{name}-devel
195%defattr(-,root,root)
196%{_libdir}/libgdbm.so
197%{_libdir}/libgdbm_compat.so
198%endif
199
200%clean
201rm -rf ${RPM_BUILD_ROOT}
202
203%changelog
204* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 1.18.1-2
205- rebuild with readline-8.0 and ncurses-6.1
206
207* Sun May 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.1-1
208- new upstream release.
209- dropped all patches.
210
211* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-24
212- rebuild with VineSeed environment
213
214* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1.8.0-23
215- rebuilt with rpm-4.8.1-3
216
217* Thu Feb 11 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.0-22
218- added patch4: gdbm-1.8.0-config.sub.patch (for x86_64)
219
220* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.0-21
221- rebuilt with new toolchain
222- fix Patch1
223
224* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.0-20vl5
225- applied new versioning policy, spec in utf-8
226
227* Thu Feb 9 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.8.0-20vl3
228- added compat32-* packages for x86_64 architecture support
229
230* Wed Jan 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-20vl2
231- added BuildRequires: libtool
232
233* Mon Apr 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-20vl1
234- rebuild with new toolchain
235- based on Rawhide 1.8.0-20
236
237* Sat Jul 14 2001 <sagami@vinelinux.org>
238- 1.8.0-10vl1
239- follow up with 1.8.0-10 which has a fix to build against new libtool
240
241* Sun Feb 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
242- 1.8.0-5vl1
243- based on 1.8.0-5 from Rawhide
244- added Japanese summary and description
245
246* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
247- automatic rebuild
248
249* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
250- FHS packaging.
251
252* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
253- handle compressed manpages
254
255* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
256- make sure created database header is initialized (#4457).
257
258* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
259- update to 1.8.0.
260- repackage to include /usr/include/gdbm/*dbm.h compatibility includes.
261
262* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
263- auto rebuild in the new build environment (release 19)
264
265* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
266- build against glibc 2.1
267
268* Thu May 07 1998 Prospector System <bugs@redhat.com>
269- translations modified for de, fr, tr
270
271* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
272- gdbm-devel moved to Development/Libraries
273
274* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
275- buildroot and built for Manhattan
276
277* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
278- spec file cleanups
279
280* Thu Jun 12 1997 Erik Troan <ewt@redhat.com>
281- built against glibc
Note: See TracBrowser for help on using the repository browser.