source: projects/specs/trunk/g/gdata-sharp/gdata-sharp-vl.spec @ 6270

Revision 6270, 3.2 KB checked in by Takemikaduchi, 12 years ago (diff)

NEW: banshee and C# binding packages

Line 
1%global         debug_package %{nil}
2%global         upstream_name libgoogle-data-mono
3
4Name:           gdata-sharp
5Version:        1.4.0.2
6Release:        1%{?_dist_release}
7Summary:        .NET library for the Google Data API
8
9Group:          System Environment/Libraries
10License:        ASL 2.0
11URL:            http://code.google.com/p/google-gdata/
12Source0:        http://google-gdata.googlecode.com/files/%{upstream_name}-%{version}.tar.gz
13# fixed in SVN:
14# http://code.google.com/p/google-gdata/source/detail?spec=svn933&r=890
15Patch0:         %{upstream_name}-1.4.0.2-pkgconfig.patch
16
17BuildRequires:  mono-devel mono-nunit
18#Requires:       
19
20# Mono only available on these:
21ExclusiveArch: %ix86 x86_64 ppc ppc64 ia64 %{arm} sparcv9 alpha s390x
22
23%description
24The Google Data APIs (GData) provide a simple protocol for reading and
25writing data on the web.
26
27Each of the following Google services provides a Google data API:
28
29    * Base
30    * Blogger
31    * Calendar
32    * Spreadsheets
33    * Google Apps Provisioning
34    * Code Search
35    * Notebook
36    * Picasa Web Albums
37    * Document Feed
38    * Contacts
39    * You Tube
40    * Google Health
41
42The GData .NET Client Library provides a library and source code that
43make it easy to access data through Google Data APIs.
44
45
46%package        devel
47Summary:        Development files for %{name}
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50Requires:       pkgconfig
51
52%description    devel
53The %{name}-devel package contains libraries and header files for
54developing applications that use %{name}.
55
56
57%prep
58%setup -q -n %{upstream_name}-%{version}
59%patch0 -p1 -b .pkgconfig
60
61%build
62make %{?_smp_mflags} PREFIX=%{_prefix}
63
64%check
65# currently 98 tests out of 921 fail
66# make test
67
68
69%install
70make install DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix}
71
72mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
73test "%{_libdir}" = "%{_prefix}/lib" || mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
74
75%files
76%defattr(-,root,root,-)
77%doc LICENSE-2.0.txt RELEASE_NOTES.HTML
78%{_prefix}/lib/mono/GData-Sharp
79%{_prefix}/lib/mono/gac/Google.GData.*
80
81%files devel
82%defattr(-,root,root,-)
83%{_libdir}/pkgconfig/gdata-sharp-*.pc
84
85
86%changelog
87* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0.2-1
88- initial build for Vine Linux
89
90
91* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0.2-7
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
93
94* Sat Oct 29 2011 Christian Krause <chkr@fedoraproject.org> - 1.4.0.2-6
95- Change paths for mono assemblies according to updated packaging
96  guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
97
98* Fri Feb 25 2011 Dan Horák <dan[at]danny.cz> - 1.4.0.2-5
99- updated the supported arch list
100
101* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0.2-4
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
103
104* Wed Sep 23 2009 Michel Salim <salimma@fedoraproject.org> - 1.4.0.2-3
105- Replace %%define with %%global
106
107* Thu Sep  3 2009 Michel Salim <salimma@fedoraproject.org> - 1.4.0.2-2
108- Build against latest mono-nunit
109
110* Fri Aug 21 2009 Michel Salim <salimma@fedoraproject.org> - 1.4.0.2-1
111- Initial Fedora package
112
Note: See TracBrowser for help on using the repository browser.