source: projects/specs/trunk/g/gd20/gd20-vl.spec @ 7856

Revision 7856, 9.3 KB checked in by tomop, 11 years ago (diff)

gd-2.1.0-1 and dependencies.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A graphics library for drawing .png files.
3Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
4Name: gd20
5Version: 2.0.35
6Release: 9%{_dist_release}
7Source0: http://www.libgd.org/releases/gd-%{version}.tar.bz2
8Patch0:        gd-2.0.33-freetype.patch
9Patch3:        gd-2.0.34-multilib.patch
10Patch4:        gd-loop.patch
11Patch5:        gd-2.0.34-sparc64.patch
12Patch6:        gd-2.0.35-overflow.patch
13Patch7:        gd-2.0.35-AALineThick.patch
14Patch8:        gd-2.0.33-BoxBound.patch
15Patch9:        gd-2.0.34-fonts-vine.patch
16Patch10:       gd-2.0.35-time.patch
17Patch11:       gd-2.0.35-security3.patch
18Patch12:       gd-2.0.35-runtests.patch
19License: BSD-style
20URL: http://www.libgd.org/
21Group: System Environment/Libraries
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: libjpeg-devel zlib-devel freetype2-devel
25BuildRequires: libpng-devel >= 2:1.2.5
26BuildRequires: libX11-devel libXpm-devel
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: daisuke
31
32%description
33Gd is a graphics library for drawing .png files.  Gd allows your code to
34quickly draw images (lines, arcs, text, multiple colors, cutting and
35pasting from other images, flood fills) and write out the result as a
36.png file. Gd is particularly useful in web applications, where .pngs
37are commonly used as inline images.  Note, however, that gd is not a
38paint program.
39
40Install gd if you are developing applications which need to draw .png
41files.  If you install gd, you'll also need to install the gd-devel
42package.
43
44%description -l ja
45GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
46画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
47簡単に描写して、PNGファイルへ結果を出力することができます。
48Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
49便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
50ん。
51
52PNGファイルを描写する必要のあるアプリケーションを開発する場合、
53Gdをインストールしてください。gdをインストールした場合、gd-devel
54パッケージも必要になります。
55
56%package progs
57Summary: Utility programs that use libgd.
58Summary(ja): libgd を用いたユーティリティプログラム
59Group: Applications/Graphics
60Requires: gd20 = %{version}, perl
61
62%description progs
63These are utility programs supplied with gd, the .png graphics library.
64If you install these, you must install gd.
65
66%description progs -l ja
67これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
68プログラムです。これをインストールするには, gdをインストールする必要
69があります。
70
71%package devel
72Requires: gd20 = %{version}
73Summary: The development libraries and header files for gd.
74Summary(ja): gd用の開発ライブラリとヘッダファイル
75Group: Development/Libraries
76
77%description devel
78These are the development libraries and header files for gd, the .png
79graphics library.
80
81If you're installing the gd graphics library, you must install gd-devel.
82
83%description devel -l ja
84これらは開発ライブラリです。
85PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
86です。
87
88gdをインストールした場合、gd-develパッケージも必要になります。
89
90
91## to build compat32 for x86_64 architecture support
92%package -n compat32-%{name}
93Summary: A graphics library for drawing .png files.
94Group: System Environment/Libraries
95%description -n compat32-%{name}
96Gd is a graphics library for drawing .png files.  Gd allows your code to
97quickly draw images (lines, arcs, text, multiple colors, cutting and
98pasting from other images, flood fills) and write out the result as a
99.png file. Gd is particularly useful in web applications, where .pngs
100are commonly used as inline images.  Note, however, that gd is not a
101paint program.
102
103Install gd if you are developing applications which need to draw .png
104files.  If you install gd, you'll also need to install the gd-devel
105package.
106
107%package -n compat32-%{name}-devel
108Summary: The development libraries and header files for gd.
109Group: Development/Libraries
110%description -n compat32-%{name}-devel
111These are the development libraries and header files for gd, the .png
112graphics library.
113
114If you're installing the gd graphics library, you must install gd-devel.
115
116
117%prep
118%setup -q -n gd-%{version}
119%patch0 -p1 -b .freetype
120%patch3 -p1 -b .mlib
121%patch4 -p1 -b .loop
122%patch6 -p1 -b .overflow
123%patch5 -p1 -b .sparc64
124%patch7 -p1 -b .AALineThick
125%patch8 -p1 -b .bb
126%patch9 -p1 -b .fonts-vine
127%patch10 -p1 -b .time
128%patch11 -p1 -b .sec3
129%patch12 -p1 -b .runtests
130
131
132%build
133%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
134make %{?_smp_mflags}
135
136%install
137[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
138make DESTDIR=$RPM_BUILD_ROOT install
139## remove unuse files
140rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
141
142%clean
143[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
144
145%post -p /sbin/ldconfig
146%postun -p /sbin/ldconfig
147
148%if %{build_compat32}
149%post -n compat32-%{name} -p /sbin/ldconfig
150%postun -n compat32-%{name} -p /sbin/ldconfig
151%endif
152
153%files
154%defattr(-,root,root)
155%doc COPYING README*
156%{_libdir}/*.so.*
157
158%files progs
159%defattr(-,root,root)
160%{_bindir}/*
161%exclude %{_bindir}/gdlib-config
162
163%files devel
164%defattr(-,root,root)
165%{_bindir}/gdlib-config
166%{_includedir}/*
167%{_libdir}/*.so
168%{_libdir}/pkgconfig/*.pc
169
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-,root,root)
173%{_libdir}/*.so.*
174%files -n compat32-%{name}-devel
175%defattr(-,root,root)
176%{_libdir}/*.so
177%endif
178
179%changelog
180* Thu Oct 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.35-9
181- changed %%name to "gd20" for compatibility.
182
183* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
184- import patches from fedora package
185- modified font path patch for Vine Linux
186- drop static library
187- remove "-DJISX0208"
188- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
189
190* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
191- move gdlib-config from gd-progs subpackage to gd-devel subpackage
192
193* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
194- build on current VineSeed
195
196* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
197- fix build_compat32 if-endif sections
198
199* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
200- add patch2 for fix CVE-2009-3546 (_gdGetColors())
201
202* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
203- updated URL
204- changed progs Group to Applications/Graphics
205- added %%postun section
206
207* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
208- removed  *.la
209- spec in utf-8
210
211* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
212- add patch1 from centos5
213- new versioning policy
214
215* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
216- new upstream release with security fix (CVE-2007-2756)
217
218* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
219- new upstream release with security fix
220- change source tarball format gz -> bz2
221
222* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
223- added compat32-* packages for x86_64 architecture support
224
225* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
226- source upgrade
227
228* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
229- source update
230- added -DJISX0208 flag
231
232* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
233- source upgrade
234- BuildPrereq: XOrg-devel instead of XFree86-devel
235
236* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
237- source upgrade
238- remove patch0 (no need for freetype2-2.1.7)
239
240* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
241- add patch0 to build against freetype2-2.1.7
242
243* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
244- source upgrade
245- add URL
246- remove all patches
247- use %%configure script
248- add BuildPrereq: freetype2-devel XFree86-devel
249- remove BuildPrereq: VFlib-devel
250- update %%files
251- update Requires:
252- use License tag instead of Copyright
253
254* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
255- rebuild with libpng-devel-1.2.5-0vl1
256
257* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
258- rebuild with new toolchain
259
260* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
261- 1.8.3-0vl2
262- symlink to libgd.so.1 (for backward compatibility)
263
264* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
265- first gd 1.8.x release for Vine from rawhide.
266- enable freetype support and defined JISX208 macro.
267
268* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
269- break out a -progs subpackage
270- disable freetype support
271
272* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
273- update to latest version (1.8.2)
274- disable xpm support
275
276* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
277- auto rebuild in the new build environment (release 6)
278
279* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
280- auto rebuild in the new build environment (release 5)
281
282* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
283- buiuld for glibc 2.1
284
285* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
286- built for 5.2
Note: See TracBrowser for help on using the repository browser.