source: projects/specs/trunk/g/gd/gd-vl.spec @ 9428

Revision 9428, 10.6 KB checked in by tomop, 9 years ago (diff)

gd-2.1.1-1

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.1.1
8Release: 1%{_dist_release}
9Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
10Patch0: gd-2.1.0-multilib.patch
11#Patch1: gd-fixautoconf.patch
12Patch100: gd-2.1.0-fonts-vine.patch
13License: BSD-style
14URL: http://www.libgd.org/
15Group: System Environment/Libraries
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: freetype2-devel
19BuildRequires: fontconfig-devel
20BuildRequires: gettext-devel
21BuildRequires: libjpeg-turbo-devel
22BuildRequires: libpng-devel
23BuildRequires: libtiff-devel
24%if %{with libvpx}
25BuildRequires: libvpx-devel
26%endif
27BuildRequires: libX11-devel
28BuildRequires: libXpm-devel
29BuildRequires: zlib-devel
30BuildRequires: pkgconfig
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: daisuke
35
36%description
37Gd is a graphics library for drawing .png files.  Gd allows your code to
38quickly draw images (lines, arcs, text, multiple colors, cutting and
39pasting from other images, flood fills) and write out the result as a
40.png file. Gd is particularly useful in web applications, where .pngs
41are commonly used as inline images.  Note, however, that gd is not a
42paint program.
43
44Install gd if you are developing applications which need to draw .png
45files.  If you install gd, you'll also need to install the gd-devel
46package.
47
48%description -l ja
49GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
50画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
51簡単に描写して、PNGファイルへ結果を出力することができます。
52Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
53便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
54ん。
55
56PNGファイルを描写する必要のあるアプリケーションを開発する場合、
57Gdをインストールしてください。gdをインストールした場合、gd-devel
58パッケージも必要になります。
59
60%package progs
61Summary: Utility programs that use libgd.
62Summary(ja): libgd を用いたユーティリティプログラム
63Group: Applications/Graphics
64Requires: gd = %{version}
65Requires: perl
66
67%description progs
68These are utility programs supplied with gd, the .png graphics library.
69If you install these, you must install gd.
70
71%description progs -l ja
72これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
73プログラムです。これをインストールするには, gdをインストールする必要
74があります。
75
76%package devel
77Summary: The development libraries and header files for gd.
78Summary(ja): Gd用の開発ライブラリとヘッダファイル
79Group: Development/Libraries
80Requires: gd = %{version}
81Requires: freetype2-devel
82Requires: fontconfig-devel
83Requires: libjpeg-turbo-devel
84Requires: libpng-devel
85Requires: libtiff-devel
86%if %{with libvpx}
87Requires: libvpx-devel
88%endif
89Requires: libX11-devel
90Requires: libXpm-devel
91Requires: zlib-devel
92
93%description devel
94These are the development libraries and header files for gd, the .png
95graphics library.
96
97If you're installing the gd graphics library, you must install gd-devel.
98
99%description devel -l ja
100これらは開発ライブラリです。
101PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
102です。
103
104gdをインストールした場合、gd-develパッケージも必要になります。
105
106
107## to build compat32 for x86_64 architecture support
108%package -n compat32-%{name}
109Summary: A graphics library for drawing .png files.
110Group: System Environment/Libraries
111%description -n compat32-%{name}
112Gd is a graphics library for drawing .png files.  Gd allows your code to
113quickly draw images (lines, arcs, text, multiple colors, cutting and
114pasting from other images, flood fills) and write out the result as a
115.png file. Gd is particularly useful in web applications, where .pngs
116are commonly used as inline images.  Note, however, that gd is not a
117paint program.
118
119Install gd if you are developing applications which need to draw .png
120files.  If you install gd, you'll also need to install the gd-devel
121package.
122
123%package -n compat32-%{name}-devel
124Summary: The development libraries and header files for gd.
125Group: Development/Libraries
126Requires: compat32-freetype2-devel
127Requires: compat32-fontconfig-devel
128Requires: compat32-libjpeg-turbo-devel
129Requires: compat32-libpng-devel
130Requires: compat32-libtiff-devel
131%if %{with libvpx}
132Requires: compat32-libvpx-devel
133%endif
134Requires: compat32-libX11-devel
135Requires: compat32-libXpm-devel
136Requires: compat32-zlib-devel
137
138%description -n compat32-%{name}-devel
139These are the development libraries and header files for gd, the .png
140graphics library.
141
142If you're installing the gd graphics library, you must install gd-devel.
143
144
145%prep
146%setup -q -n libgd-%{version}
147%patch0 -p1 -b .mlib
148#%patch1 -p1 -b .automake
149%patch100 -p1 -b .fonts-vine
150
151# https://bitbucket.org/libgd/gd-libgd/issue/77
152#sed -e '/GD_VERSION_STRING/s/-alpha//' \
153#    -e '/GD_EXTRA_VERSION/s/alpha//' \
154#    -i src/gd.h
155#grep VERSION src/gd.h
156
157: regenerate autotool stuff
158if [ -f configure ]; then
159   libtoolize --copy --force
160   autoreconf -vif
161else
162   ./bootstrap.sh
163fi
164
165
166%build
167# Provide a correct default font search path
168CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
169/usr/share/fonts/TrueType-vlgothic:\
170/usr/share/fonts/bitstream-vera:\
171/usr/share/fonts/dejavu:\
172/usr/share/fonts/default/Type1:\
173/usr/share/X11/fonts/Type1:\
174/usr/share/fonts/liberation\"'"
175
176%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
177    --with-tiff=%{_prefix} \
178%if %{with libvpx}
179    --with-vpx=%{_prefix} \
180%endif
181        --disable-rpath
182make %{?_smp_mflags}
183
184%install
185[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
186make DESTDIR=$RPM_BUILD_ROOT install
187## remove unuse files
188rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
189
190%clean
191[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
192
193%post -p /sbin/ldconfig
194%postun -p /sbin/ldconfig
195
196%if %{build_compat32}
197%post -n compat32-%{name} -p /sbin/ldconfig
198%postun -n compat32-%{name} -p /sbin/ldconfig
199%endif
200
201%files
202%defattr(-,root,root)
203%doc ChangeLog COPYING NEWS docs/*
204%{_libdir}/*.so.*
205
206%files progs
207%defattr(-,root,root)
208%{_bindir}/*
209%exclude %{_bindir}/gdlib-config
210
211%files devel
212%defattr(-,root,root)
213%{_bindir}/gdlib-config
214%{_includedir}/*
215%{_libdir}/*.so
216%{_libdir}/pkgconfig/*.pc
217
218%if %{build_compat32}
219%files -n compat32-%{name}
220%defattr(-,root,root)
221%{_libdir}/*.so.*
222%files -n compat32-%{name}-devel
223%defattr(-,root,root)
224%{_libdir}/*.so
225%endif
226
227%changelog
228* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
229- new upstream release.
230
231* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
232- BR: freetype2-devel instead of freetype-devel on devel package
233
234* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
235- fixed version in gd.h.
236- added fontconfig and tiff support.
237
238* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
239- new upstream release.
240- dropped unnecessary patches.
241
242* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
243- import patches from fedora package
244- modified font path patch for Vine Linux
245- drop static library
246- remove "-DJISX0208"
247- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
248
249* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
250- move gdlib-config from gd-progs subpackage to gd-devel subpackage
251
252* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
253- build on current VineSeed
254
255* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
256- fix build_compat32 if-endif sections
257
258* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
259- add patch2 for fix CVE-2009-3546 (_gdGetColors())
260
261* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
262- updated URL
263- changed progs Group to Applications/Graphics
264- added %%postun section
265
266* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
267- removed  *.la
268- spec in utf-8
269
270* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
271- add patch1 from centos5
272- new versioning policy
273
274* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
275- new upstream release with security fix (CVE-2007-2756)
276
277* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
278- new upstream release with security fix
279- change source tarball format gz -> bz2
280
281* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
282- added compat32-* packages for x86_64 architecture support
283
284* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
285- source upgrade
286
287* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
288- source update
289- added -DJISX0208 flag
290
291* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
292- source upgrade
293- BuildPrereq: XOrg-devel instead of XFree86-devel
294
295* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
296- source upgrade
297- remove patch0 (no need for freetype2-2.1.7)
298
299* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
300- add patch0 to build against freetype2-2.1.7
301
302* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
303- source upgrade
304- add URL
305- remove all patches
306- use %%configure script
307- add BuildPrereq: freetype2-devel XFree86-devel
308- remove BuildPrereq: VFlib-devel
309- update %%files
310- update Requires:
311- use License tag instead of Copyright
312
313* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
314- rebuild with libpng-devel-1.2.5-0vl1
315
316* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
317- rebuild with new toolchain
318
319* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
320- 1.8.3-0vl2
321- symlink to libgd.so.1 (for backward compatibility)
322
323* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
324- first gd 1.8.x release for Vine from rawhide.
325- enable freetype support and defined JISX208 macro.
326
327* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
328- break out a -progs subpackage
329- disable freetype support
330
331* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
332- update to latest version (1.8.2)
333- disable xpm support
334
335* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
336- auto rebuild in the new build environment (release 6)
337
338* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
339- auto rebuild in the new build environment (release 5)
340
341* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
342- buiuld for glibc 2.1
343
344* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
345- built for 5.2
Note: See TracBrowser for help on using the repository browser.