source: projects/specs/trunk/g/gcdemu/gcdemu-vl.spec @ 6150

Revision 6150, 4.1 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%global python_module_name gcdemu
3
4Summary: A GNOME panel applet to control CDEmu daemon
5Summary: CDEmu daemon を制御するための GNOME パネルアプレット
6Name: gcdemu
7Version: 1.5.0
8Release: 1%{?_dist_release}
9License: GPLv2+
10Group: Applications/Accessories
11URL: http://cdemu.sourceforge.net
12Source: http://downloads.sourceforge.net/cdemu/%{name}-%{version}.tar.bz2
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15
16BuildRequires: dbus-python-devel
17BuildRequires: gettext
18BuildRequires: glib2-devel
19BuildRequires: intltool >= 0.21
20#BuildRequires: gnome-panel-devel
21#BuildRequires: gnome-python-devel
22BuildRequires: perl-XML-Parser
23#BuildRequires: pygtk2-devel >= 2.6
24BuildRequires: python-devel
25#BuildRequires: gnome-doc-utils >= 0.3.2
26
27Requires: dbus-python >= 0.80
28Requires: pygobject3
29Requires: cdemu-daemon
30#Requires: gnome-python-applet
31#Requires: hicolor-icon-theme
32#Requires: pygtk2 >= 2.6
33
34#Requires(pre): GConf2
35#Requires(post):        GConf2
36#Requires(preun): GConf2
37
38Requires(post): scrollkeeper
39Requires(postun): scrollkeeper
40
41%description
42This is gCDEmu, a GNOME applet for controlling CDEmu daemon. It is part of the
43userspace-cdemu suite, a free, GPL CD/DVD-ROM device emulator for linux.
44
45It provides a graphic interface that allows performing the key tasks related to
46controlling the CDEmu daemon, such as loading and unloading devices, displaying
47devices' status and retrieving/setting devices' debug masks.
48
49In addition, applet listens to the signals emitted by CDEmu daemon and provides
50the notification via libnotify's notifications (provided that python bindings
51are installed).
52
53%prep
54%setup -q
55
56%build
57%{configure}
58%{__make} %{?_smp_mflags}
59
60%install
61%{__rm} -rf $RPM_BUILD_ROOT
62#export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
63%{__make} install DESTDIR=$RPM_BUILD_ROOT
64#unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
65%find_lang gcdemu --with-gnome
66
67%clean
68%{__rm} -rf $RPM_BUILD_ROOT
69
70%pre
71#if [ "$1" -gt 1 ]; then
72#       export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
73#       gconftool-2 --makefile-uninstall-rule \
74#               %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
75#fi
76glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
77
78%post
79scrollkeeper-update -q
80#export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
81#gconftool-2 --makefile-install-rule \
82#       %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
83glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
84
85%preun
86#if [ "$1" -eq 0 ]; then
87#       export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
88#       gconftool-2 --makefile-uninstall-rule \
89#               %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
90#fi
91glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
92
93
94%postun
95scrollkeeper-update -q
96
97%files -f gcdemu.lang
98%defattr(-,root,root,-)
99%doc AUTHORS ChangeLog COPYING NEWS README
100%{_bindir}/%{name}
101%{_datadir}/applications/*
102%{_datadir}/glib-2.0/schemas/apps.gcdemu.gschema.xml
103%{_datadir}/pixmaps/*
104#%{_datadir}/omf/gcdemu/gcdemu-C.omf
105#%{_libdir}/bonobo/servers/*
106#%{_libexecdir}/*
107#%dir %{python_sitelib}/%{python_module_name}/
108#%{python_sitelib}/%{python_module_name}/*.py*
109#%{_sysconfdir}/gconf/schemas/*
110
111
112%changelog
113* Sun May 06 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
114- new upstream release
115- changed atchive type gzip to bzip2
116- deleted unrecognized option: --disable-schemas-install
117
118* Sat Dec 24 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.0-1
119- new upstream release
120- fixed configure option
121  - deleted --disable-scrollkeeper
122
123* Fri Nov 19 2010 IWAI, Masaharu <iwai@alib.jp> - 1.3.0-2
124- add BuildRequires: gnome-doc-utils >= 0.3.2
125
126* Fri Sep 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
127- new upstream release
128
129* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
130- rebuilt with python-2.6.4
131
132* Fri Sep 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
133- initial build for VineSeed
134
135* Sat Jun 28 2008 Rok Mandeljc <rok.mandeljc@email.si> - 1.1.0-1
136- Updated to 1.1.0
137
138* Thu Dec 20 2007 Rok Mandeljc <rok.mandeljc@email.si> - 1.0.0-1
139- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.