source: projects/specs/trunk/g/gcdemu/gcdemu-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%global python_module_name gcdemu
3
4Summary: A GNOME panel applet to control CDEmu daemon
5Summary: CDEmu daemon を制御するための GNOME パネルアプレット
6Name: gcdemu
7Version: 1.2.0
8Release: 2%{?_dist_release}
9License: GPLv2+
10Group: Applications/Accessories
11URL: http://cdemu.sourceforge.net
12Source: http://downloads.sourceforge.net/cdemu/%{name}-%{version}.tar.bz2
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15
16BuildRequires: dbus-python-devel
17BuildRequires: gettext
18BuildRequires: intltool >= 0.21
19BuildRequires: gnome-panel-devel
20BuildRequires: gnome-python-devel
21BuildRequires: perl-XML-Parser
22BuildRequires: pygtk2-devel >= 2.6
23BuildRequires: python-devel
24
25Requires: dbus-python >= 0.80
26Requires: gnome-python-applet
27Requires: hicolor-icon-theme
28Requires: pygtk2 >= 2.6
29
30Requires(pre): GConf2
31Requires(post): GConf2
32Requires(preun): GConf2
33
34Requires(post): scrollkeeper
35Requires(postun): scrollkeeper
36
37%description
38This is gCDEmu, a GNOME applet for controlling CDEmu daemon. It is part of the
39userspace-cdemu suite, a free, GPL CD/DVD-ROM device emulator for linux.
40
41It provides a graphic interface that allows performing the key tasks related to
42controlling the CDEmu daemon, such as loading and unloading devices, displaying
43devices' status and retrieving/setting devices' debug masks.
44
45In addition, applet listens to the signals emitted by CDEmu daemon and provides
46the notification via libnotify's notifications (provided that python bindings
47are installed).
48
49%prep
50%setup -q
51
52%build
53%{configure} --disable-schemas-install --disable-scrollkeeper
54%{__make} %{?_smp_mflags}
55
56%install
57%{__rm} -rf $RPM_BUILD_ROOT
58export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
59%{__make} install DESTDIR=$RPM_BUILD_ROOT
60unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
61%find_lang gcdemu --with-gnome
62
63%clean
64%{__rm} -rf $RPM_BUILD_ROOT
65
66%pre
67if [ "$1" -gt 1 ]; then
68        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
69        gconftool-2 --makefile-uninstall-rule \
70                %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
71fi
72
73%post
74scrollkeeper-update -q
75export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
76gconftool-2 --makefile-install-rule \
77        %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
78
79%preun
80if [ "$1" -eq 0 ]; then
81        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
82        gconftool-2 --makefile-uninstall-rule \
83                %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
84fi
85
86%postun
87scrollkeeper-update -q
88
89%files -f gcdemu.lang
90%defattr(-,root,root,-)
91%doc AUTHORS ChangeLog COPYING NEWS README
92%{_datadir}/pixmaps/*
93#%{_datadir}/omf/gcdemu/gcdemu-C.omf
94%{_libdir}/bonobo/servers/*
95%{_libexecdir}/*
96%dir %{python_sitelib}/%{python_module_name}/
97%{python_sitelib}/%{python_module_name}/*.py*
98%{_sysconfdir}/gconf/schemas/*
99
100
101%changelog
102* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
103- rebuilt with python-2.6.4
104
105* Fri Sep 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
106- initial build for VineSeed
107
108* Sat Jun 28 2008 Rok Mandeljc <rok.mandeljc@email.si> - 1.1.0-1
109- Updated to 1.1.0
110
111* Thu Dec 20 2007 Rok Mandeljc <rok.mandeljc@email.si> - 1.0.0-1
112- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.