source: projects/specs/trunk/g/gawk/gawk-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary(ja): GNU バージョンの awk テキスト処理ユーティリティー
2Summary: The GNU version of the awk text processing utility.
3Name: gawk
4Version: 3.1.3
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/Text
8
9Source0: ftp://ftp.gnu.org/gnu/gawk/gawk-%{version}.tar.bz2
10Source1: ftp://ftp.gnu.org/gnu/gawk/gawk-%{version}-ps.tar.gz
11Patch3: gawk-3.1.3-fix1.patch
12Patch4: gawk-3.1.3-fix2.patch
13Patch5: gawk-3.1.3-fix3.patch
14Patch6: gawk-3.1.3-fix4.patch
15Patch7: gawk-3.1.3-fix5.patch
16Patch8: gawk-3.1.3-getpgrp_void.patch
17Patch9: gawk-3.1.0-shutup.patch
18
19Source10: gawk-3.1.3-ja.po
20Patch10: gawk-3.1.3-ja.patch
21
22Prereq: /sbin/install-info
23Requires: mktemp
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29The gawk packages contains the GNU version of awk, a text processing
30utility.  Awk interprets a special-purpose programming language to do
31quick and easy text pattern matching and reformatting jobs.
32
33Install the gawk package if you need a text processing utility. Gawk is
34considered to be a standard Linux tool for processing text.
35
36
37%description -l ja
38gawk パッケージは GNU バージョンの、テキスト処理ユーティリティー awk
39を含んでいます。awk は素早く、簡単にパターンマッチングと整形処理を行う
40ためのプログラミング
41
42テキスト処理ユーティティーが必要なら、gawk パッケージをインストールし
43てください。gawk はLinux 上でテキスト処理を行う標準的なツールです。
44
45%prep
46%setup -q -b 1 -n gawk-%{version}
47%patch3 -p1 -b .fix1
48%patch4 -p0 -b .fix2
49%patch5 -p1 -b .fix3
50%patch6 -p1 -b .fix4
51%patch7 -p1 -b .fix5
52%patch8 -p1 -b .getpgrp_void
53%patch9 -p1 -b .shutup
54%patch10 -p0 -b .ja
55cp -f %{SOURCE10} po/ja.po
56
57%build
58%configure --bindir=/bin
59make
60(cd po; make update-po; make)
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%makeinstall bindir=${RPM_BUILD_ROOT}/bin \
65        libexecdir=${RPM_BUILD_ROOT}%{_libexecdir}/awk \
66        datadir=${RPM_BUILD_ROOT}%{_datadir}/awk
67
68mkdir -p $RPM_BUILD_ROOT%{_bindir}
69ln -sf gawk.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/awk.1.gz
70ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/awk
71ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/gawk
72rm -f $RPM_BUILD_ROOT/bin/{,p}gawk-%{version}
73
74rm -f $RPM_BUILD_ROOT%{_infodir}/dir
75mv -f $RPM_BUILD_ROOT%{_datadir}/awk/locale $RPM_BUILD_ROOT%{_datadir}/locale
76
77%find_lang %name
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post
83/sbin/install-info %{_infodir}/gawk.info.gz %{_infodir}/dir
84
85%preun
86if [ $1 = 0 ]; then
87   /sbin/install-info --delete %{_infodir}/gawk.info.gz %{_infodir}/dir
88fi
89
90%files -f %{name}.lang
91%defattr(-,root,root,-)
92%doc COPYING FUTURES INSTALL LIMITATIONS NEWS README
93%doc POSIX.STD README_d doc/gawk.ps doc/awkcard.ps
94/bin/*
95%{_bindir}/*
96%{_mandir}/man1/*
97%{_infodir}/gawk.info*
98%{_infodir}/gawkinet.info*
99%{_libexecdir}/awk
100%{_datadir}/awk
101
102%changelog
103* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1vl5
104- applied new versioning policy, spec in utf-8
105
106* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 3.1.3-0vl3
107- fixed missing list in %%doc
108- rebuilt for x86_64 architecture support
109
110* Tue May 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.3-0vl2
111- readd patch9 to disable warning
112
113* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.3-0vl1
114- new upstream release
115- import patches from fedora package.
116- add patch10 to add ja in LINGUAS
117- add ja.po
118
119* Tue May 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1.2-3vl1
120- synced with Rawhide 3.1.2-3
121
122* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-2vl2
123- fixed typo
124
125* Thu May 31 2001 <sagami@vinelinux.org>
126- 3.0.6-2vl1: follow up with RH 3.0.6-2
127- gawk-3.0.6 + mb1.15
128
129* Mon Aug  7 2000 Jun Nishii <jun@vinelinux.org>
130- 3.0.4-2vl1
131- follow up with RHL62
132- use brp
133
134* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
135- 3.0.4-1vl1
136- change version-release for Vine Linux 2.0
137- bzip2 sources
138
139* Wed Sep 29 1999 Norihito Ohmori <nono@kondara.org>
140- add Multibyte Patch.
141
142* Wed Jun 30 1999 Jeff Johnson <jbj@redhat.com>
143- update to 3.0.4.
144
145* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
146- make sure all binaries are stripped
147
148* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
149- auto rebuild in the new build environment (release 6)
150
151* Fri Feb 19 1999 Jeff Johnson <jbj@redhat.com>
152- Install info pages (#1242).
153
154* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
155- build for glibc 2.1
156- don't package /usr/info/dir
157
158* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
159- translations modified for de, fr, tr
160
161* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
162- upgraded to 3.0.3
163- added documentation and buildroot
164
165* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
166- built against glibc
167
Note: See TracBrowser for help on using the repository browser.