source: projects/specs/trunk/g/gauche/gauche-vl.spec @ 10805

Revision 10805, 4.6 KB checked in by ara_t, 8 years ago (diff)

change Group

Line 
1%define pkg_name    gauche
2%define pkg_version 0.9.5
3%define pkg_release 2%{?_dist_release}
4
5Summary:     An R7RS Scheme implementation developed to be a handy script interpreter
6Summary(ja): R7RS準拠のScheme処理系
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD-style
12Group:   Development/Languages
13URL:     http://practical-scheme.net/gauche/index-j.html
14Source:  Gauche-%{version}.tgz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: zlib-devel
19BuildRequires: gdbm-devel
20BuildRequires: texi2html
21
22# BuildRequires: texinfo
23# BuildRequires: texlive-common
24# BuildRequires: texlive-collection-basic
25# BuildRequires: texlive-collection-latexextra
26# BuildRequires: texlive-collection-fontsextra
27
28# %if %{?_dist_release} == "vl6"
29# BuildRequires: texlive-collection-texinfo
30# %endif
31# %if %{?_dist_release} == "vl7"
32# BuildRequires: texlive-collection-plainextra
33# BuildRequires: texlive-collection-fontsrecommended
34# # rpm -qa --qf "BuildRequires: %{name}\n" | grep -v -e "doc$" | \
35# #   grep texlive-collection-lang
36# BuildRequires: texlive-collection-langenglish
37# BuildRequires: texlive-collection-langkorean
38# BuildRequires: texlive-collection-langitalian
39# BuildRequires: texlive-collection-langpolish
40# BuildRequires: texlive-collection-langgerman
41# BuildRequires: texlive-collection-langjapanese
42# BuildRequires: texlive-collection-langgreek
43# BuildRequires: texlive-collection-langcyrillic
44# BuildRequires: texlive-collection-langeuropean
45# BuildRequires: texlive-collection-langspanish
46# BuildRequires: texlive-collection-langcjk
47# BuildRequires: texlive-collection-langczechslovak
48# BuildRequires: texlive-collection-langfrench
49# BuildRequires: texlive-collection-langarabic
50# BuildRequires: texlive-collection-langother
51# BuildRequires: texlive-collection-langportuguese
52# BuildRequires: texlive-collection-langindic
53# BuildRequires: texlive-collection-langafrican
54# BuildRequires: texlive-collection-langchinese
55# %endif
56
57Requires: gdbm
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: ara_t
62
63
64%description
65Gauche is an R7RS Scheme implementation developed to be a handy
66script interpreter, which allows programmers and system administrators
67to write small to large scripts for their daily chores. Quick startup,
68built-in system interface, native multilingual support are some of my goals.
69
70%descriptionl -l ja
71Gauche(ゴーシュ)は、スクリプトインタプリタとしての使い易さに重点を置いて
72開発を行っているR7RS準拠のScheme処理系です。日常業務の中でのちょっとした
73処理を行うスクリプトを気軽にSchemeで書きたいなあ、という願望のもとに、
74起動が速いこと、システムへのアクセスが組み込まれていること、 最初から
75多国語対応を考慮していること、リスト処理ライブラリとして他のC/C++プログラム
76から簡単にリンク可能であること、などを目標としています。
77
78
79%prep
80%{__rm} -rf ${RPM_BUILD_ROOT}
81%setup -q -n Gauche-%{version}
82
83%build
84%{configure} --enable-multibyte=utf-8
85%{__perl} -pi -e "s|DESTDIR\ +\=|DESTDIR = ${RPM_BUILD_ROOT}|" src/Makefile
86
87%{__make} %{?_smp_mflags}
88# (cd doc; %{__make} pdf html)
89(cd doc; %{__make} html)
90
91%install
92export LD_LIBRARY_PATH=${RPM_BUILD_ROOT}%{_libdir}:${LD_LIBRARY_PATH}
93%{__make} install DESTDIR=${RPM_BUILD_ROOT}
94%{__make} install-doc DESTDIR=${RPM_BUILD_ROOT}
95
96%check
97export LD_LIBRARY_PATH=${RPM_BUILD_ROOT}%{_libdir}:${LD_LIBRARY_PATH}
98%{__make} check
99
100%clean
101%{__rm} -rf ${RPM_BUILD_ROOT}
102
103%post
104for doc in gauche-refe gauche-refj; do
105    file=%{_infodir}/${doc}.info.gz
106    if [ -e ${file} ]; then
107        /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
108    fi
109done
110%{_syssbindir}/ldconfig
111
112%preun
113if [ $1 = 0 ]; then
114    for doc in gauche-refe gauche-refj; do
115        file=%{_infodir}/${doc}.info.gz
116        if [ -e ${file} ]; then
117            /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
118        fi
119    done
120fi
121
122%postun -p %{_syssbindir}/ldconfig
123
124
125%files
126%defattr(-, root, root)
127%doc AUTHORS COPYING ChangeLog HACKING NEWS README
128%doc doc/gauche-ref*.html
129# %doc doc/gauche-ref*.pdf
130%{_bindir}/
131%{_libdir}/gauche-*
132%{_libdir}/libgauche-*.so*
133%{_datadir}/aclocal/
134%{_datadir}/gauche-*
135%{_infodir}/
136%{_mandir}/man1/
137
138
139%changelog
140* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 0.9.5-2
141- change Group to Development/Languages
142
143* Sat Oct 08 2016 Toshiaki Ara <ara_t@384.jp> 0.9.5-1
144- update to 0.9.5
145- drop PDF manual
146
147* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 0.9.4-2
148- make pdf manuals
149- add BuildRequires
150
151* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 0.9.4-1
152- new package
Note: See TracBrowser for help on using the repository browser.