source: projects/specs/trunk/g/gated/gated-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The public release version of the GateD routing daemon.
2Summary(ja): GateD ¥ë¡¼¥Æ¥£¥ó¥°¥Ç¡¼¥â¥ó¤Î¥Ñ¥Ö¥ê¥Ã¥¯¥ê¥ê¡¼¥¹ÈÇ
3Name: gated
4Version: 3.6
5Release: 5vl1
6Copyright: distributable
7Group: System Environment/Daemons
8Source0: ftp://ftp.gated.org/net-research/gated/gated-3-6.tar.gz
9Source1: gated-3.5.10-init
10Source2: gated-conf-3.5.11.tar.gz
11Source3: gated-docs-3.5.11.tar.gz
12Source4: gated-man-3.5.11.tar.gz
13Source5: gated-3.5.10-gated.conf
14Patch0: gated-3.5.11-rh70.patch
15Patch1: gated-3.6-noscram.patch
16Patch2: gated-3.6-installfix.patch
17URL: http://www.gated.org/
18Prereq: /sbin/chkconfig
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21
22%description
23GateD is a modular software program consisting of core services, a
24routing database, and protocol modules which support multiple routing
25protocols (RIP v1, v2), OSPF, ISIS, SLSP, BGP (v3, v4), and EGP.
26GateD is designed to handle dynamic routing with a routing database
27built from the information exchanged by routing protocols.
28
29Install gated if you need a routing daemon.
30
31%description -l ja
32GateD ¤Ï¥³¥¢¥µ¡¼¥Ó¥¹¡¤¥ë¡¼¥Æ¥£¥ó¥°¥Ç¡¼¥¿¥Ù¡¼¥¹¡¤µÚ¤Ó
33RIP v1, v2¡¤OSPF, ISIS, SLSP, BGP (v3, v4), EGP Åù¤Î¥ë¡¼¥Æ¥£¥ó¥°
34¥×¥í¥È¥³¥ë¤ËÂбþ¤·¤¿¥â¥¸¥å¡¼¥ë¤«¤éÀ®¤ë¡¤¥â¥¸¥å¥é¡¼·Á¼°¤Î
35¥½¥Õ¥È¥¦¥§¥¢¥×¥í¥°¥é¥à¤Ç¤¹¡¥
36GateD ¤Ï¥ë¡¼¥Æ¥£¥ó¥°¥×¥í¥È¥³¥ë¤Ç¸ò¤ï¤µ¤ì¤¿¾ðÊó¤ò¸µ¤ËÀ¸À®¤µ¤ì¤¿
37¥ë¡¼¥Æ¥£¥ó¥°¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤ÆưŪ¤Ê¥ë¡¼¥Æ¥£¥ó¥°¤ò¹Ô¤¦ÍÍ
38À߷פµ¤ì¤Æ¤¤¤Þ¤¹¡¥
39
40¥ë¡¼¥Æ¥£¥ó¥°¥Ç¡¼¥â¥ó¤¬É¬Íפʾì¹ç¤Ï gated ¤ò¥¤¥ó¥¹¥È¡¼¥ë¤·¤Æ²¼¤µ¤¤¡¥
41
42
43%prep
44%setup -q -n gated-public-3_6 -a 2 -a 3 -a 4
45%patch0 -p1 -b .rh70
46%patch1 -p1 -b .noscram
47%patch2 -p1 -b .installfix
48
49
50%build
51%configure --enable-dist \
52            --enable-inet \
53            --enable-bgp \
54            --enable-egp \
55            --enable-icmp \
56            --enable-rip \
57            --enable-ospf \
58            --enable-rdisc
59
60make depend
61
62# this stuff is all screwed up
63make || :
64
65make -C src/smux
66make -C src/krt
67make -C src/krt_os
68make -C src/krt_multi
69make -C src/gii
70make -C src/icmp
71make -C src/inet
72make -C src/ospf
73make -C src/rdisc
74make -C src/rip
75make -C src/gatedcompat
76make
77
78
79%install
80rm -fr ${RPM_BUILD_ROOT}
81
82%makeinstall
83
84mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
85install -c -m 0755 %SOURCE1 ${RPM_BUILD_ROOT}%{_initdir}/gated
86
87mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
88install man/*8 ${RPM_BUILD_ROOT}%{_mandir}/man8
89
90mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
91install src/gdc/gdc ${RPM_BUILD_ROOT}%{_sbindir}
92install src/ripquery/ripquery ${RPM_BUILD_ROOT}%{_sbindir}
93install src/ospf_monitor/ospf_monitor ${RPM_BUILD_ROOT}%{_sbindir}
94
95# sample config file
96cp %{SOURCE5} ./gated.conf.sample
97
98
99%clean
100rm -rf ${RPM_BUILD_ROOT}
101
102
103%post
104/sbin/ldconfig
105/sbin/chkconfig --add gated
106
107
108%preun
109if [ $1 = 0 ] ; then
110    /sbin/chkconfig --del gated
111    /sbin/service gated stop >/dev/null 2>&1
112fi
113
114
115%postun
116if [ "$1" -ge "1" ]; then
117    service gated condrestart > /dev/null 2>&1
118fi
119
120
121%files
122%defattr(-,root,root)
123%doc CHANGES README VERSION gated.conf.sample
124%doc conf doc
125%config %{_initdir}/gated
126%{_sbindir}/gdc
127%{_sbindir}/ripquery
128%{_sbindir}/ospf_monitor
129%{_sbindir}/gated
130
131
132%changelog
133* Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
134- 3.6-5vl1
135- based on 3.6-5 from Rawhide
136- use better macros (%%{_initdir})
137- added Japanese summary and description
138
139* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
140- gettextize the init script
141
142* Wed Oct 11 2000 Jeff Johnson <jbj@redhat.com>
143- re-add gdc (and ripquery) to the gated package (#18914).
144
145* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
146- move initscript back
147
148* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
149- automatic rebuild
150
151* Fri Jun 30 2000 Preston Brown <pbrown@redhat.com>
152- gated 3.6 public
153- include configs and man pages from old gated; they are missing from archive.
154- condrestart directive and initscript fixage/movage
155
156* Sun Jun  4 2000 Jeff Johnson <jbj@redhat.com>
157- build with rpm FHS macros.
158- remove bogus dependence on libdb.so.3.
159
160* Thu Feb 17 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
161- Update to 3.5.11 (this fixes bug #483 and probably #7811)
162- Get rid of CC=egcs (Bug #5929)
163- handle RPM_OPT_FLAGS
164- fix typo in specfile (Consortium_Agreement, not _Agreeemnt)
165
166* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
167- init script marked config.
168
169* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
170- handle compressed manpages
171
172* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
173- initscript munging
174
175* Thu Apr 08 1999 Preston Brown <pbrown@redhat.com>
176- sample config script and init script are world readable
177
178* Wed Mar 31 1999 Jeff Johnson <jbj@redhat.com>
179- kernel-2.2 changed /proc/net/route (#1894)
180
181* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
182- auto rebuild in the new build environment (release 7)
183
184* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
185- use /var/gated for generated files to avoid d-o-s attacks.
186
187* Mon Dec  7 1998 Jeff Johnson <jbj@redhat.com>
188- merge in patches from Matthew Grant <grantma@anathoth.gen.nz> (#6)
189
190* Sun Dec  6 1998 Jeff Johnson <jbj@redhat.com>
191- fix init script (#35).
192
193* Thu Sep 03 1998 Cristian Gafton <gafton@redhat.com>
194- version 3.5.10
195
196* Tue May 05 1998 Prospector System <bugs@redhat.com>
197- translations modified for de, fr, tr
198
199* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
200- enhanced initscript
201
202* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
203- upgraded to 3.5.9
204
205* Thu Jan  8 1998 Cristian Gafton <gafton@redhat.com>
206- upgraded to 3.5.8
207- added glibc patch to aid glibc's brain-dead define of IFF_ constants
208  as enums instead of #defines
209- we install now gated.conf.sample instead of gated.conf, so gated won't be
210  started accidentaly anymore
211
212* Tue Oct 27 1997 Cristian Gafton <gafton@redhat.com>
213- build against glibc; added BuildRoot
Note: See TracBrowser for help on using the repository browser.