source: projects/specs/trunk/g/galera/galera-vl.spec @ 12399

Revision 12399, 8.6 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

clamav-0.102.3-1

galera-26.4.4-1

mariadb-10.4.13-1

php74-7.4.6-1

postgresql-12.3-1

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%define galera_api_version 26.4
5%define mariadb_version 10.4.13
6
7%if %{with python3}
8%global scons scons-3
9%else
10%global scons scons
11%endif
12
13Name:           galera
14Version:        %{galera_api_version}.4
15Release:        1%{?_dist_release}%{?with_systemd:.systemd}
16Summary:        Synchronous multi-master wsrep provider (replication engine)
17
18License:        GPLv2
19URL:            http://galeracluster.com/
20
21# Actually, the truth is, we do use galera source tarball provided by MariaDB on
22# following URL (without macros):
23#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
24
25Source0:        https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
26
27Source1:        garbd.service
28Source2:        garbd-wrapper
29Source3:        garbd.init
30
31Patch0:         galera-python3.patch
32
33BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
34%if %{with systemd}
35BuildRequires:  systemd
36%endif
37Requires:       nmap
38Provides:       galera(%{galera_api_version})
39
40%if %{with systemd}
41Requires(post): systemd
42Requires(preun): systemd
43Requires(postun): systemd
44%else
45Requires(post): chkconfig
46Requires(preun): chkconfig initscripts
47%endif
48
49%description
50Galera is a fast synchronous multi-master wsrep provider (replication engine)
51for transactional databases and similar applications. For more information
52about wsrep API see http://launchpad.net/wsrep. For a description of Galera
53replication engine see http://www.codership.com.
54
55
56%debug_package
57
58
59%prep
60%setup -q
61%if %{with python3}
62%patch0 -p1
63%endif
64
65%build
66CPPFLAGS="%{optflags}"
67CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
68export CPPFLAGS
69
70%{scons} %{?_smp_mflags} strict_build_flags=0
71
72
73%install
74%if %{with systemd}
75install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
76install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
77%else
78install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
79%endif
80install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
81install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
82install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
83install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
84install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
85install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
86install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
87install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
88install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
89
90
91%post
92/sbin/ldconfig
93%if %{with systemd}
94%systemd_post garbd.service
95%else
96/sbin/chkconfig --add garbd
97%endif
98
99%preun
100%if %{with systemd}
101%systemd_preun garbd.service
102%else
103if [ $1 = 0 -o -x /bin/systemctl ]; then
104/sbin/service garbd stop >/dev/null 2>/dev/null ||:
105/sbin/chkconfig --del garbd
106fi
107%endif
108
109%postun
110/sbin/ldconfig
111%if %{with systemd}
112%systemd_postun_with_restart garbd.service
113%endif
114
115
116%files
117%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
118%dir %{_docdir}/galera
119%dir %{_libdir}/galera
120%{_sbindir}/garbd
121%if %{with systemd}
122%{_sbindir}/garbd-wrapper
123%{_unitdir}/garbd.service
124%else
125%{_initdir}/garbd
126%endif
127%{_libdir}/galera/libgalera_smm.so
128%license %{_docdir}/galera/COPYING
129%license %{_docdir}/galera/LICENSE.asio
130%license %{_docdir}/galera/LICENSE.crc32
131%license %{_docdir}/galera/LICENSE.chromium
132%doc %{_docdir}/galera/README
133%doc %{_docdir}/galera/README-MySQL
134
135
136%changelog
137* Thu May 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.4-1
138- new upstream release.
139
140* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-2
141- rebuilt with boost-1.72.0.
142
143* Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
144- new upstream release.
145
146* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
147- updated to 26.4.2 for MariaDB-10.4.
148
149* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
150- initial build for Vine Linux.
151
152* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
154
155* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
156- Rebuilt for Boost 1.69
157
158* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
159- Rebase to 25.3.25
160
161* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
162- Require asio also on rhel
163
164* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
165- Add explicit gcc-c++ BR
166- Use python3-scons
167
168* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
169- Do not require asio on rhel
170
171* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
173
174* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
175- Update to 25.3.23
176
177* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
179
180* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
181- Update to 25.3.22
182
183* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
185
186* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
188
189* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
190- Rebuilt for Boost 1.64
191
192* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
194
195* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
196- Use asio-devel instead of bundled asio library
197
198* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
200
201* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
202- Update to 25.3.16
203
204* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
206
207* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
208- Rebuilt for Boost 1.60
209
210* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
211- Remove use of -mtune=native which breaks build on secondary architectures
212
213* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
214- Update to 25.3.12.
215- Should fix the build on 32 bit ARM (RHBZ#1241164).
216- Remove ExcludeArch (should have read the BZ more closely).
217
218* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
219- Rebuilt for Boost 1.59
220
221* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
222- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
223
224* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
225- rebuild for Boost 1.58
226
227* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
228- Disable ARM builds (#1241164, #1239516)
229
230* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
231- Update to version 25.3.10
232
233* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
235
236* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
237- Rebuild for boost 1.57.0
238
239* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
240- Add aarch64 support.
241
242* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
244
245* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
246- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
247
248* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
249- Rebuild for boost 1.55.0
250
251* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
252- set ExclusiveArch
253
254* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
255- Use strict_build_flags=0 to avoid -Werror
256- Remove unnecessary clean section
257
258* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
259- Include galera directories in file list
260- Set CPPFLAGS to optflags
261
262* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
263- Fix client certificate verification (#1090604)
264
265* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
266- Update to version 25.3.5
267
268* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
269- Add systemd service
270
271* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
272- Initial build
Note: See TracBrowser for help on using the repository browser.