source: projects/specs/trunk/g/galera/galera-vl.spec @ 12062

Revision 12062, 8.0 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%if %{with python3}
5%global scons scons-3
6%else
7%global scons scons
8%endif
9
10Name:           galera
11Version:        25.3.25
12Release:        4%{?_dist_release}
13Summary:        Synchronous multi-master wsrep provider (replication engine)
14
15License:        GPLv2
16URL:            http://galeracluster.com/
17
18# Actually, the truth is, we do use galera source tarball provided by MariaDB on
19# following URL (without macros):
20#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
21
22Source0:        http://releases.galeracluster.com/source/%{name}-%{version}.tar.gz
23
24Source1:        garbd.service
25Source2:        garbd-wrapper
26Source3:        garbd.init
27
28Patch0:         galera-python3.patch
29
30BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
31%if %{with systemd}
32BuildRequires:  systemd
33%endif
34Requires:       nmap
35
36
37%if %{with systemd}
38Requires(post): systemd
39Requires(preun): systemd
40Requires(postun): systemd
41%else
42Requires(post): chkconfig
43Requires(preun): chkconfig initscripts
44%endif
45
46
47%description
48Galera is a fast synchronous multi-master wsrep provider (replication engine)
49for transactional databases and similar applications. For more information
50about wsrep API see http://launchpad.net/wsrep. For a description of Galera
51replication engine see http://www.codership.com.
52
53
54%prep
55%setup -q
56%if %{with python3}
57%patch0 -p1
58%endif
59
60%build
61CPPFLAGS="%{optflags}"
62CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
63export CPPFLAGS
64
65%{scons} %{?_smp_mflags} strict_build_flags=0
66
67
68%install
69%if %{with systemd}
70install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
71install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
72%else
73install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
74%endif
75install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
76install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
77install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
78install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
79install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
80install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
81install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
82install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
83install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
84
85
86%post
87/sbin/ldconfig
88%if %{with systemd}
89%systemd_post garbd.service
90%else
91/sbin/chkconfig --add garbd
92%endif
93
94%preun
95%if %{with systemd}
96%systemd_preun garbd.service
97%else
98if [ $1 = 0 ]; then
99/sbin/service garbd stop >/dev/null 2>/dev/null ||:
100/sbin/chkconfig --del garbd
101fi
102%endif
103
104%postun
105/sbin/ldconfig
106%if %{with systemd}
107%systemd_postun_with_restart garbd.service
108%endif
109
110
111%files
112%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
113%dir %{_docdir}/galera
114%dir %{_libdir}/galera
115%{_sbindir}/garbd
116%if %{with systemd}
117%{_sbindir}/garbd-wrapper
118%{_unitdir}/garbd.service
119%else
120%{_initdir}/garbd
121%endif
122%{_libdir}/galera/libgalera_smm.so
123%license %{_docdir}/galera/COPYING
124%license %{_docdir}/galera/LICENSE.asio
125%license %{_docdir}/galera/LICENSE.crc32
126%license %{_docdir}/galera/LICENSE.chromium
127%doc %{_docdir}/galera/README
128%doc %{_docdir}/galera/README-MySQL
129
130
131%changelog
132* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
133- initial build for Vine Linux.
134
135* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
137
138* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
139- Rebuilt for Boost 1.69
140
141* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
142- Rebase to 25.3.25
143
144* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
145- Require asio also on rhel
146
147* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
148- Add explicit gcc-c++ BR
149- Use python3-scons
150
151* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
152- Do not require asio on rhel
153
154* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
156
157* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
158- Update to 25.3.23
159
160* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
162
163* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
164- Update to 25.3.22
165
166* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
168
169* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
171
172* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
173- Rebuilt for Boost 1.64
174
175* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
177
178* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
179- Use asio-devel instead of bundled asio library
180
181* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
183
184* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
185- Update to 25.3.16
186
187* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
189
190* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
191- Rebuilt for Boost 1.60
192
193* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
194- Remove use of -mtune=native which breaks build on secondary architectures
195
196* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
197- Update to 25.3.12.
198- Should fix the build on 32 bit ARM (RHBZ#1241164).
199- Remove ExcludeArch (should have read the BZ more closely).
200
201* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
202- Rebuilt for Boost 1.59
203
204* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
205- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
206
207* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
208- rebuild for Boost 1.58
209
210* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
211- Disable ARM builds (#1241164, #1239516)
212
213* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
214- Update to version 25.3.10
215
216* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
218
219* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
220- Rebuild for boost 1.57.0
221
222* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
223- Add aarch64 support.
224
225* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
227
228* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
229- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
230
231* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
232- Rebuild for boost 1.55.0
233
234* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
235- set ExclusiveArch
236
237* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
238- Use strict_build_flags=0 to avoid -Werror
239- Remove unnecessary clean section
240
241* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
242- Include galera directories in file list
243- Set CPPFLAGS to optflags
244
245* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
246- Fix client certificate verification (#1090604)
247
248* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
249- Update to version 25.3.5
250
251* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
252- Add systemd service
253
254* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
255- Initial build
Note: See TracBrowser for help on using the repository browser.