source: projects/specs/trunk/g/gal/gal-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define soname  23
2%define libname libgal%{soname}
3
4Summary:        The Gnome Application Library.
5Summary(ja):    Gnome ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¥é¥¤¥Ö¥é¥ê
6Name:           gal
7Version:        0.24
8Release:        1vl3
9License:        GPL
10Group:          System Environment/Libraries
11Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/0.23/%{name}-%{version}.tar.bz2
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildPreReq:    libxml-devel
15BuildPreReq:    freetype2-devel
16BuildPreReq:    libglade-devel >= 0.13
17BuildPreReq:    gnome-vfs-devel
18BuildPreReq:    gnome-print-devel >= 0.22
19BuildPreReq:    gtk+-devel >= 1.2.7
20BuildPreReq:    gtk-doc
21BuildRequires:  autoconf213, automake14
22
23Requires:       libxml >= 1.8.8
24Requires:       libgnomeprint15 >= 0.22
25Requires:       libglade >= 0.13
26Requires:       gtk+ >= 1.2.7
27
28Patch0:         gal-0.18.1-config.patch
29
30
31%description
32A collection of GNOME widgets and utility functions.
33
34%description -l ja
35GNOME ¤Î¥³¥ó¥Ý¡¼¥Í¥ó¥È¤ª¤è¤ÓÌòΩ¤Äµ¡Ç½¤Î¥³¥ì¥¯¥·¥ç¥ó¤Ç¤¹¡£
36
37%package devel
38Summary:  Development files for the GNOME Applications library
39Summary(ja): GNOME ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¥é¥¤¥Ö¥é¥ê¤Î³«È¯ÍÑ¥Õ¥¡¥¤¥ë
40Group:    Development/Libraries
41Requires: %{name} = %{PACKAGE_VERSION}, %{libname}
42Requires: gnome-vfs-devel
43Requires: gnome-print-devel >= 0.22
44Requires: gnome-libs-devel
45Requires: libglade-devel
46
47%description devel
48Development files for the GNOME Applications library
49
50%package -n %{libname}
51Summary: The GNOME Application Library
52Summary(ja): GNOME ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¥é¥¤¥Ö¥é¥ê
53Group: System Environment/Libraries
54Requires: %{name} >= %{version}
55
56%description -n %{libname}
57A collection of GNOME widgets and utility functions.
58
59%description -n %{libname} -l ja
60GNOME ¤Î¥³¥ó¥Ý¡¼¥Í¥ó¥È¤ª¤è¤ÓÌòΩ¤Äµ¡Ç½¤Î¥³¥ì¥¯¥·¥ç¥ó¤Ç¤¹¡£
61
62%prep
63%setup -q
64
65
66%build
67#autoconf
68%define __libtoolize /bin/true
69cp %{_datadir}/libtool/config.{guess,sub} .
70%configure --disable-gtk-doc
71make
72
73
74%install
75%makeinstall
76
77##%find_lang %{name}
78
79%clean
80[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
81
82
83%post -n %{libname} -p /sbin/ldconfig
84
85%postun -n %{libname} -p /sbin/ldconfig
86
87
88##%files -f %{name}.lang
89%files
90%defattr(-, root, root)
91%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
92%dir %{_datadir}/gal
93%{_datadir}/gal/%{version}/pixmaps
94%{_datadir}/gal/%{version}/glade
95%{_datadir}/locale
96
97%files devel
98%defattr(-, root, root)
99%{_libdir}/*.so
100%{_libdir}/*.a
101%{_libdir}/*.la
102%{_libdir}/*sh
103%{_libdir}/pkgconfig/*.pc
104%{_includedir}/*
105
106
107%files -n %{libname}
108%defattr(-, root, root)
109%{_datadir}/etable
110%{_datadir}/gal/html
111%{_libdir}/libgal.so.%{soname}
112%{_libdir}/libgal.so.*.*
113
114
115%changelog
116* Thu Sep 06 2007 Shu KONNO <owa@bg.wakwak.com> 0.24-1vl3
117- dropt %%find_lang (added locale data directry to %%files)
118
119* Tue Oct 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.24-1vl2
120- rebuilt with db4-4.2.52
121- added Japanese summary to all packages
122- s/Copyright/License/
123- fixed %post, %postun script
124
125* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.24-1vl1
126- updated to 0.24
127- so ver is updated
128
129* Wed Mar  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.23-1vl1
130- updated to new upstream release.
131- so ver is updated
132
133* Sun Sep 15 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.19.3-0vl1
134- updated to new upstream release.
135
136* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.19-0vl1
137- New upstream release.
138- Seperated the shared libraries.
139
140* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.18.1-0vl1
141- New upstream release.
142
143* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.7-0vl1
144- New upstream release.
145
146* Fri Mar 30 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5-0vl2
147- Fixed font selection with e-font.
148- Use %find_lang macro.
149
150* Wed Mar 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5-0vl1
151- New upstream release.
152
153* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.4.99.0-0vl1
154- Build for Vine
155
156* Fri Oct 10 2000 John Gotts <jgotts@linuxsavvy.com>
157- Created spec file.
Note: See TracBrowser for help on using the repository browser.