source: projects/specs/trunk/f/fxload/fxload-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: fxload
2Version: 2002_04_11
3Release: 7%{?dist}
4Summary: A helper program to download firmware into FX and FX2 EZ-USB devices
5Summary(ja): FX/FX2 EZ-USB デバイスにファームウェアをダウンロードするプログラム
6
7Group: System Environment/Kernel
8License: GPLv2+
9URL: http://linux-hotplug.sourceforge.net/
10Source0: fxload-2002_04_11-noa3load.tar.gz
11# The above file is derived from:
12# http://downloads.sourceforge.net/linux-hotplug/fxload-2002_04_11.tar.gz
13# This file contains code that is copyright Cypress Semiconductor Inc,
14# and cannot be distributed. Therefore we use this script to remove the
15# copyright code before shipping it. Download the upstream tarball and
16# invoke this script while in the tarball's directory:
17# ./fxload-generate-tarball.sh 2002_04_11
18Source1: fxload-generate-tarball.sh
19Patch0: fxload-header.patch
20Patch1: fxload-noa3load.patch
21BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
22
23BuildRequires: kernel-headers
24Requires: udev
25Conflicts: hotplug-gtk hotplug
26
27%description
28This program is conveniently able to download firmware into FX and FX2
29EZ-USB devices, as well as the original AnchorChips EZ-USB.  It is
30intended to be invoked by udev scripts when the unprogrammed device
31appears on the bus.
32
33%description -l ja
34このプログラムを使って、EZ-USB FX / FX2 デバイス、およびオリジナルの
35AnchorChips EZ-USB にファームウェアをダウンロードすることができます。
36本プログラムは、バス上にデバイスが検出された時に udev スクリプト経由で
37起動されるものです。
38
39%prep
40%setup -q
41%patch0 -p0 -b .fxload-header
42%patch1 -p1 -b .fxload-noa3load
43
44%build
45make
46
47%install
48rm -rf %{buildroot}
49mkdir -p -m 755 %{buildroot}/sbin
50install -m 755 fxload %{buildroot}/sbin
51mkdir -p -m 755 %{buildroot}/%{_mandir}/man8/
52install -m 644 fxload.8 %{buildroot}/%{_mandir}/man8/
53
54%clean
55rm -rf %{buildroot}
56
57%files
58%defattr(0644,root,root,0755)
59%doc COPYING
60%doc README.txt
61%attr(0755, root, root) /sbin/fxload
62%{_mandir}/*/*
63
64%changelog
65* Thu Feb 19 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2002_04_11-7
66- initial build for Vine Linux
67
68* Sat Feb 9 2008 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-7
69- Bump version to rebuild with gcc-4.3
70
71* Sat Nov 16 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-6
72- Rework the spec file formatting to match templates from rpmdev
73- Be explicit about file attributes, just in case
74
75* Sat Nov 16 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-5
76- Updates after reading packaging guide-lines more thoroughly:
77- Make license version more explicit
78- Add generate-tarball.sh, and associated comments
79- Added BuildRequires on kernel-headers
80- Added COPYING as a doc
81- Use dollar v.s. percent macros more consitently
82
83* Fri Nov 15 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-4
84- Repackage the source tarball to remove a3load.hex
85- Added instructions to spec file on how to do the above
86- Remove reference to a3load.hex from the man page too
87
88* Thu Nov 15 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-3
89- Update BuildRoot per Fedora wiki
90- Fixed rpmlint complaint about not cleaning buildroot
91- Updated source patch file to match latest kernel file layout
92- Add patch to remove reference to non-shipped non-free a3load.hex firmware
93
94* Fri Dec 8 2006 Bart Vanbrabant <bart.vanbrabant@zoeloelip.be> - 2002_04_11-2
95- Fixed some rpmlint complaints
96- Added patch to fix an include header
97- Added dist tag
98
99* Wed Apr 12 2006 Bart Vanbrabant <bart.vanbrabant@zoeloelip.be> - 2002_04_11-1
100- First version of fxload spec based on hotplug spec
101
Note: See TracBrowser for help on using the repository browser.