source: projects/specs/trunk/f/fwbackups/fwbackups-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2Name:              fwbackups
3Version:           1.43.2
4Release:           2%{?_dist_release}
5Summary:           A feature-rich user backup program
6Summary(ja):       機能豊富なユーザバックアッププログラム
7Group:             Applications/Archiving
8License:           GPLv2+
9URL:               http://www.diffingo.com/content/view/12/45/lang,en/
10Source0:           http://www.diffingo.com/downloads/%{name}/%{name}-%{version}.tar.gz
11BuildRoot:         %{_tmppath}/%{name}-%{version}-root
12BuildArch:         noarch
13
14BuildRequires:     desktop-file-utils
15BuildRequires:     gettext
16BuildRequires:     intltool, automake
17BuildRequires:     libxml2
18BuildRequires:     python-devel >= 2.4
19BuildRequires:     scrollkeeper
20BuildRequires:     gnome-doc-utils
21BuildRequires:     perl-XML-Parser
22Requires:          /usr/bin/crontab
23Requires:          tar, rsync
24Requires:          notify-python, gnome-python
25Requires:          pygtk2, pygtk2-libglade
26Requires:          python >= 2.4
27Requires:          python-paramiko
28Requires(post):    scrollkeeper
29Requires(postun):  scrollkeeper
30
31%description
32fwbackups is a feature-rich user backup program that allows users (including
33but not limited to root) to backup their files on demand or periodically via
34backup sets. Each set may have different settings meaning users can backup
35groups of files and folders to different destinations at different times.
36Restores can be performed at any time using an existing backup from fwbackups
37or from the contents of an external folder or archive.
38
39%description -l ja
40fwbackups はユーザ(rootを含むもこれに限定されず)がバックアップセットを介して
41要求に応じて、或いは定期的にファイルのバックアップをとることができる
42機能豊富なユーザバックアッププログラムです。
43各々のセットには、ユーザが異なる時間・異なる目的地にファイルとフォルダのグループの
44バックアップを取ることができることを意味している異なるセッティングがあるかもしれません。
45リストアは、いつでも fwbackups 、或いは外部フォルダやアーカイブのコンテンツから
46既存のバックアップを使用することで実行できます。
47
48%prep
49%setup -q
50
51%build
52%configure --disable-scrollkeeper
53# We don't implement this yet: make %{?_smp_mflags}
54make
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install DESTDIR=$RPM_BUILD_ROOT
59
60desktop-file-install --vendor vine\
61    --dir ${RPM_BUILD_ROOT}%{_datadir}/applications\
62    --delete-original \
63    ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
64
65%find_lang %{name} --with-gnome
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post
71scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
72
73%postun
74scrollkeeper-update -q || :
75
76%files -f %{name}.lang
77%defattr(-,root,root,-)
78
79%{_bindir}/*
80%{_datadir}/%{name}/
81%{_datadir}/pixmaps/*
82%{_datadir}/applications/vine-*.desktop
83%{python_sitelib}/%{name}/
84
85%doc AUTHORS README COPYING COPYING-DOCS ChangeLog TODO
86
87%changelog
88* Thu Mar 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.43.2-2
89- rebuilt with new environment
90
91* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.43.2-1
92- initial build for VineSeed
93
94* Wed Oct 1 2008 Stewart Adam <s.adam at diffingo.com> 1.43.2-1
95- Update to 1.43.2 final
96- BR: gnome-doc-utils
97
98* Fri Jul 18 2008 Stewart Adam <s.adam at diffingo.com> 1.43.2-0.1.rc3
99- Update to 1.43.2rc3
100
101* Sat May 31 2008 Stewart Adam <s.adam at diffingo.com> 1.43.2-0.1.rc2
102- Update to 1.43.2rc2
103
104* Sat Apr 12 2008 Stewart Adam <s.adam at diffingo.com> 1.43.2-0.1.rc1
105- Update to 1.43.2rc1
106
107* Thu Jan 17 2008 Stewart Adam <s.adam at diffingo.com> 1.43.2-0.1.beta3
108- Update to beta3 (not finished work yet)
109- BR: libxml2
110- Remove useless python >= 2.4 BR
111- Remove scrollkeeper scriptlets; Only need that for .omf files
112- Don't require vixie-cron, but do require /usr/bin/crontab
113
114* Wed Oct 31 2007 Stewart Adam <s.adam at diffingo.com> 1.43.2-0.1.beta1
115- Update to 1.43.2 beta1
116
117* Mon Oct 22 2007 Stewart Adam <s.adam at diffingo.com> 1.43.2-0.1
118- 1.42.3 spec using autotools/automake
119- Remove Manual fields patch
120
121* Sat Sep 1 2007 Stewart Adam <s.adam at diffingo.com> 1.43.1-5
122- Add BR python-devel
123
124* Thu Aug 16 2007 Stewart Adam <s.adam at diffingo.com> 1.43.1-4
125- Add Requires vixie-rcron
126
127* Mon Aug 13 2007 Stewart Adam <s.adam at diffingo.com> 1.43.1-3
128- Update license field
129
130* Wed Jul 25 2007 Stewart Adam <s.adam at diffingo.com> 1.43.1-2
131- Add Manual fields patch (bz #249592)
132
133* Sun Jul 22 2007 Stewart Adam <s.adam at diffingo.com> 1.43.1-1
134- Change get_python_lib() to get_python_lib(1) for x86_64
135- Add new Requires and Post(un) scripts because of new documentation
136- Switch all instances of fwbackups to %%{name} for consistency
137- Update to 1.43.1 (see CHANGELOG file for details on version changes)
138
139* Sun Jul 8 2007 Stewart Adam <s.adam at diffingo.com> 1.43.0-1
140- Add BuildRequires python 2.4, gettext
141- Add Requires python 2.4, notify-python
142- No longer requires redhat-artwork and usermode
143- New description
144- Update to 1.43.0 (see CHANGELOG file for details on version changes)
145
146* Sat Apr 14 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.43.0-0.1.beta3
147- Update to 1.43.0 Beta3
148
149* Mon Mar 26 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.43.0-0.1.beta2
150- Update to 1.43.0 Beta2
151
152* Sun Mar 18 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.43.0-0.1.beta1
153- Make release a Beta1 so the upgrade to final upgrade goes smoothly...
154
155* Fri Mar 16 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.43.0-3
156- Minor changes to package again
157
158* Wed Mar 14 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.43.0-2
159- Minor changes
160
161* Mon Feb 12 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.43.0-1
162- Update to version 1.43
163
164* Sun Jan 28 2007 Stewart Adam <s.adam AT diffingo DOT com> 1.42.2-1
165- Update to version 1.42.2 (see CHANGELOG file for details on version changes)
166
167* Sat Sep 30 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42.1-3
168- Clean up spec for final submission to Fedora Extras
169
170* Sat Sep 30 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42.1-2
171- Match upstream md5sum
172- Fix capitals in %%Source0 tag
173
174* Tue Sep 26 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42.1-1
175- Clean up %%install section
176- Don't install fwbackups.conf twice
177- Make tarball match upstream
178- Add the default configuration file to %%doc, and make it replaceable
179- Update to version 1.42.1 (see CHANGELOG file for details on version changes)
180
181* Thu Sep 21 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42-5
182- Add %%requires: pygtk2-libglade
183
184* Wed Sep 13 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42-4
185- Fix the python_sitearch macro
186- Update file paths
187- Fix URL tag
188
189* Wed Sep 06 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42-3
190- Made pam use 'include' statements and not the old pam_stack
191- Use relative symlinks
192
193* Sun Sep 03 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42-2
194- Added CHANGELOG file for detailed information on changes between versions
195- Made this .spec and package files suitable for Fedora Extras submission
196
197* Thu Aug 29 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42-1
198- Fixed errors when removing symbolic links
199- Make listing files in RemoveOldBackups list files and directory names, not their contents
200
201* Thu Aug 15 2006 Stewart Adam <s.adam AT diffingo DOT com> 1.42-0
202- Rebuild using sample .spec file from Fedora Extras
203- Update to version 1.42 (see CHANGELOG file for details on version changes)
204
Note: See TracBrowser for help on using the repository browser.