source: projects/specs/trunk/f/fvwm2/fvwm2-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An improved version of the FVWM window manager for X.
2Summary(ja): fvwm2 (F(?) Virtual Window Manager version 2) の日本語対応版
3Name: fvwm2
4Version: 2.5.28
5Release: 1%{?_dist_release}
6License: GPLv2
7Group: User Interface/Desktops
8Url: http://www.fvwm.org
9Source0: ftp://ftp.fvwm.org/pub/fvwm/version-2/fvwm-%{version}.tar.bz2
10Source1: fvwm-2.0.46.icons.tar.gz
11##Source2: compat-icons.tar.gz
12Source3: fvwm2rc.vine
13Source4: fvwm2rc.vine.ja
14Source10: start_fvwm2
15Source11: fvwm.desktop
16Source12: fvwm-setwallpaper
17Source13: fvwm-resetwallpaper
18Source20: fvwm.ja.po
19Source21: FvwmTaskBar.ja.po
20Source22: FvwmScript.ja.po
21Source30: Blue-Vine-theme.tar.bz2
22Source31: fvwm-backgrounds.tar.bz2
23Source32: fvwm-system-styles.tar.bz2
24Source40: Exit.png
25Source41: fvwm-start.png
26Source42: mlterm.png
27##Patch0: fvwm-2.2.5-I18N_mb-2.1.patch
28##Patch1: fvwm-2.2.2-vine.patch
29##Patch2: fvwm-2.2.2-adhoc.patch
30Patch10: fvwm2-config.patch
31Patch11: fvwm-form-setup.patch
32Patch12: fvwm-script-setup95.patch
33
34BuildRequires: glibc-devel xorg-x11-proto-devel  libXpm-devel readline-devel
35BuildRequires: ncurses-devel perl gtk+-devel imlib-devel libXft-devel
36BuildRequires: fribidi-devel libpng-devel librsvg2-devel libSM-devel
37BuildRequires: libxslt-devel libXrender-devel libXinerama-devel libXt-devel
38Requires: glibc libXpm readline
39Requires: ncurses perl >= 5.004 gtk+ imlib libXft
40Requires: fribidi libpng librsvg2 libSM
41Requires: libxslt libXrender libXinerama libXt
42Requires: Gtk-Perl zenity xsri ImageMagick w3m
43Buildroot: %{_tmppath}/%{name}-%{version}-root
44
45%description
46FVWM2 (the F stands for whatever you want, but the VWM stands for
47Virtual Window Manager) is an improved version of the FVWM window
48manager for the X Window System and shares the same characteristics as
49FVWM. 
50
51Install the fvwm2 package if you'd like to use the FVWM2 window manager.
52If you install fvwm2, you'll also need to install fvwm2-icons.
53
54%description -l ja
55高機能でカラフルな X 用ウィンドウマネージャ fvwm2 (FVWM version 2) の
56日本語版です。ウィンドウマネージャとは、X 上の各クライアントのウィンド
57ウを操作(移動・リサイズ等)したり、枠を装飾したりするソフトウェアです。
58
59%prep
60%setup -n fvwm-%{version} -q -a 1 -a 30 -a 31 -a 32
61##%patch0 -p1 -b .mb
62##%patch1 -p1 -b .redhat
63##%ifarch ppc
64##%patch2 -p1 -b .adhoc
65##%endif
66%patch10 -p1
67%patch11 -p1
68%patch12 -p1
69
70cp -p %{SOURCE3} sample.fvwmrc/system.fvwm2rc
71cp -p %{SOURCE4} sample.fvwmrc/system.fvwm2rc.ja
72#cp -p %{SOURCE10} .
73#cp -p %{SOURCE11} .
74cp -p %{SOURCE20} %{SOURCE21} %{SOURCE22} po/
75
76%build
77%configure --enable-htmldoc
78
79if [ "$SMP" != "" ]; then
80  make -j$SMP "MAKE=make -j$SMP"
81else
82  make
83fi
84
85pushd po
86make fvwm.ja.gmo
87make FvwmScript.ja.gmo
88make FvwmTaskBar.ja.gmo
89popd
90
91%install
92# fvwm2 package
93rm -rf %{buildroot}
94mkdir -p %{buildroot}/%{_libexecdir}/%{name}/%{version}
95%makeinstall
96#----- startup script
97%__install %{SOURCE10} %{buildroot}/%{_bindir}/
98#----- wallpaper utility
99%__install %{SOURCE12} %{buildroot}/%{_bindir}/
100%__install %{SOURCE13} %{buildroot}/%{_bindir}/
101#----- desktop session entry file
102%__mkdir -p %{buildroot}/%{_sysconfdir}/X11/dm/Sessions
103%__install -m0644 %{SOURCE11} %{buildroot}/%{_sysconfdir}/X11/dm/Sessions/
104#----- fvwm config files
105%__mkdir -p %{buildroot}/%{_datadir}/fvwm/Blue-Vine-theme
106%__install -m0644 Blue-Vine-theme/.fvwm2rc %{buildroot}/%{_datadir}/fvwm/Blue-Vine-theme
107%__install -m0644 Blue-Vine-theme/* %{buildroot}/%{_datadir}/fvwm/Blue-Vine-theme
108#----- wallpaper
109%__mkdir -p %{buildroot}/%{_datadir}/fvwm/backgrounds
110%__install -m0644 backgrounds/* %{buildroot}/%{_datadir}/fvwm/backgrounds
111#----- mini icons
112mkdir -p %{buildroot}%{_datadir}/icons/mini
113install -m 644 icons/*.xpm %{buildroot}%{_datadir}/icons/mini/
114install -m 644 %{SOURCE40} %{SOURCE41} %{SOURCE42} %{buildroot}%{_datadir}/icons/mini/
115#----- modified styles
116mkdir %{buildroot}/%{_datadir}/fvwm/fvwm-system-styles/
117install -m 644 fvwm-system-styles/* %{buildroot}/%{_datadir}/fvwm/fvwm-system-styles/
118
119###find docs/ -type f -perm +111 | xargs -r chmod -x
120
121%clean
122rm -rf %{buildroot}
123
124#-----------------------------------
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING INSTALL INSTALL.fvwm NEWS README
128%doc docs/ANNOUNCE docs/BUGS docs/COMMANDS docs/DEVELOPERS docs/FAQ docs/TODO
129%doc docs/error_codes docs/fvwm.lsm
130%{_bindir}/*
131%{_sysconfdir}/*
132%{_datadir}/fvwm/*
133%{_datadir}/locale/*
134%{_datadir}/man/*
135%{_datadir}/icons/mini/*
136%{_libexecdir}/fvwm/%{version}/*
137%dir %{_datadir}/fvwm
138%dir %{_libexecdir}/fvwm/%{version}
139%dir %{_datadir}/icons/mini
140
141
142
143%changelog
144* Sat Oct  3 2009 KATO Masashi <mkato@par.odn.ne.jp> 2.5.28-1
145- new upstream release
146
147* Sun Aug 30 2009 KATO Masashi <mkato@par.odn.ne.jp> 2.5.27-2
148- update documents(converted text to html)
149
150* Mon Aug 17 2009 KATO Masashi <mkato@par.odn.ne.jp> 2.5.27-1
151- new upstream release
152- dropped patchs(0-2)
153- added patch10(for Japanese translation)
154- added patch11,12(prevents garbled characters)
155- added po files(fvwm.ja.po,FvwmScript.ja.po,FvwmTaskBar.ja.po).
156- added theme files(Blue-Vine)
157- added dm-session entry
158- added startup script
159
160* Thu Nov 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl4
161- rebuilt with new toolchain
162
163* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 2.2.5-0vl3
164- eliminate executable bit in %doc (requierment for /bin/sh)
165
166* Thu Jul 12 2001 <sagami@vinelinux.org>
167- 2.2.5-0vl2: added COPYING README.mb docs
168
169* Mon Feb 26 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
170- 2.2.5-0vl1
171
172* Mon Dec 25 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
173- 2.2.4-0vl4
174- fixed fvwm2rc for Vine 2.1+
175
176* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.2.4-0vl2
177- build on gcc-2.95.3
178- partially used rpmmacros
179
180* Mon Oct 16 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
181- 2.2.4-0vl2
182- added ad-hoc patch to stop segfaults on ppc
183  (va_* in fvwm/{read,misc}.c should be faulty though...)
184
185* Mon Feb  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
186- update to 2.2.4
187
188* Mon Nov  8  1999 Yasuyuki Furukawa <furukawa@vinelinux.or>, Vine vl3,vl4
189- update fontset_wrapper patch(I18N)
190- make default menu NLS (English/Japanese).
191
192* Wed Oct 20 1999 Jun Nishii <jun@flatout.org>
193- modify default menu
194
195* Tue Oct 19 1999 Jun Nishii <jun@flatout.org>
196- build with jp patch by Mr. Furukawa
197
198* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
199- added ability to read wmconfig generated menu (# 2665)
200
201* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
202- removed compatibility icon pak.
203
204* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
205- 2.2.2 bugfix release
206
207* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
208- added some icons from kdebase back to this package for upgrade
209- compatibility.
210
211* Wed Mar 24 1999 Bill Nottingham <notting@redhat.com>
212- don't require xterm-color
213
214* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
215- better default system.fvwm2rc
216
217* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
218- auto rebuild in the new build environment (release 2)
219
220* Fri Feb 26 1999 Cristian Gafton <gafton@redhat.com>
221- package is still not finished yet
222- upgraded to 2.2, got rid of all the cruft in the spec file
223
224* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
225- updated to 2.0.47
226- mark config files as %config files
227
228* Mon Jun 29 1998 Michael Maher <mike@redhat.com>
229- removed duplicate files found in the package Another level.
230- fixes bug: 651
231
232* Thu May 07 1998 Prospector System <bugs@redhat.com>
233- translations modified for de, fr, tr
234
235* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
236- long time no new version released :-(. -> misc patch
237- major spec file cleanups
238
239* Mon Nov 03 1997 Cristian Gafton <gafton@redhat.com>
240- Fixed more bugs (bugs patch)
241
242* Fri Oct 24 1997 Cristian Gafton <gafton@redhat.com>
243- fixed Alpha build
244
245* Thu Oct 16 1997 Cristian Gafton <gafton@redhat.com>
246- fixed FvwmTaskBar severe bug (taskbar patch)
247- misc fixes
248
249* Mon Oct 13 1997 Cristian Gafton <gafton@redhat.com>
250- built against glibc; added -rh and -fixes patches
251
Note: See TracBrowser for help on using the repository browser.