source: projects/specs/trunk/f/ftp/ftp-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The standard UNIX FTP (File Transfer Protocol) client.
2Summary(ja): 標準的な UNIX FTP (ファイル転送プロトコル) クライアント
3Name: ftp
4Version: 0.17
5Release: 33%{?_dist_release}
6License: BSD
7Group: Applications/Internet
8Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-ftp-%{version}.tar.bz2
9Patch1: netkit-ftp-0.17-pre20000412.pasv-security.patch
10Patch2: netkit-ftp-0.17-acct.patch
11Patch3: netkit-ftp.usagi-ipv6.patch
12Patch4: netkit-ftp-0.17-segv.patch
13Patch5: netkit-ftp-0.17-volatile.patch
14Patch6: netkit-ftp-0.17-runique_mget.patch
15Patch7: netkit-ftp-locale.patch
16Patch8: netkit-ftp-0.17-printf.patch
17Patch9: netkit-ftp-0.17-longint.patch
18Patch10: netkit-ftp-0.17-vsftp165083.patch
19Patch11: netkit-ftp-0.17-C-Frame121.patch
20Patch12: netkit-ftp-0.17-data.patch
21Patch13: netkit-ftp-0.17-multihome.patch
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: gcc, glibc-devel, readline-devel, ncurses-devel, perl
24
25%description
26The ftp package provides the standard UNIX command-line FTP (File
27Transfer Protocol) client.  FTP is a widely used protocol for
28transferring files over the Internet and for archiving files.
29
30If your system is on a network, you should install ftp in order to do
31file transfers.
32
33%description -l ja
34この ftp パッケージは標準的な UNIX コマンドラインベースの FTP (フ
35ァイル転送プロトコル) クライアントです。FTP はインターネット経由で
36ファイルを転送したり、ファイルを格納したりするのに広く使われている
37プロトコルです。
38
39もしあなたのシステムがネットワークに接続されていて、そこにファイ
40ルを転送したい場合は、このパッケージをインストールして下さい。
41
42%prep
43%setup -q -n netkit-ftp-%{version}
44%patch1 -p1
45%patch2 -p1 -b .acct
46%patch3 -p1 -b .ipv6
47%patch4 -p1 -b .segv
48%patch5 -p1 -b .volatile
49%patch6 -p1 -b .runique_mget
50%patch7 -p1 -b .locale
51%patch8 -p1 -b .printf
52%patch9 -p1 -b .longint
53%patch10 -p1 -b .vsftp165083
54%patch11 -p1 -b .C-Frame121
55%patch12 -p1 -b .data
56%patch13 -p1 -b .multihome
57
58
59%build
60sh configure --with-c-compiler=gcc --enable-ipv6
61perl -pi -e '
62    s,^CC=.*$,CC=cc,;
63    s,-O2,\$(RPM_OPT_FLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64,;
64    s,^BINDIR=.*$,BINDIR=%{_bindir},;
65    s,^MANDIR=.*$,MANDIR=%{_mandir},;
66    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
67    ' MCONFIG
68
69make %{?_smp_mflags}
70
71
72%install
73rm -rf ${RPM_BUILD_ROOT}
74mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
75mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
76mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
77
78make INSTALLROOT=${RPM_BUILD_ROOT} install
79
80
81%clean
82rm -rf ${RPM_BUILD_ROOT}
83
84%files
85%defattr(-,root,root)
86%{_bindir}/ftp
87%{_bindir}/pftp
88%{_mandir}/man1/ftp.*
89%{_mandir}/man1/pftp.*
90%{_mandir}/man5/netrc.*
91
92
93%changelog
94* Tue Aug  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-33
95- rebuilt with readline 5.2
96- applied new versioning policy
97- spec in UTF-8
98
99* Sat Apr 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-32vl1
100- rebuilt with readline 5.1
101- added patches(9-13) from Fedora
102  * Thu Jan 12 2006 Petr Raszyk <praszyk@redhat.com> - 0.17-32
103  - support for multi-homed clients
104    See #171621, netkit-ftp-0.17-multihome.patch
105  * Fri Dec 2 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-31
106  - ftp does not close socket descriptor (if the remote file
107    does not exist).
108    See #174599, netkit-ftp-0.17-data.patch
109  * Wed Oct 26 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-30
110  - The patch netkit-ftp-0.17-C-Frame121.patch adds some
111    comments/hints for C-Frame 121. It can be removed any time.
112  * Tue Aug 30 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-28
113  - This 'hack' will avoid a bug in ftp-server
114    (  < vsftpd-2.0.1-5   ). See #165083 (server prints the
115    '150 FILE:...' line twice).
116    This patch can be (later ?) removed.
117  * Mon Aug 22 2005 Petr Raszyk <praszyk@redhat.com> - 0.17-27
118  - overflow using 'hash mode' (printing '#' but
119    not reading data from network - #79367)
120
121* Sat May 28 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-26vl1
122- added patches from Fedora
123  * Tue May 24 2005 Miloslav Trmac <mitr@redhat.com> - 0.17-26
124  - Fix passive mode with SELinux (#158234, patch by Nalin Dahyabhai)
125  - Fix format string mismatch
126  * Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
127  - Call setlocale() so that readline works correctly (bug #142265).
128  * Tue Dec  7 2004 Thomas Woerner <twoerner@redhat.com> 0.17-23
129  - fixed mget with runique (#79367)
130  * Mon Jun 14 2004 Alan Cox <alan@redhat.com>
131  - Re-arranged some totally bogus old bezerkly code that could
132    segfault ftp on connection loss. (BZ #122295)
133- added Japanese summary and description from spec translation project
134
135* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.17-15vl2
136- rebuild with readline-4.3
137
138* Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.17-15vl1
139- based on 0.17-15 from Rawhide and built for Vine Linux
140
141* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
142- automated rebuild
143
144* Thu May 23 2002 Tim Powers <timp@redhat.com>
145- automated rebuild
146
147* Fri Apr 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.17-13
148- Recompile with support for files > 2 GB
149
150* Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.17-12
151- Add some Build dependencies (#45007)
152
153* Fri May 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.17-11
154- Actually apply Patch #3
155
156* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.17-10
157- Rebuild with new readline
158
159* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
160- Add IPv6 patch (RFE #35642)
161
162* Wed Apr  4 2001 Jakub Jelinek <jakub@redhat.com>
163- don't let configure to guess compiler, it can pick up egcs
164
165* Sun Jan 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
166- Update to 0.17 final
167- Fix up ACCT support in netrc (Bug #17353)
168
169* Wed Aug 16 2000 Philipp Knirsch <pknirsch@redhat.com>
170- Switched the default transfer protocol from PORT to PASV as proposed on
171  bugzilla (#16134)
172- Fixed a small compiler warning in ftp.c line 886
173
174* Fri Jul 14 2000 Jeff Johnson <jbj@redhat.com>
175- add netrc man page (#7443).
176- fix possible buffer overflows in ftp client.
177
178* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
179- automatic rebuild
180
181* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
182- FHS packaging.
183- update to 0.17-pre20000412.
184
185* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
186- rebuild with current libreadline
187
188* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
189- 0.17
190
191* Fri Feb  4 2000 Bill Nottingham <notting@redhat.com>
192- handle compressed man pages
193
194* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
195- the ftp client does not require inetd
196
197* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
198- update to 0.16.
199
200* Mon Aug 30 1999 Jeff Johnson <jbj@redhat.com>
201- update to 0.15.
202- enable readline support (#3796).
203
204* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
205- auto rebuild in the new build environment (release 22)
206
207* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
208- compile for 6.0.
209
210* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
211- build root
212
213* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
214- translations modified for de, fr, tr
Note: See TracBrowser for help on using the repository browser.