source: projects/specs/trunk/f/ftgl/ftgl-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A font rendering library for OpenGL
2Summary(ja):    OpenGL 用のフォントレンダリングライブラリ
3Name:           ftgl
4Version:        2.1.2
5Release:        1%{?_dist_release}
6License:        LGPL
7Group:          System Environment/Libraries
8URL:            http://homepages.paradise.net.nz/henryj/code/index.html#FTGL
9Source:         http://opengl.geek.nz/ftgl/ftgl-%{version}.tar.bz2
10Patch0:         ftgl-2.0.11-pkgconfig.patch
11Patch1:         ftgl-2.1.2-gcc4.patch
12Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13BuildRequires:  freetype2-devel, mesa-libGL-devel, freeglut-devel
14BuildRequires:  pkgconfig
15BuildRequires:  doxygen
16Requires:       freetype2, mesa-libGL
17
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21%description
22FTGL is a free, open source library to enable developers to use arbitrary
23fonts in their OpenGL applications. Unlike other OpenGL font libraries
24FTGL uses standard font file formats so doesn't need a preprocessing step
25to convert the high quality font data into a lesser quality, proprietary
26format. FTGL uses the Freetype font library to open and 'decode' the fonts.
27It then takes that output and stores it in a format most efficient for
28OpenGL rendering.
29
30Rendering modes supported are:
31 * Bit maps
32 * Anti aliased pix maps
33 * Texture maps
34 * Outlines
35 * Polygon meshes
36 * Extruded polygon meshes
37
38%package devel
39Summary:        Development files for FTGL
40Summary(ja):    FTGL の開発用ファイル
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       freetype2-devel, mesa-libGL-devel
44Requires:       pkgconfig
45
46%description devel
47FTGL is a free, open source library to enable developers to use arbitrary
48fonts in their OpenGL applications. Unlike other OpenGL font libraries
49FTGL uses standard font file formats so doesn't need a preprocessing step
50to convert the high quality font data into a lesser quality, proprietary
51format. FTGL uses the Freetype font library to open and 'decode' the fonts.
52It then takes that output and stores it in a format most efficient for
53OpenGL rendering.
54
55This package contains the libraries and header files necessary to develop
56applications with FTGL.
57
58%prep
59%setup -q -n FTGL
60
61%patch0 -p1 -b .pkgconfig
62%patch1 -p1 -b .gcc
63
64%{_bindir}/find . -type f -name "*.txt" -exec %__chmod 0644 "{}" \;
65
66%build
67pushd unix
68%configure --enable-shared --disable-static
69%__make
70popd
71
72%install
73%__rm -rf %{buildroot}
74
75pushd unix
76%makeinstall
77popd
78
79# remove unneeded files
80%__rm -f %{buildroot}%{_bindir}/FTGLDemo
81%__rm -rf %{buildroot}%{_docdir}
82
83%post
84/sbin/ldconfig
85
86%postun
87/sbin/ldconfig
88
89%clean
90%__rm -rf %{buildroot}
91
92%files
93%defattr(-,root,root)
94%doc COPYING.txt HISTORY.txt README.txt license.txt
95%{_libdir}/lib*.so.*
96
97%files devel
98%doc unix/README.txt unix/docs/html
99%defattr(-,root,root)
100%{_includedir}/FTGL
101%{_libdir}/lib*.so
102%exclude %{_libdir}/lib*.la
103%{_libdir}/pkgconfig/*.pc
104
105%changelog
106* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.2-1vl5
107- applied new versioning policy, spec in utf-8
108- excluded lib*.la
109
110* Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.2-0vl1
111- initial build for Vine Linux
112
113* Fri Jan 26 2007 Götz Waschk <waschk@mandriva.org> 2.1.2-1mdv2007.0
114+ Revision: 113842
115- Import ftgl
116
117* Fri Jan 26 2007 Götz Waschk <waschk@mandriva.org> 2.1.2-1mdv2007.1
118- fix build
119- new version
120
121* Wed Aug 23 2006 Per Øyvind Karlsen <pkarlsen@mandriva.com> 2.0.11-5mdv2007.0
122- fix correct usage of %%mklibname
123
124* Tue Aug 22 2006 Per Øyvind Karlsen <pkarlsen@mandriva.com> 2.0.11-4mdv2007.0
125- rebuild for new xorg
126- %%mkrel
127
128* Sun Jan 08 2006 Mandriva Linux Team <http://www.mandrivaexpert.com/> 2.0.11-3mdk
129- Rebuild
130
131* Sun Nov 21 2004 Abel Cheung <deaddog@mandrake.org> 2.0.11-2mdk
132- Fix build (thx Stefan's bot)
133
134* Thu Nov 04 2004 Abel Cheung <deaddog@mandrake.org> 2.0.11-1mdk
135- First Mandrake package
136- Patch0: Patch .pc file to use freetype2.pc
Note: See TracBrowser for help on using the repository browser.