source: projects/specs/trunk/f/freetype2/freetype2-vl.spec @ 9196

Revision 9196, 16.3 KB checked in by kudoh, 9 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with subpixel_rendering
4%define ver_majar 2.5.4
5
6Summary: FreeType 2 library
7Summary(ja): FreeType 2 ライブラリ
8Name: freetype2
9Version: %{ver_majar}
10Release: 1%{?_dist_release}
11License: GPL/FTL dual license
12URL: http://www.freetype.org/
13Group: System Environment/Libraries
14
15Source: freetype-%{version}.tar.bz2
16Source1: freetype-doc-%{ver_majar}.tar.bz2
17Source2: ft2demos-%{ver_majar}.tar.bz2
18
19# enable subpixel rendering
20Patch21: freetype-2.3.0-enable-spr.patch
21# Enable otvalid and gxvalid modules
22Patch46:  freetype-2.2.1-enable-valid.patch
23# Fix multilib conflicts
24Patch88:  freetype-multilib.patch
25# Fix crash https://bugs.freedesktop.org/show_bug.cgi?id=6841
26Patch89:  freetype-2.2.1-memcpy-fix.patch
27Patch90:  freetype-2.5.4-pkgconfig.patch
28
29Patch200: freetype-2.1.10-slight-embolden.patch
30Patch201: freetype-2.4.12-x86_64-invalid_outline.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires: zlib-devel
35BuildRequires: bzip2-devel
36BuildRequires: libX11-devel
37BuildRequires: libpng-devel
38
39%description
40The FreeType project is a team of volunteers who develop free,
41portable and high-quality software solutions for digital typography.
42They specifically target embedded systems and focus on bringing small,
43efficient and ubiquitous products.
44
45The FreeType 2 library is their new software font engine. It has been
46designed to provide the following important features:
47 * A universal and simple API to manage font files
48 * Support for several font formats through loadable modules
49 * High-quality anti-aliasing
50 * High portability & performance
51
52Supported font formats include:
53 * TrueType files (.ttf) and collections (.ttc)
54 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
55 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
56   routines to manage design instances easily
57 * Type 1 CID-keyed fonts
58 * OpenType/CFF (.otf) fonts
59 * CFF/Type 2 fonts
60 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
61   the Adobe SVG viewer plugin.
62 * Windows FNT/FON bitmap fonts
63
64This package contains the files needed to run programs that use the
65FreeType 2 library.
66
67
68%package demos
69Summary: A collection of FreeType demos
70Group: System Environment/Libraries
71Requires: %{name} = %{version}-%{release}
72Obsoletes: freetype-utils < 2.0
73Provides: freetype-utils = %{version}
74
75%description demos
76A collection of FreeType demos.
77
78
79%package -n compat32-%{name}
80Summary: FreeType 2 library
81Summary(ja): FreeType 2 ライブラリ
82Group: System Environment/Libraries
83Requires:       %{name} = %{version}-%{release}
84
85
86%description -n compat32-%{name}
87The FreeType project is a team of volunteers who develop free,
88portable and high-quality software solutions for digital typography.
89They specifically target embedded systems and focus on bringing small,
90efficient and ubiquitous products.
91
92The FreeType 2 library is their new software font engine. It has been
93designed to provide the following important features:
94 * A universal and simple API to manage font files
95 * Support for several font formats through loadable modules
96 * High-quality anti-aliasing
97 * High portability & performance
98
99Supported font formats include:
100 * TrueType files (.ttf) and collections (.ttc)
101 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
102 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
103   routines to manage design instances easily
104 * Type 1 CID-keyed fonts
105 * OpenType/CFF (.otf) fonts
106 * CFF/Type 2 fonts
107 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
108   the Adobe SVG viewer plugin.
109 * Windows FNT/FON bitmap fonts
110
111This package contains the files needed to run programs that use the
112FreeType 2 library.
113
114
115%package devel
116Summary:        Development files for FreeType 2 library
117Summary(ja):    FreeType 2 ライブラリの開発ファイル
118Group:          Development/Libraries
119Requires:       %{name} = %{version}-%{release}
120Requires:       zlib-devel
121Requires:       bzip2-devel
122Requires:       libpng-devel
123
124
125%description devel
126The FreeType project is a team of volunteers who develop free,
127portable and high-quality software solutions for digital typography.
128They specifically target embedded systems and focus on bringing small,
129efficient and ubiquitous products.
130
131The FreeType 2 library is their new software font engine. It has been
132designed to provide the following important features:
133 * A universal and simple API to manage font files
134 * Support for several font formats through loadable modules
135 * High-quality anti-aliasing
136 * High portability & performance
137
138Supported font formats include:
139 * TrueType files (.ttf) and collections (.ttc)
140 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
141 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
142   routines to manage design instances easily
143 * Type 1 CID-keyed fonts
144 * OpenType/CFF (.otf) fonts
145 * CFF/Type 2 fonts
146 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
147   the Adobe SVG viewer plugin.
148 * Windows FNT/FON bitmap fonts
149
150This package contains all supplementary files (static library, headers
151and documentation) you need to develop your own programs using the
152FreeType 2 library.
153
154
155%package -n compat32-%{name}-devel
156Summary:        FreeType 2 library
157Summary(ja):    FreeType 2 ライブラリ
158Group:          Development/Libraries
159Requires:       compat32-%{name} = %{version}-%{release}
160Requires:       %{name}-devel    = %{version}-%{release}
161Requires:       compat32-zlib-devel
162Requires:       compat32-bzip2-devel
163
164%description -n compat32-%{name}-devel
165The FreeType project is a team of volunteers who develop free,
166portable and high-quality software solutions for digital typography.
167They specifically target embedded systems and focus on bringing small,
168efficient and ubiquitous products.
169
170The FreeType 2 library is their new software font engine. It has been
171designed to provide the following important features:
172 * A universal and simple API to manage font files
173 * Support for several font formats through loadable modules
174 * High-quality anti-aliasing
175 * High portability & performance
176
177Supported font formats include:
178 * TrueType files (.ttf) and collections (.ttc)
179 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
180 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
181   routines to manage design instances easily
182 * Type 1 CID-keyed fonts
183 * OpenType/CFF (.otf) fonts
184 * CFF/Type 2 fonts
185 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
186   the Adobe SVG viewer plugin.
187 * Windows FNT/FON bitmap fonts
188
189This package contains all supplementary files (static library, headers
190and documentation) you need to develop your own programs using the
191FreeType 2 library.
192
193%package static
194Summary:        Static ilbrary for FreeType 2
195Summary(ja):    FreeType 2 のスタティックライブラリ
196Group:          Development/Libraries
197Requires:       %{name}-devel = %{version}-%{release}
198
199%description static
200This package contains the static library for %{name}
201
202%prep
203%setup -q -n freetype-%{version} -b 1 -a 2
204
205%if %{with subpixel_rendering}
206%patch21 -p1 -b .enable-spr
207%endif
208
209%patch46 -p1 -b .enable-valid
210%patch88 -p1 -b .multilib
211%patch89 -p1 -b .memcpy
212%patch90 -p1 -b .pkgconfig
213
214%patch200 -p1 -b .slight-embolden
215
216%ifarch x86_64
217%patch201 -p1 -b .invalid_outline
218%endif
219
220%build
221%configure
222%__make %{?_smp_mflags}
223
224# Build demos
225pushd ft2demos-%{ver_majar}
226make TOP_DIR=".."
227popd
228
229
230%install
231[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
232
233%makeinstall gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
234
235for ftdemo in ftbench ftdump ftlint ftvalid ftdiff ftgamma ftgrid ftmulti ftstring ftview
236do
237  builds/unix/libtool --mode=install install -m 755 ft2demos-%{ver_majar}/bin/$ftdemo $RPM_BUILD_ROOT/%{_bindir}
238done
239
240## remove unuse files
241rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
242
243
244%clean
245[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
246
247
248%post -p /sbin/ldconfig
249
250%postun -p /sbin/ldconfig
251
252%post -n compat32-%{name} -p /sbin/ldconfig
253
254%postun -n compat32-%{name} -p /sbin/ldconfig
255
256%files
257%defattr(-, root, root)
258%{_libdir}/*.so*
259%doc docs
260
261%files devel
262%defattr(-, root, root)
263%{_bindir}/freetype-config
264%{_libdir}/*.so
265%{_libdir}/pkgconfig/*.pc
266%{_includedir}/%{name}
267%{_datadir}/aclocal/freetype2.m4
268%{_mandir}/man1/*
269
270%files static
271%defattr(-, root, root)
272%{_libdir}/*.a
273
274%files demos
275%defattr(-,root,root)
276%{_bindir}/ftbench
277%{_bindir}/ftdump
278%{_bindir}/ftlint
279%{_bindir}/ftvalid
280%{_bindir}/ftdiff
281%{_bindir}/ftgamma
282%{_bindir}/ftgrid
283%{_bindir}/ftmulti
284%{_bindir}/ftstring
285%{_bindir}/ftview
286
287%if %{build_compat32}
288%files -n compat32-%{name}
289%defattr(-, root, root)
290%{_libdir}/*.so*
291
292%files -n compat32-%{name}-devel
293%defattr(-, root, root)
294%{_libdir}/*.so
295%endif
296
297%changelog
298* Sun Dec 28 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.4-1
299- new upstream release
300- remade Patch90
301
302* Fri Jun 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.3-2
303- rebuilt with libpng-1.6.
304
305* Sun Apr 20 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.3-1
306- new upstream release
307- remade Patch90
308
309* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-5
310- add Requires: libpng-devel in %%{name}-devel
311
312* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
313- fix Patch90
314- fix %%files -n compat32-%%{name}-devel (remove pkgconfig files)
315
316* Tue Dec 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-3
317- re-fixed invalid infomation in freetype-config
318
319* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-2
320- fixed invalid infomation in freetype-config (BTS:2711)
321
322* Sat Dec 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-1
323- new upstream release
324
325* Mon Aug 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.0.1-1
326- new upstream release
327- added BuildRequires: libpng-devel
328
329* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-2
330- fixed Patch88
331- added Pacth90 to fix BTS:2631
332
333* Sun May 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-1
334- new upstream release
335- refreshed Patch88, 201
336
337* Sat Dec 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.11-1
338- new upstream release
339
340* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.10-1
341- new upstream release
342- updated Patch201
343
344* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.8-1
345- new upstream release
346- add BuildRequires: bzip2-devel
347- add Requires: bzip2-devel (-devel package)
348
349* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-1
350- new upstream release
351
352* Fri Dec 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-1
353- new upstream release
354
355* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.4.2-2
356- build with rpm-4.8.1-1 for pkg-config file
357
358* Mon Aug 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
359- new upstream release
360
361* Tue Jul 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
362- new upstream release
363
364* Thu Jul 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
365- new upstream release
366
367* Sun May 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-2
368- enable bytecode interpreter, the patent is now expired.
369
370* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-1
371- new upstream release
372
373* Tue Oct 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.11-1
374- new upstream release
375- update patch201
376
377* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-6
378- rebuild with gpg signing
379
380* Wed Jul 29 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-5
381- fixed "Invalid Outline" error on x86_64.
382
383* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.9-4
384- removed %%if !%%{build_compat32} case condition
385- removed CC='gcc -m32' before make setup
386
387* Sun Apr 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-3
388- enable Patch200 again
389
390* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-2
391- split static library to freetype2-static
392  - needed by tuxonice-userui
393- disable Patch200
394
395* Sat Mar 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-1
396- new upstream release
397
398* Wed Jan 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-1
399- new upstream release
400
401* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.7-2
402- removed *.la
403
404* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-1
405- new upstream release
406
407* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-1
408- new upstream release
409
410* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-3
411- add Provides: freetype-utils = %%{version} to freetype2-demos
412
413* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-2
414- remove %%{_bindir}/* from -devel
415
416* Fri Mar 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-1
417- new upstream release
418- add freetype2-demos
419  - Obsoletes: freetype-utils
420
421* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.4-0vl2
422- add Patch201 (CVE-2007-2754)
423
424* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-0vl1
425- new upstream release
426
427* Thu Aug 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.10-0vl8
428- add Requires: zlib-devel (devel package)
429- compat32
430  - add BuildRequires: compat32-zlib-devel
431  - add Requires: compat32-zlib-devel (devel package)
432
433* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl7
434- add Patch200 to adjust synthetic-embold font weight.
435  - default value is too heavy...
436
437* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl6
438- add Patch100 for autofit-cjk
439
440* Fri Feb 24 2006 Shu KONNO <owa@bg.wakwak.com> 2.1.10-0vl5
441- added --libdir=%%{_libdir} to make setup
442- added CC='gcc -m32' before make setup if compat32
443
444* Sun Feb 12 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.1.10-0vl4
445- added compat32-* packages for x86_64 architecture support
446
447* Thu Oct 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl3
448- add upstream patches (from MDK)
449  - add Patch13 to fix memleak
450  - add Patch14 to put back internal API, used by XOrg
451  - add Patch15 to fix bad anti-aliasing
452
453* Sat Oct 01 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl2
454- add upstream patches (from MDK)
455  - add Patch10 to add fixes from CVS
456  - add Patch11 to fix autofit render setup
457  - add Patch12 to fix kerning
458- add Patch20 (enable bytecode interpreter), but not applied by default
459
460* Tue Sep  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.10-0vl1
461- new upstream release
462- drop Patch1 (auto-hinter has been replaced with a new module)
463- drop Patch2 (included in freetype-2.1.8)
464- add pkgconfig file
465
466* Fri Apr 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl4
467- add xtt2-1.2a related patch which is merged in CVS.
468  (http://x-tt.sourceforge.jp/index_nippon.html)
469
470* Thu Apr 01 2004 Tomoya TAKA <taka@vinelinux.org> 2.1.7-0vl3
471- add a fix from Fedora freetype-2.1.7-3
472  * Wed Mar 10 2004 Mike A. Harris <mharris@redhat.com> 2.1.7-3
473  - Added -fno-strict-aliasing to CFLAGS and CXXFLAGS to try to fix SEGV and
474    SIGILL crashes in mkfontscale which have been traced into freetype and seem
475    to be caused by aliasing issues in freetype macros
476
477* Wed Dec 10 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.7-0vl2
478- update patch1
479
480* Sun Nov 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
481- new upstream release
482
483* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl2
484- rebuild for VineSeed
485
486* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
487- source upgrade
488- add Patch1 from http://www.kde.gr.jp/~akito/
489- remove Source1
490- remove Patch0 (no need to 2.1.5)
491
492* Wed Aug 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
493- correct License tag from GPL to GPL/FTL dual license
494  - FTL: The FreeType Project License
495
496* Wed Apr  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.4-0vl1
497- source upgrade
498
499* Sat Dec  7 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
500- source and patch upgrade
501
502* Thu Dec  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl3
503- rebuild with new toolchain
504
505* Wed Aug 21 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
506- add Patch0 to fix problem to Dyna-Font
507
508* Tue Jul 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl1
509- source upgrade
510- add %{_datadir}/aclocal/freetype2.m4 to -devel
511
512* Mon Jan 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.6-0vl2
513- modified %%build section
514
515* Wed Jan 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.6-0vl1
516- source update
517- add ftdocs
518
519* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.1-0vl5
520- small build fix
521
522* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl4
523- Added Requires for -devel
524- Fixed config path
525
526* Mon Apr 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.1-0vl3
527- add %{_bindir} in devel package's %file section.
528
529* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl2
530- Added %defattr.
531
532* Sun Dec 17 2000 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl1
533- Initial revision.
534
Note: See TracBrowser for help on using the repository browser.