source: projects/specs/trunk/f/freetype2/freetype2-vl.spec @ 521

Revision 521, 14.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define enable_bytecode_interpreter 0
2%define enable_subpixel_rendering 0
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Summary: FreeType 2 library
6Summary(ja): FreeType 2 ライブラリ
7Name: freetype2
8Version: 2.3.12
9Release: 1%{?_dist_release}
10License: GPL/FTL dual license
11URL: http://www.freetype.org/
12Group: System Environment/Libraries
13
14Source: freetype-%{version}.tar.bz2
15Source1: freetype-doc-%{version}.tar.bz2
16Source2: ft2demos-%{version}.tar.bz2
17
18# enable bytecode interpreter
19Patch20: freetype-2.1.10-enable-bci.patch
20# enable subpixel rendering
21Patch21: freetype-2.3.0-enable-spr.patch
22# Enable otvalid and gxvalid modules
23Patch46:  freetype-2.2.1-enable-valid.patch
24# Fix multilib conflicts
25Patch88:  freetype-multilib.patch
26# Fix crash https://bugs.freedesktop.org/show_bug.cgi?id=6841
27Patch89:  freetype-2.2.1-memcpy-fix.patch
28
29Patch200: freetype-2.1.10-slight-embolden.patch
30Patch201: freetype-2.3.11-x86_64-invalid_outline.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires: zlib-devel
35BuildRequires: libX11-devel
36Requires: zlib
37
38%description
39The FreeType project is a team of volunteers who develop free,
40portable and high-quality software solutions for digital typography.
41They specifically target embedded systems and focus on bringing small,
42efficient and ubiquitous products.
43
44The FreeType 2 library is their new software font engine. It has been
45designed to provide the following important features:
46 * A universal and simple API to manage font files
47 * Support for several font formats through loadable modules
48 * High-quality anti-aliasing
49 * High portability & performance
50
51Supported font formats include:
52 * TrueType files (.ttf) and collections (.ttc)
53 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
54 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
55   routines to manage design instances easily
56 * Type 1 CID-keyed fonts
57 * OpenType/CFF (.otf) fonts
58 * CFF/Type 2 fonts
59 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
60   the Adobe SVG viewer plugin.
61 * Windows FNT/FON bitmap fonts
62
63This package contains the files needed to run programs that use the
64FreeType 2 library.
65
66
67%package demos
68Summary: A collection of FreeType demos
69Group: System Environment/Libraries
70Requires: %{name} = %{version}-%{release}
71Obsoletes: freetype-utils < 2.0
72Provides: freetype-utils = %{version}
73
74%description demos
75A collection of FreeType demos.
76
77
78%package -n compat32-%{name}
79Summary: FreeType 2 library
80Summary(ja): FreeType 2 ライブラリ
81Group: System Environment/Libraries
82Requires:       %{name} = %{version}-%{release}
83
84
85%description -n compat32-%{name}
86The FreeType project is a team of volunteers who develop free,
87portable and high-quality software solutions for digital typography.
88They specifically target embedded systems and focus on bringing small,
89efficient and ubiquitous products.
90
91The FreeType 2 library is their new software font engine. It has been
92designed to provide the following important features:
93 * A universal and simple API to manage font files
94 * Support for several font formats through loadable modules
95 * High-quality anti-aliasing
96 * High portability & performance
97
98Supported font formats include:
99 * TrueType files (.ttf) and collections (.ttc)
100 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
101 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
102   routines to manage design instances easily
103 * Type 1 CID-keyed fonts
104 * OpenType/CFF (.otf) fonts
105 * CFF/Type 2 fonts
106 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
107   the Adobe SVG viewer plugin.
108 * Windows FNT/FON bitmap fonts
109
110This package contains the files needed to run programs that use the
111FreeType 2 library.
112
113
114%package devel
115Summary:        Development files for FreeType 2 library
116Summary(ja):    FreeType 2 ライブラリの開発ファイル
117Group:          Development/Libraries
118Requires:       %{name} = %{version}-%{release}
119Requires:       zlib-devel
120
121
122%description devel
123The FreeType project is a team of volunteers who develop free,
124portable and high-quality software solutions for digital typography.
125They specifically target embedded systems and focus on bringing small,
126efficient and ubiquitous products.
127
128The FreeType 2 library is their new software font engine. It has been
129designed to provide the following important features:
130 * A universal and simple API to manage font files
131 * Support for several font formats through loadable modules
132 * High-quality anti-aliasing
133 * High portability & performance
134
135Supported font formats include:
136 * TrueType files (.ttf) and collections (.ttc)
137 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
138 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
139   routines to manage design instances easily
140 * Type 1 CID-keyed fonts
141 * OpenType/CFF (.otf) fonts
142 * CFF/Type 2 fonts
143 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
144   the Adobe SVG viewer plugin.
145 * Windows FNT/FON bitmap fonts
146
147This package contains all supplementary files (static library, headers
148and documentation) you need to develop your own programs using the
149FreeType 2 library.
150
151
152%package -n compat32-%{name}-devel
153Summary:        FreeType 2 library
154Summary(ja):    FreeType 2 ライブラリ
155Group:          Development/Libraries
156Requires:       compat32-%{name} = %{version}-%{release}
157Requires:       %{name}-devel    = %{version}-%{release}
158Requires:       compat32-zlib-devel
159
160%description -n compat32-%{name}-devel
161The FreeType project is a team of volunteers who develop free,
162portable and high-quality software solutions for digital typography.
163They specifically target embedded systems and focus on bringing small,
164efficient and ubiquitous products.
165
166The FreeType 2 library is their new software font engine. It has been
167designed to provide the following important features:
168 * A universal and simple API to manage font files
169 * Support for several font formats through loadable modules
170 * High-quality anti-aliasing
171 * High portability & performance
172
173Supported font formats include:
174 * TrueType files (.ttf) and collections (.ttc)
175 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
176 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
177   routines to manage design instances easily
178 * Type 1 CID-keyed fonts
179 * OpenType/CFF (.otf) fonts
180 * CFF/Type 2 fonts
181 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
182   the Adobe SVG viewer plugin.
183 * Windows FNT/FON bitmap fonts
184
185This package contains all supplementary files (static library, headers
186and documentation) you need to develop your own programs using the
187FreeType 2 library.
188
189%package static
190Summary:        Static ilbrary for FreeType 2
191Summary(ja):    FreeType 2 のスタティックライブラリ
192Group:          Development/Libraries
193Requires:       %{name}-devel = %{version}-%{release}
194
195%description static
196This package contains the static library for %{name}
197
198%prep
199%setup -q -n freetype-%{version} -b 1 -a 2
200%if %{enable_bytecode_interpreter}
201%patch20 -p1 -b .enable-bci
202%endif
203%if %{enable_subpixel_rendering}
204%patch21 -p1 -b .enable-spr
205%endif
206
207%patch46 -p1 -b .enable-valid
208%patch88 -p1 -b .multilib
209%patch89 -p1 -b .memcpy
210
211%patch200 -p1 -b .slight-embolden
212
213%ifarch x86_64
214%patch201 -p1 -b .invalid_outline
215%endif
216
217%build
218%configure
219%__make %{?_smp_mflags}
220
221# Build demos
222pushd ft2demos-%{version}
223make TOP_DIR=".."
224popd
225
226
227%install
228[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
229
230%makeinstall gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
231
232for ftdemo in ftbench ftdump ftlint ftvalid ftdiff ftgamma ftgrid ftmulti ftstring ftview
233do
234  builds/unix/libtool --mode=install install -m 755 ft2demos-%{version}/bin/$ftdemo $RPM_BUILD_ROOT/%{_bindir}
235done
236
237## remove unuse files
238rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
239
240
241%clean
242[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
243
244
245%post -p /sbin/ldconfig
246
247%postun -p /sbin/ldconfig
248
249%post -n compat32-%{name} -p /sbin/ldconfig
250
251%postun -n compat32-%{name} -p /sbin/ldconfig
252
253%files
254%defattr(-, root, root)
255%{_libdir}/*.so*
256%doc docs
257
258%files devel
259%defattr(-, root, root)
260%{_bindir}/freetype-config
261%{_libdir}/*.so
262%{_libdir}/pkgconfig/*.pc
263%{_includedir}/*
264%{_datadir}/aclocal/freetype2.m4
265
266%files static
267%defattr(-, root, root)
268%{_libdir}/*.a
269
270%files demos
271%defattr(-,root,root)
272%{_bindir}/ftbench
273%{_bindir}/ftdump
274%{_bindir}/ftlint
275%{_bindir}/ftvalid
276%{_bindir}/ftdiff
277%{_bindir}/ftgamma
278%{_bindir}/ftgrid
279%{_bindir}/ftmulti
280%{_bindir}/ftstring
281%{_bindir}/ftview
282
283%if %{build_compat32}
284%files -n compat32-%{name}
285%defattr(-, root, root)
286%{_libdir}/*.so*
287
288%files -n compat32-%{name}-devel
289%defattr(-, root, root)
290%{_libdir}/*.so
291%{_libdir}/pkgconfig/*.pc
292%endif
293
294%changelog
295* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-1
296- new upstream release
297
298* Tue Oct 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.11-1
299- new upstream release
300- update patch201
301
302* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-6
303- rebuild with gpg signing
304
305* Wed Jul 29 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-5
306- fixed "Invalid Outline" error on x86_64.
307
308* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.9-4
309- removed %%if !%%{build_compat32} case condition
310- removed CC='gcc -m32' before make setup
311
312* Sun Apr 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-3
313- enable Patch200 again
314
315* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-2
316- split static library to freetype2-static
317  - needed by tuxonice-userui
318- disable Patch200
319
320* Sat Mar 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-1
321- new upstream release
322
323* Wed Jan 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-1
324- new upstream release
325
326* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.7-2
327- removed *.la
328
329* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-1
330- new upstream release
331
332* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-1
333- new upstream release
334
335* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-3
336- add Provides: freetype-utils = %%{version} to freetype2-demos
337
338* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-2
339- remove %%{_bindir}/* from -devel
340
341* Fri Mar 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-1
342- new upstream release
343- add freetype2-demos
344  - Obsoletes: freetype-utils
345
346* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.4-0vl2
347- add Patch201 (CVE-2007-2754)
348
349* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-0vl1
350- new upstream release
351
352* Thu Aug 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.10-0vl8
353- add Requires: zlib-devel (devel package)
354- compat32
355  - add BuildRequires: compat32-zlib-devel
356  - add Requires: compat32-zlib-devel (devel package)
357
358* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl7
359- add Patch200 to adjust synthetic-embold font weight.
360  - default value is too heavy...
361
362* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl6
363- add Patch100 for autofit-cjk
364
365* Fri Feb 24 2006 Shu KONNO <owa@bg.wakwak.com> 2.1.10-0vl5
366- added --libdir=%%{_libdir} to make setup
367- added CC='gcc -m32' before make setup if compat32
368
369* Sun Feb 12 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.1.10-0vl4
370- added compat32-* packages for x86_64 architecture support
371
372* Thu Oct 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl3
373- add upstream patches (from MDK)
374  - add Patch13 to fix memleak
375  - add Patch14 to put back internal API, used by XOrg
376  - add Patch15 to fix bad anti-aliasing
377
378* Sat Oct 01 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl2
379- add upstream patches (from MDK)
380  - add Patch10 to add fixes from CVS
381  - add Patch11 to fix autofit render setup
382  - add Patch12 to fix kerning
383- add Patch20 (enable bytecode interpreter), but not applied by default
384
385* Tue Sep  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.10-0vl1
386- new upstream release
387- drop Patch1 (auto-hinter has been replaced with a new module)
388- drop Patch2 (included in freetype-2.1.8)
389- add pkgconfig file
390
391* Fri Apr 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl4
392- add xtt2-1.2a related patch which is merged in CVS.
393  (http://x-tt.sourceforge.jp/index_nippon.html)
394
395* Thu Apr 01 2004 Tomoya TAKA <taka@vinelinux.org> 2.1.7-0vl3
396- add a fix from Fedora freetype-2.1.7-3
397  * Wed Mar 10 2004 Mike A. Harris <mharris@redhat.com> 2.1.7-3
398  - Added -fno-strict-aliasing to CFLAGS and CXXFLAGS to try to fix SEGV and
399    SIGILL crashes in mkfontscale which have been traced into freetype and seem
400    to be caused by aliasing issues in freetype macros
401
402* Wed Dec 10 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.7-0vl2
403- update patch1
404
405* Sun Nov 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
406- new upstream release
407
408* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl2
409- rebuild for VineSeed
410
411* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
412- source upgrade
413- add Patch1 from http://www.kde.gr.jp/~akito/
414- remove Source1
415- remove Patch0 (no need to 2.1.5)
416
417* Wed Aug 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
418- correct License tag from GPL to GPL/FTL dual license
419  - FTL: The FreeType Project License
420
421* Wed Apr  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.4-0vl1
422- source upgrade
423
424* Sat Dec  7 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
425- source and patch upgrade
426
427* Thu Dec  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl3
428- rebuild with new toolchain
429
430* Wed Aug 21 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
431- add Patch0 to fix problem to Dyna-Font
432
433* Mon Jul 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl1
434- source upgrade
435- add %{_datadir}/aclocal/freetype2.m4 to -devel
436
437* Mon Jan 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.6-0vl2
438- modified %%build section
439
440* Wed Jan 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.6-0vl1
441- source update
442- add ftdocs
443
444* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.1-0vl5
445- small build fix
446
447* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl4
448- Added Requires for -devel
449- Fixed config path
450
451* Mon Apr 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.1-0vl3
452- add %{_bindir} in devel package's %file section.
453
454* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl2
455- Added %defattr.
456
457* Sun Dec 17 2000 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl1
458- Initial revision.
459
Note: See TracBrowser for help on using the repository browser.