source: projects/specs/trunk/f/freetype2/freetype2-vl.spec @ 8370

Revision 8370, 16.2 KB checked in by kudoh, 10 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with subpixel_rendering
4%define ver_majar 2.5.3
5
6Summary: FreeType 2 library
7Summary(ja): FreeType 2 ライブラリ
8Name: freetype2
9Version: %{ver_majar}
10Release: 1%{?_dist_release}
11License: GPL/FTL dual license
12URL: http://www.freetype.org/
13Group: System Environment/Libraries
14
15Source: freetype-%{version}.tar.bz2
16Source1: freetype-doc-%{ver_majar}.tar.bz2
17Source2: ft2demos-%{ver_majar}.tar.bz2
18
19# enable subpixel rendering
20Patch21: freetype-2.3.0-enable-spr.patch
21# Enable otvalid and gxvalid modules
22Patch46:  freetype-2.2.1-enable-valid.patch
23# Fix multilib conflicts
24Patch88:  freetype-multilib.patch
25# Fix crash https://bugs.freedesktop.org/show_bug.cgi?id=6841
26Patch89:  freetype-2.2.1-memcpy-fix.patch
27Patch90:  freetype-2.5.3-pkgconfig.patch
28
29Patch200: freetype-2.1.10-slight-embolden.patch
30Patch201: freetype-2.4.12-x86_64-invalid_outline.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires: zlib-devel
35BuildRequires: bzip2-devel
36BuildRequires: libX11-devel
37BuildRequires: libpng-devel
38Requires: zlib
39Requires: bzip2
40Requires: libpng
41
42%description
43The FreeType project is a team of volunteers who develop free,
44portable and high-quality software solutions for digital typography.
45They specifically target embedded systems and focus on bringing small,
46efficient and ubiquitous products.
47
48The FreeType 2 library is their new software font engine. It has been
49designed to provide the following important features:
50 * A universal and simple API to manage font files
51 * Support for several font formats through loadable modules
52 * High-quality anti-aliasing
53 * High portability & performance
54
55Supported font formats include:
56 * TrueType files (.ttf) and collections (.ttc)
57 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
58 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
59   routines to manage design instances easily
60 * Type 1 CID-keyed fonts
61 * OpenType/CFF (.otf) fonts
62 * CFF/Type 2 fonts
63 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
64   the Adobe SVG viewer plugin.
65 * Windows FNT/FON bitmap fonts
66
67This package contains the files needed to run programs that use the
68FreeType 2 library.
69
70
71%package demos
72Summary: A collection of FreeType demos
73Group: System Environment/Libraries
74Requires: %{name} = %{version}-%{release}
75Obsoletes: freetype-utils < 2.0
76Provides: freetype-utils = %{version}
77
78%description demos
79A collection of FreeType demos.
80
81
82%package -n compat32-%{name}
83Summary: FreeType 2 library
84Summary(ja): FreeType 2 ライブラリ
85Group: System Environment/Libraries
86Requires:       %{name} = %{version}-%{release}
87
88
89%description -n compat32-%{name}
90The FreeType project is a team of volunteers who develop free,
91portable and high-quality software solutions for digital typography.
92They specifically target embedded systems and focus on bringing small,
93efficient and ubiquitous products.
94
95The FreeType 2 library is their new software font engine. It has been
96designed to provide the following important features:
97 * A universal and simple API to manage font files
98 * Support for several font formats through loadable modules
99 * High-quality anti-aliasing
100 * High portability & performance
101
102Supported font formats include:
103 * TrueType files (.ttf) and collections (.ttc)
104 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
105 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
106   routines to manage design instances easily
107 * Type 1 CID-keyed fonts
108 * OpenType/CFF (.otf) fonts
109 * CFF/Type 2 fonts
110 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
111   the Adobe SVG viewer plugin.
112 * Windows FNT/FON bitmap fonts
113
114This package contains the files needed to run programs that use the
115FreeType 2 library.
116
117
118%package devel
119Summary:        Development files for FreeType 2 library
120Summary(ja):    FreeType 2 ライブラリの開発ファイル
121Group:          Development/Libraries
122Requires:       %{name} = %{version}-%{release}
123Requires:       zlib-devel
124Requires:       bzip2-devel
125Requires:       libpng-devel
126
127
128%description devel
129The FreeType project is a team of volunteers who develop free,
130portable and high-quality software solutions for digital typography.
131They specifically target embedded systems and focus on bringing small,
132efficient and ubiquitous products.
133
134The FreeType 2 library is their new software font engine. It has been
135designed to provide the following important features:
136 * A universal and simple API to manage font files
137 * Support for several font formats through loadable modules
138 * High-quality anti-aliasing
139 * High portability & performance
140
141Supported font formats include:
142 * TrueType files (.ttf) and collections (.ttc)
143 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
144 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
145   routines to manage design instances easily
146 * Type 1 CID-keyed fonts
147 * OpenType/CFF (.otf) fonts
148 * CFF/Type 2 fonts
149 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
150   the Adobe SVG viewer plugin.
151 * Windows FNT/FON bitmap fonts
152
153This package contains all supplementary files (static library, headers
154and documentation) you need to develop your own programs using the
155FreeType 2 library.
156
157
158%package -n compat32-%{name}-devel
159Summary:        FreeType 2 library
160Summary(ja):    FreeType 2 ライブラリ
161Group:          Development/Libraries
162Requires:       compat32-%{name} = %{version}-%{release}
163Requires:       %{name}-devel    = %{version}-%{release}
164Requires:       compat32-zlib-devel
165Requires:       compat32-bzip2-devel
166
167%description -n compat32-%{name}-devel
168The FreeType project is a team of volunteers who develop free,
169portable and high-quality software solutions for digital typography.
170They specifically target embedded systems and focus on bringing small,
171efficient and ubiquitous products.
172
173The FreeType 2 library is their new software font engine. It has been
174designed to provide the following important features:
175 * A universal and simple API to manage font files
176 * Support for several font formats through loadable modules
177 * High-quality anti-aliasing
178 * High portability & performance
179
180Supported font formats include:
181 * TrueType files (.ttf) and collections (.ttc)
182 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
183 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
184   routines to manage design instances easily
185 * Type 1 CID-keyed fonts
186 * OpenType/CFF (.otf) fonts
187 * CFF/Type 2 fonts
188 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
189   the Adobe SVG viewer plugin.
190 * Windows FNT/FON bitmap fonts
191
192This package contains all supplementary files (static library, headers
193and documentation) you need to develop your own programs using the
194FreeType 2 library.
195
196%package static
197Summary:        Static ilbrary for FreeType 2
198Summary(ja):    FreeType 2 のスタティックライブラリ
199Group:          Development/Libraries
200Requires:       %{name}-devel = %{version}-%{release}
201
202%description static
203This package contains the static library for %{name}
204
205%prep
206%setup -q -n freetype-%{version} -b 1 -a 2
207
208%if %{with subpixel_rendering}
209%patch21 -p1 -b .enable-spr
210%endif
211
212%patch46 -p1 -b .enable-valid
213%patch88 -p1 -b .multilib
214%patch89 -p1 -b .memcpy
215%patch90 -p1 -b .pkgconfig
216
217%patch200 -p1 -b .slight-embolden
218
219%ifarch x86_64
220%patch201 -p1 -b .invalid_outline
221%endif
222
223%build
224%configure
225%__make %{?_smp_mflags}
226
227# Build demos
228pushd ft2demos-%{ver_majar}
229make TOP_DIR=".."
230popd
231
232
233%install
234[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
235
236%makeinstall gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
237
238for ftdemo in ftbench ftdump ftlint ftvalid ftdiff ftgamma ftgrid ftmulti ftstring ftview
239do
240  builds/unix/libtool --mode=install install -m 755 ft2demos-%{ver_majar}/bin/$ftdemo $RPM_BUILD_ROOT/%{_bindir}
241done
242
243## remove unuse files
244rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
245
246
247%clean
248[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
249
250
251%post -p /sbin/ldconfig
252
253%postun -p /sbin/ldconfig
254
255%post -n compat32-%{name} -p /sbin/ldconfig
256
257%postun -n compat32-%{name} -p /sbin/ldconfig
258
259%files
260%defattr(-, root, root)
261%{_libdir}/*.so*
262%doc docs
263
264%files devel
265%defattr(-, root, root)
266%{_bindir}/freetype-config
267%{_libdir}/*.so
268%{_libdir}/pkgconfig/*.pc
269%{_includedir}/%{name}
270%{_datadir}/aclocal/freetype2.m4
271%{_mandir}/man1/*
272
273%files static
274%defattr(-, root, root)
275%{_libdir}/*.a
276
277%files demos
278%defattr(-,root,root)
279%{_bindir}/ftbench
280%{_bindir}/ftdump
281%{_bindir}/ftlint
282%{_bindir}/ftvalid
283%{_bindir}/ftdiff
284%{_bindir}/ftgamma
285%{_bindir}/ftgrid
286%{_bindir}/ftmulti
287%{_bindir}/ftstring
288%{_bindir}/ftview
289
290%if %{build_compat32}
291%files -n compat32-%{name}
292%defattr(-, root, root)
293%{_libdir}/*.so*
294
295%files -n compat32-%{name}-devel
296%defattr(-, root, root)
297%{_libdir}/*.so
298%endif
299
300%changelog
301* Sun Apr 20 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.3-1
302- new upstream release
303- remade Patch90
304
305* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-5
306- add Requires: libpng-devel in %%{name}-devel
307
308* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
309- fix Patch90
310- fix %%files -n compat32-%%{name}-devel (remove pkgconfig files)
311
312* Tue Dec 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-3
313- re-fixed invalid infomation in freetype-config
314
315* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-2
316- fixed invalid infomation in freetype-config (BTS:2711)
317
318* Sat Dec 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-1
319- new upstream release
320
321* Mon Aug 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.0.1-1
322- new upstream release
323- added BuildRequires: libpng-devel
324
325* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-2
326- fixed Patch88
327- added Pacth90 to fix BTS:2631
328
329* Sun May 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-1
330- new upstream release
331- refreshed Patch88, 201
332
333* Sat Dec 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.11-1
334- new upstream release
335
336* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.10-1
337- new upstream release
338- updated Patch201
339
340* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.8-1
341- new upstream release
342- add BuildRequires: bzip2-devel
343- add Requires: bzip2-devel (-devel package)
344
345* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-1
346- new upstream release
347
348* Fri Dec 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-1
349- new upstream release
350
351* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.4.2-2
352- build with rpm-4.8.1-1 for pkg-config file
353
354* Mon Aug 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
355- new upstream release
356
357* Tue Jul 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
358- new upstream release
359
360* Thu Jul 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
361- new upstream release
362
363* Sun May 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-2
364- enable bytecode interpreter, the patent is now expired.
365
366* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-1
367- new upstream release
368
369* Tue Oct 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.11-1
370- new upstream release
371- update patch201
372
373* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-6
374- rebuild with gpg signing
375
376* Wed Jul 29 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-5
377- fixed "Invalid Outline" error on x86_64.
378
379* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.9-4
380- removed %%if !%%{build_compat32} case condition
381- removed CC='gcc -m32' before make setup
382
383* Sun Apr 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-3
384- enable Patch200 again
385
386* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-2
387- split static library to freetype2-static
388  - needed by tuxonice-userui
389- disable Patch200
390
391* Sat Mar 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-1
392- new upstream release
393
394* Wed Jan 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-1
395- new upstream release
396
397* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.7-2
398- removed *.la
399
400* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-1
401- new upstream release
402
403* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-1
404- new upstream release
405
406* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-3
407- add Provides: freetype-utils = %%{version} to freetype2-demos
408
409* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-2
410- remove %%{_bindir}/* from -devel
411
412* Fri Mar 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-1
413- new upstream release
414- add freetype2-demos
415  - Obsoletes: freetype-utils
416
417* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.4-0vl2
418- add Patch201 (CVE-2007-2754)
419
420* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-0vl1
421- new upstream release
422
423* Thu Aug 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.10-0vl8
424- add Requires: zlib-devel (devel package)
425- compat32
426  - add BuildRequires: compat32-zlib-devel
427  - add Requires: compat32-zlib-devel (devel package)
428
429* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl7
430- add Patch200 to adjust synthetic-embold font weight.
431  - default value is too heavy...
432
433* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl6
434- add Patch100 for autofit-cjk
435
436* Fri Feb 24 2006 Shu KONNO <owa@bg.wakwak.com> 2.1.10-0vl5
437- added --libdir=%%{_libdir} to make setup
438- added CC='gcc -m32' before make setup if compat32
439
440* Sun Feb 12 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.1.10-0vl4
441- added compat32-* packages for x86_64 architecture support
442
443* Thu Oct 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl3
444- add upstream patches (from MDK)
445  - add Patch13 to fix memleak
446  - add Patch14 to put back internal API, used by XOrg
447  - add Patch15 to fix bad anti-aliasing
448
449* Sat Oct 01 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl2
450- add upstream patches (from MDK)
451  - add Patch10 to add fixes from CVS
452  - add Patch11 to fix autofit render setup
453  - add Patch12 to fix kerning
454- add Patch20 (enable bytecode interpreter), but not applied by default
455
456* Tue Sep  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.10-0vl1
457- new upstream release
458- drop Patch1 (auto-hinter has been replaced with a new module)
459- drop Patch2 (included in freetype-2.1.8)
460- add pkgconfig file
461
462* Fri Apr 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl4
463- add xtt2-1.2a related patch which is merged in CVS.
464  (http://x-tt.sourceforge.jp/index_nippon.html)
465
466* Thu Apr 01 2004 Tomoya TAKA <taka@vinelinux.org> 2.1.7-0vl3
467- add a fix from Fedora freetype-2.1.7-3
468  * Wed Mar 10 2004 Mike A. Harris <mharris@redhat.com> 2.1.7-3
469  - Added -fno-strict-aliasing to CFLAGS and CXXFLAGS to try to fix SEGV and
470    SIGILL crashes in mkfontscale which have been traced into freetype and seem
471    to be caused by aliasing issues in freetype macros
472
473* Wed Dec 10 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.7-0vl2
474- update patch1
475
476* Sun Nov 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
477- new upstream release
478
479* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl2
480- rebuild for VineSeed
481
482* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
483- source upgrade
484- add Patch1 from http://www.kde.gr.jp/~akito/
485- remove Source1
486- remove Patch0 (no need to 2.1.5)
487
488* Wed Aug 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
489- correct License tag from GPL to GPL/FTL dual license
490  - FTL: The FreeType Project License
491
492* Wed Apr  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.4-0vl1
493- source upgrade
494
495* Sat Dec  7 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
496- source and patch upgrade
497
498* Thu Dec  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl3
499- rebuild with new toolchain
500
501* Wed Aug 21 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
502- add Patch0 to fix problem to Dyna-Font
503
504* Tue Jul 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl1
505- source upgrade
506- add %{_datadir}/aclocal/freetype2.m4 to -devel
507
508* Mon Jan 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.6-0vl2
509- modified %%build section
510
511* Wed Jan 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.6-0vl1
512- source update
513- add ftdocs
514
515* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.1-0vl5
516- small build fix
517
518* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl4
519- Added Requires for -devel
520- Fixed config path
521
522* Mon Apr 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.1-0vl3
523- add %{_bindir} in devel package's %file section.
524
525* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl2
526- Added %defattr.
527
528* Sun Dec 17 2000 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl1
529- Initial revision.
530
Note: See TracBrowser for help on using the repository browser.