source: projects/specs/trunk/f/freetype2/freetype2-vl.spec @ 8064

Revision 8064, 15.9 KB checked in by Takemikaduchi, 11 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with subpixel_rendering
4%define ver_majar 2.5.2
5
6Summary: FreeType 2 library
7Summary(ja): FreeType 2 ライブラリ
8Name: freetype2
9Version: %{ver_majar}
10Release: 4%{?_dist_release}
11License: GPL/FTL dual license
12URL: http://www.freetype.org/
13Group: System Environment/Libraries
14
15Source: freetype-%{version}.tar.bz2
16Source1: freetype-doc-%{ver_majar}.tar.bz2
17Source2: ft2demos-%{ver_majar}.tar.bz2
18
19# enable subpixel rendering
20Patch21: freetype-2.3.0-enable-spr.patch
21# Enable otvalid and gxvalid modules
22Patch46:  freetype-2.2.1-enable-valid.patch
23# Fix multilib conflicts
24Patch88:  freetype-multilib.patch
25# Fix crash https://bugs.freedesktop.org/show_bug.cgi?id=6841
26Patch89:  freetype-2.2.1-memcpy-fix.patch
27Patch90:  freetype-2.5.2-pkgconfig.patch
28
29Patch200: freetype-2.1.10-slight-embolden.patch
30Patch201: freetype-2.4.12-x86_64-invalid_outline.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires: zlib-devel
35BuildRequires: bzip2-devel
36BuildRequires: libX11-devel
37BuildRequires: libpng-devel
38Requires: zlib
39Requires: bzip2
40
41%description
42The FreeType project is a team of volunteers who develop free,
43portable and high-quality software solutions for digital typography.
44They specifically target embedded systems and focus on bringing small,
45efficient and ubiquitous products.
46
47The FreeType 2 library is their new software font engine. It has been
48designed to provide the following important features:
49 * A universal and simple API to manage font files
50 * Support for several font formats through loadable modules
51 * High-quality anti-aliasing
52 * High portability & performance
53
54Supported font formats include:
55 * TrueType files (.ttf) and collections (.ttc)
56 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
57 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
58   routines to manage design instances easily
59 * Type 1 CID-keyed fonts
60 * OpenType/CFF (.otf) fonts
61 * CFF/Type 2 fonts
62 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
63   the Adobe SVG viewer plugin.
64 * Windows FNT/FON bitmap fonts
65
66This package contains the files needed to run programs that use the
67FreeType 2 library.
68
69
70%package demos
71Summary: A collection of FreeType demos
72Group: System Environment/Libraries
73Requires: %{name} = %{version}-%{release}
74Obsoletes: freetype-utils < 2.0
75Provides: freetype-utils = %{version}
76
77%description demos
78A collection of FreeType demos.
79
80
81%package -n compat32-%{name}
82Summary: FreeType 2 library
83Summary(ja): FreeType 2 ライブラリ
84Group: System Environment/Libraries
85Requires:       %{name} = %{version}-%{release}
86
87
88%description -n compat32-%{name}
89The FreeType project is a team of volunteers who develop free,
90portable and high-quality software solutions for digital typography.
91They specifically target embedded systems and focus on bringing small,
92efficient and ubiquitous products.
93
94The FreeType 2 library is their new software font engine. It has been
95designed to provide the following important features:
96 * A universal and simple API to manage font files
97 * Support for several font formats through loadable modules
98 * High-quality anti-aliasing
99 * High portability & performance
100
101Supported font formats include:
102 * TrueType files (.ttf) and collections (.ttc)
103 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
104 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
105   routines to manage design instances easily
106 * Type 1 CID-keyed fonts
107 * OpenType/CFF (.otf) fonts
108 * CFF/Type 2 fonts
109 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
110   the Adobe SVG viewer plugin.
111 * Windows FNT/FON bitmap fonts
112
113This package contains the files needed to run programs that use the
114FreeType 2 library.
115
116
117%package devel
118Summary:        Development files for FreeType 2 library
119Summary(ja):    FreeType 2 ライブラリの開発ファイル
120Group:          Development/Libraries
121Requires:       %{name} = %{version}-%{release}
122Requires:       zlib-devel
123Requires:       bzip2-devel
124
125
126%description devel
127The FreeType project is a team of volunteers who develop free,
128portable and high-quality software solutions for digital typography.
129They specifically target embedded systems and focus on bringing small,
130efficient and ubiquitous products.
131
132The FreeType 2 library is their new software font engine. It has been
133designed to provide the following important features:
134 * A universal and simple API to manage font files
135 * Support for several font formats through loadable modules
136 * High-quality anti-aliasing
137 * High portability & performance
138
139Supported font formats include:
140 * TrueType files (.ttf) and collections (.ttc)
141 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
142 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
143   routines to manage design instances easily
144 * Type 1 CID-keyed fonts
145 * OpenType/CFF (.otf) fonts
146 * CFF/Type 2 fonts
147 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
148   the Adobe SVG viewer plugin.
149 * Windows FNT/FON bitmap fonts
150
151This package contains all supplementary files (static library, headers
152and documentation) you need to develop your own programs using the
153FreeType 2 library.
154
155
156%package -n compat32-%{name}-devel
157Summary:        FreeType 2 library
158Summary(ja):    FreeType 2 ライブラリ
159Group:          Development/Libraries
160Requires:       compat32-%{name} = %{version}-%{release}
161Requires:       %{name}-devel    = %{version}-%{release}
162Requires:       compat32-zlib-devel
163Requires:       compat32-bzip2-devel
164
165%description -n compat32-%{name}-devel
166The FreeType project is a team of volunteers who develop free,
167portable and high-quality software solutions for digital typography.
168They specifically target embedded systems and focus on bringing small,
169efficient and ubiquitous products.
170
171The FreeType 2 library is their new software font engine. It has been
172designed to provide the following important features:
173 * A universal and simple API to manage font files
174 * Support for several font formats through loadable modules
175 * High-quality anti-aliasing
176 * High portability & performance
177
178Supported font formats include:
179 * TrueType files (.ttf) and collections (.ttc)
180 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
181 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
182   routines to manage design instances easily
183 * Type 1 CID-keyed fonts
184 * OpenType/CFF (.otf) fonts
185 * CFF/Type 2 fonts
186 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
187   the Adobe SVG viewer plugin.
188 * Windows FNT/FON bitmap fonts
189
190This package contains all supplementary files (static library, headers
191and documentation) you need to develop your own programs using the
192FreeType 2 library.
193
194%package static
195Summary:        Static ilbrary for FreeType 2
196Summary(ja):    FreeType 2 のスタティックライブラリ
197Group:          Development/Libraries
198Requires:       %{name}-devel = %{version}-%{release}
199
200%description static
201This package contains the static library for %{name}
202
203%prep
204%setup -q -n freetype-%{version} -b 1 -a 2
205
206%if %{with subpixel_rendering}
207%patch21 -p1 -b .enable-spr
208%endif
209
210%patch46 -p1 -b .enable-valid
211%patch88 -p1 -b .multilib
212%patch89 -p1 -b .memcpy
213%patch90 -p1 -b .pkgconfig
214
215%patch200 -p1 -b .slight-embolden
216
217%ifarch x86_64
218%patch201 -p1 -b .invalid_outline
219%endif
220
221%build
222%configure
223%__make %{?_smp_mflags}
224
225# Build demos
226pushd ft2demos-%{ver_majar}
227make TOP_DIR=".."
228popd
229
230
231%install
232[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
233
234%makeinstall gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
235
236for ftdemo in ftbench ftdump ftlint ftvalid ftdiff ftgamma ftgrid ftmulti ftstring ftview
237do
238  builds/unix/libtool --mode=install install -m 755 ft2demos-%{ver_majar}/bin/$ftdemo $RPM_BUILD_ROOT/%{_bindir}
239done
240
241## remove unuse files
242rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
243
244
245%clean
246[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
247
248
249%post -p /sbin/ldconfig
250
251%postun -p /sbin/ldconfig
252
253%post -n compat32-%{name} -p /sbin/ldconfig
254
255%postun -n compat32-%{name} -p /sbin/ldconfig
256
257%files
258%defattr(-, root, root)
259%{_libdir}/*.so*
260%doc docs
261
262%files devel
263%defattr(-, root, root)
264%{_bindir}/freetype-config
265%{_libdir}/*.so
266%{_libdir}/pkgconfig/*.pc
267%{_includedir}/%{name}
268%{_datadir}/aclocal/freetype2.m4
269
270%files static
271%defattr(-, root, root)
272%{_libdir}/*.a
273
274%files demos
275%defattr(-,root,root)
276%{_bindir}/ftbench
277%{_bindir}/ftdump
278%{_bindir}/ftlint
279%{_bindir}/ftvalid
280%{_bindir}/ftdiff
281%{_bindir}/ftgamma
282%{_bindir}/ftgrid
283%{_bindir}/ftmulti
284%{_bindir}/ftstring
285%{_bindir}/ftview
286
287%if %{build_compat32}
288%files -n compat32-%{name}
289%defattr(-, root, root)
290%{_libdir}/*.so*
291
292%files -n compat32-%{name}-devel
293%defattr(-, root, root)
294%{_libdir}/*.so
295%endif
296
297%changelog
298* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
299- fix Patch90
300- fix %%files -n compat32-%%{name}-devel (remove pkgconfig files)
301
302* Tue Dec 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-3
303- re-fixed invalid infomation in freetype-config
304
305* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-2
306- fixed invalid infomation in freetype-config (BTS:2711)
307
308* Sat Dec 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-1
309- new upstream release
310
311* Mon Aug 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.0.1-1
312- new upstream release
313- added BuildRequires: libpng-devel
314
315* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-2
316- fixed Patch88
317- added Pacth90 to fix BTS:2631
318
319* Sun May 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-1
320- new upstream release
321- refreshed Patch88, 201
322
323* Sat Dec 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.11-1
324- new upstream release
325
326* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.10-1
327- new upstream release
328- updated Patch201
329
330* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.8-1
331- new upstream release
332- add BuildRequires: bzip2-devel
333- add Requires: bzip2-devel (-devel package)
334
335* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-1
336- new upstream release
337
338* Fri Dec 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-1
339- new upstream release
340
341* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.4.2-2
342- build with rpm-4.8.1-1 for pkg-config file
343
344* Mon Aug 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
345- new upstream release
346
347* Tue Jul 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
348- new upstream release
349
350* Thu Jul 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
351- new upstream release
352
353* Sun May 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-2
354- enable bytecode interpreter, the patent is now expired.
355
356* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-1
357- new upstream release
358
359* Tue Oct 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.11-1
360- new upstream release
361- update patch201
362
363* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-6
364- rebuild with gpg signing
365
366* Wed Jul 29 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-5
367- fixed "Invalid Outline" error on x86_64.
368
369* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.9-4
370- removed %%if !%%{build_compat32} case condition
371- removed CC='gcc -m32' before make setup
372
373* Sun Apr 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-3
374- enable Patch200 again
375
376* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-2
377- split static library to freetype2-static
378  - needed by tuxonice-userui
379- disable Patch200
380
381* Sat Mar 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-1
382- new upstream release
383
384* Wed Jan 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-1
385- new upstream release
386
387* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.7-2
388- removed *.la
389
390* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-1
391- new upstream release
392
393* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-1
394- new upstream release
395
396* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-3
397- add Provides: freetype-utils = %%{version} to freetype2-demos
398
399* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-2
400- remove %%{_bindir}/* from -devel
401
402* Fri Mar 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-1
403- new upstream release
404- add freetype2-demos
405  - Obsoletes: freetype-utils
406
407* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.4-0vl2
408- add Patch201 (CVE-2007-2754)
409
410* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-0vl1
411- new upstream release
412
413* Thu Aug 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.10-0vl8
414- add Requires: zlib-devel (devel package)
415- compat32
416  - add BuildRequires: compat32-zlib-devel
417  - add Requires: compat32-zlib-devel (devel package)
418
419* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl7
420- add Patch200 to adjust synthetic-embold font weight.
421  - default value is too heavy...
422
423* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl6
424- add Patch100 for autofit-cjk
425
426* Fri Feb 24 2006 Shu KONNO <owa@bg.wakwak.com> 2.1.10-0vl5
427- added --libdir=%%{_libdir} to make setup
428- added CC='gcc -m32' before make setup if compat32
429
430* Sun Feb 12 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.1.10-0vl4
431- added compat32-* packages for x86_64 architecture support
432
433* Thu Oct 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl3
434- add upstream patches (from MDK)
435  - add Patch13 to fix memleak
436  - add Patch14 to put back internal API, used by XOrg
437  - add Patch15 to fix bad anti-aliasing
438
439* Sat Oct 01 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl2
440- add upstream patches (from MDK)
441  - add Patch10 to add fixes from CVS
442  - add Patch11 to fix autofit render setup
443  - add Patch12 to fix kerning
444- add Patch20 (enable bytecode interpreter), but not applied by default
445
446* Tue Sep  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.10-0vl1
447- new upstream release
448- drop Patch1 (auto-hinter has been replaced with a new module)
449- drop Patch2 (included in freetype-2.1.8)
450- add pkgconfig file
451
452* Fri Apr 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl4
453- add xtt2-1.2a related patch which is merged in CVS.
454  (http://x-tt.sourceforge.jp/index_nippon.html)
455
456* Thu Apr 01 2004 Tomoya TAKA <taka@vinelinux.org> 2.1.7-0vl3
457- add a fix from Fedora freetype-2.1.7-3
458  * Wed Mar 10 2004 Mike A. Harris <mharris@redhat.com> 2.1.7-3
459  - Added -fno-strict-aliasing to CFLAGS and CXXFLAGS to try to fix SEGV and
460    SIGILL crashes in mkfontscale which have been traced into freetype and seem
461    to be caused by aliasing issues in freetype macros
462
463* Wed Dec 10 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.7-0vl2
464- update patch1
465
466* Sun Nov 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
467- new upstream release
468
469* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl2
470- rebuild for VineSeed
471
472* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
473- source upgrade
474- add Patch1 from http://www.kde.gr.jp/~akito/
475- remove Source1
476- remove Patch0 (no need to 2.1.5)
477
478* Wed Aug 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
479- correct License tag from GPL to GPL/FTL dual license
480  - FTL: The FreeType Project License
481
482* Wed Apr  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.4-0vl1
483- source upgrade
484
485* Sat Dec  7 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
486- source and patch upgrade
487
488* Thu Dec  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl3
489- rebuild with new toolchain
490
491* Wed Aug 21 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
492- add Patch0 to fix problem to Dyna-Font
493
494* Tue Jul 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl1
495- source upgrade
496- add %{_datadir}/aclocal/freetype2.m4 to -devel
497
498* Mon Jan 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.6-0vl2
499- modified %%build section
500
501* Wed Jan 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.6-0vl1
502- source update
503- add ftdocs
504
505* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.1-0vl5
506- small build fix
507
508* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl4
509- Added Requires for -devel
510- Fixed config path
511
512* Mon Apr 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.1-0vl3
513- add %{_bindir} in devel package's %file section.
514
515* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl2
516- Added %defattr.
517
518* Sun Dec 17 2000 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl1
519- Initial revision.
520
Note: See TracBrowser for help on using the repository browser.