source: projects/specs/trunk/f/freetype2/freetype2-vl.spec @ 7269

Revision 7269, 15.0 KB checked in by kudoh, 11 years ago (diff)
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with subpixel_rendering
4
5Summary: FreeType 2 library
6Summary(ja): FreeType 2 ライブラリ
7Name: freetype2
8Version: 2.4.11
9Release: 1%{?_dist_release}
10License: GPL/FTL dual license
11URL: http://www.freetype.org/
12Group: System Environment/Libraries
13
14Source: freetype-%{version}.tar.bz2
15Source1: freetype-doc-%{version}.tar.bz2
16Source2: ft2demos-%{version}.tar.bz2
17
18# enable subpixel rendering
19Patch21: freetype-2.3.0-enable-spr.patch
20# Enable otvalid and gxvalid modules
21Patch46:  freetype-2.2.1-enable-valid.patch
22# Fix multilib conflicts
23Patch88:  freetype-multilib.patch
24# Fix crash https://bugs.freedesktop.org/show_bug.cgi?id=6841
25Patch89:  freetype-2.2.1-memcpy-fix.patch
26
27Patch200: freetype-2.1.10-slight-embolden.patch
28Patch201: freetype-2.4.10-x86_64-invalid_outline.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31
32BuildRequires: zlib-devel
33BuildRequires: bzip2-devel
34BuildRequires: libX11-devel
35Requires: zlib
36Requires: bzip2
37
38%description
39The FreeType project is a team of volunteers who develop free,
40portable and high-quality software solutions for digital typography.
41They specifically target embedded systems and focus on bringing small,
42efficient and ubiquitous products.
43
44The FreeType 2 library is their new software font engine. It has been
45designed to provide the following important features:
46 * A universal and simple API to manage font files
47 * Support for several font formats through loadable modules
48 * High-quality anti-aliasing
49 * High portability & performance
50
51Supported font formats include:
52 * TrueType files (.ttf) and collections (.ttc)
53 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
54 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
55   routines to manage design instances easily
56 * Type 1 CID-keyed fonts
57 * OpenType/CFF (.otf) fonts
58 * CFF/Type 2 fonts
59 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
60   the Adobe SVG viewer plugin.
61 * Windows FNT/FON bitmap fonts
62
63This package contains the files needed to run programs that use the
64FreeType 2 library.
65
66
67%package demos
68Summary: A collection of FreeType demos
69Group: System Environment/Libraries
70Requires: %{name} = %{version}-%{release}
71Obsoletes: freetype-utils < 2.0
72Provides: freetype-utils = %{version}
73
74%description demos
75A collection of FreeType demos.
76
77
78%package -n compat32-%{name}
79Summary: FreeType 2 library
80Summary(ja): FreeType 2 ライブラリ
81Group: System Environment/Libraries
82Requires:       %{name} = %{version}-%{release}
83
84
85%description -n compat32-%{name}
86The FreeType project is a team of volunteers who develop free,
87portable and high-quality software solutions for digital typography.
88They specifically target embedded systems and focus on bringing small,
89efficient and ubiquitous products.
90
91The FreeType 2 library is their new software font engine. It has been
92designed to provide the following important features:
93 * A universal and simple API to manage font files
94 * Support for several font formats through loadable modules
95 * High-quality anti-aliasing
96 * High portability & performance
97
98Supported font formats include:
99 * TrueType files (.ttf) and collections (.ttc)
100 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
101 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
102   routines to manage design instances easily
103 * Type 1 CID-keyed fonts
104 * OpenType/CFF (.otf) fonts
105 * CFF/Type 2 fonts
106 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
107   the Adobe SVG viewer plugin.
108 * Windows FNT/FON bitmap fonts
109
110This package contains the files needed to run programs that use the
111FreeType 2 library.
112
113
114%package devel
115Summary:        Development files for FreeType 2 library
116Summary(ja):    FreeType 2 ライブラリの開発ファイル
117Group:          Development/Libraries
118Requires:       %{name} = %{version}-%{release}
119Requires:       zlib-devel
120Requires:       bzip2-devel
121
122
123%description devel
124The FreeType project is a team of volunteers who develop free,
125portable and high-quality software solutions for digital typography.
126They specifically target embedded systems and focus on bringing small,
127efficient and ubiquitous products.
128
129The FreeType 2 library is their new software font engine. It has been
130designed to provide the following important features:
131 * A universal and simple API to manage font files
132 * Support for several font formats through loadable modules
133 * High-quality anti-aliasing
134 * High portability & performance
135
136Supported font formats include:
137 * TrueType files (.ttf) and collections (.ttc)
138 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
139 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
140   routines to manage design instances easily
141 * Type 1 CID-keyed fonts
142 * OpenType/CFF (.otf) fonts
143 * CFF/Type 2 fonts
144 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
145   the Adobe SVG viewer plugin.
146 * Windows FNT/FON bitmap fonts
147
148This package contains all supplementary files (static library, headers
149and documentation) you need to develop your own programs using the
150FreeType 2 library.
151
152
153%package -n compat32-%{name}-devel
154Summary:        FreeType 2 library
155Summary(ja):    FreeType 2 ライブラリ
156Group:          Development/Libraries
157Requires:       compat32-%{name} = %{version}-%{release}
158Requires:       %{name}-devel    = %{version}-%{release}
159Requires:       compat32-zlib-devel
160Requires:       compat32-bzip2-devel
161
162%description -n compat32-%{name}-devel
163The FreeType project is a team of volunteers who develop free,
164portable and high-quality software solutions for digital typography.
165They specifically target embedded systems and focus on bringing small,
166efficient and ubiquitous products.
167
168The FreeType 2 library is their new software font engine. It has been
169designed to provide the following important features:
170 * A universal and simple API to manage font files
171 * Support for several font formats through loadable modules
172 * High-quality anti-aliasing
173 * High portability & performance
174
175Supported font formats include:
176 * TrueType files (.ttf) and collections (.ttc)
177 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
178 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
179   routines to manage design instances easily
180 * Type 1 CID-keyed fonts
181 * OpenType/CFF (.otf) fonts
182 * CFF/Type 2 fonts
183 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
184   the Adobe SVG viewer plugin.
185 * Windows FNT/FON bitmap fonts
186
187This package contains all supplementary files (static library, headers
188and documentation) you need to develop your own programs using the
189FreeType 2 library.
190
191%package static
192Summary:        Static ilbrary for FreeType 2
193Summary(ja):    FreeType 2 のスタティックライブラリ
194Group:          Development/Libraries
195Requires:       %{name}-devel = %{version}-%{release}
196
197%description static
198This package contains the static library for %{name}
199
200%prep
201%setup -q -n freetype-%{version} -b 1 -a 2
202
203%if %{with subpixel_rendering}
204%patch21 -p1 -b .enable-spr
205%endif
206
207%patch46 -p1 -b .enable-valid
208%patch88 -p1 -b .multilib
209%patch89 -p1 -b .memcpy
210
211%patch200 -p1 -b .slight-embolden
212
213%ifarch x86_64
214%patch201 -p1 -b .invalid_outline
215%endif
216
217%build
218%configure
219%__make %{?_smp_mflags}
220
221# Build demos
222pushd ft2demos-%{version}
223make TOP_DIR=".."
224popd
225
226
227%install
228[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
229
230%makeinstall gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
231
232for ftdemo in ftbench ftdump ftlint ftvalid ftdiff ftgamma ftgrid ftmulti ftstring ftview
233do
234  builds/unix/libtool --mode=install install -m 755 ft2demos-%{version}/bin/$ftdemo $RPM_BUILD_ROOT/%{_bindir}
235done
236
237## remove unuse files
238rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
239
240
241%clean
242[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
243
244
245%post -p /sbin/ldconfig
246
247%postun -p /sbin/ldconfig
248
249%post -n compat32-%{name} -p /sbin/ldconfig
250
251%postun -n compat32-%{name} -p /sbin/ldconfig
252
253%files
254%defattr(-, root, root)
255%{_libdir}/*.so*
256%doc docs
257
258%files devel
259%defattr(-, root, root)
260%{_bindir}/freetype-config
261%{_libdir}/*.so
262%{_libdir}/pkgconfig/*.pc
263%{_includedir}/*
264%{_datadir}/aclocal/freetype2.m4
265
266%files static
267%defattr(-, root, root)
268%{_libdir}/*.a
269
270%files demos
271%defattr(-,root,root)
272%{_bindir}/ftbench
273%{_bindir}/ftdump
274%{_bindir}/ftlint
275%{_bindir}/ftvalid
276%{_bindir}/ftdiff
277%{_bindir}/ftgamma
278%{_bindir}/ftgrid
279%{_bindir}/ftmulti
280%{_bindir}/ftstring
281%{_bindir}/ftview
282
283%if %{build_compat32}
284%files -n compat32-%{name}
285%defattr(-, root, root)
286%{_libdir}/*.so*
287
288%files -n compat32-%{name}-devel
289%defattr(-, root, root)
290%{_libdir}/*.so
291%{_libdir}/pkgconfig/*.pc
292%endif
293
294%changelog
295* Sat Dec 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.11-1
296- new upstream release
297
298* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.10-1
299- new upstream release
300- updated Patch201
301
302* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.8-1
303- new upstream release
304- add BuildRequires: bzip2-devel
305- add Requires: bzip2-devel (-devel package)
306
307* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-1
308- new upstream release
309
310* Fri Dec 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-1
311- new upstream release
312
313* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.4.2-2
314- build with rpm-4.8.1-1 for pkg-config file
315
316* Mon Aug 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
317- new upstream release
318
319* Tue Jul 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
320- new upstream release
321
322* Thu Jul 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
323- new upstream release
324
325* Sun May 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-2
326- enable bytecode interpreter, the patent is now expired.
327
328* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-1
329- new upstream release
330
331* Tue Oct 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.11-1
332- new upstream release
333- update patch201
334
335* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-6
336- rebuild with gpg signing
337
338* Wed Jul 29 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-5
339- fixed "Invalid Outline" error on x86_64.
340
341* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.9-4
342- removed %%if !%%{build_compat32} case condition
343- removed CC='gcc -m32' before make setup
344
345* Sun Apr 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-3
346- enable Patch200 again
347
348* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-2
349- split static library to freetype2-static
350  - needed by tuxonice-userui
351- disable Patch200
352
353* Sat Mar 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-1
354- new upstream release
355
356* Wed Jan 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-1
357- new upstream release
358
359* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.7-2
360- removed *.la
361
362* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-1
363- new upstream release
364
365* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-1
366- new upstream release
367
368* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-3
369- add Provides: freetype-utils = %%{version} to freetype2-demos
370
371* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-2
372- remove %%{_bindir}/* from -devel
373
374* Fri Mar 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-1
375- new upstream release
376- add freetype2-demos
377  - Obsoletes: freetype-utils
378
379* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.4-0vl2
380- add Patch201 (CVE-2007-2754)
381
382* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-0vl1
383- new upstream release
384
385* Thu Aug 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.10-0vl8
386- add Requires: zlib-devel (devel package)
387- compat32
388  - add BuildRequires: compat32-zlib-devel
389  - add Requires: compat32-zlib-devel (devel package)
390
391* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl7
392- add Patch200 to adjust synthetic-embold font weight.
393  - default value is too heavy...
394
395* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl6
396- add Patch100 for autofit-cjk
397
398* Fri Feb 24 2006 Shu KONNO <owa@bg.wakwak.com> 2.1.10-0vl5
399- added --libdir=%%{_libdir} to make setup
400- added CC='gcc -m32' before make setup if compat32
401
402* Sun Feb 12 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.1.10-0vl4
403- added compat32-* packages for x86_64 architecture support
404
405* Thu Oct 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl3
406- add upstream patches (from MDK)
407  - add Patch13 to fix memleak
408  - add Patch14 to put back internal API, used by XOrg
409  - add Patch15 to fix bad anti-aliasing
410
411* Sat Oct 01 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl2
412- add upstream patches (from MDK)
413  - add Patch10 to add fixes from CVS
414  - add Patch11 to fix autofit render setup
415  - add Patch12 to fix kerning
416- add Patch20 (enable bytecode interpreter), but not applied by default
417
418* Tue Sep  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.10-0vl1
419- new upstream release
420- drop Patch1 (auto-hinter has been replaced with a new module)
421- drop Patch2 (included in freetype-2.1.8)
422- add pkgconfig file
423
424* Fri Apr 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl4
425- add xtt2-1.2a related patch which is merged in CVS.
426  (http://x-tt.sourceforge.jp/index_nippon.html)
427
428* Thu Apr 01 2004 Tomoya TAKA <taka@vinelinux.org> 2.1.7-0vl3
429- add a fix from Fedora freetype-2.1.7-3
430  * Wed Mar 10 2004 Mike A. Harris <mharris@redhat.com> 2.1.7-3
431  - Added -fno-strict-aliasing to CFLAGS and CXXFLAGS to try to fix SEGV and
432    SIGILL crashes in mkfontscale which have been traced into freetype and seem
433    to be caused by aliasing issues in freetype macros
434
435* Wed Dec 10 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.7-0vl2
436- update patch1
437
438* Sun Nov 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
439- new upstream release
440
441* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl2
442- rebuild for VineSeed
443
444* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
445- source upgrade
446- add Patch1 from http://www.kde.gr.jp/~akito/
447- remove Source1
448- remove Patch0 (no need to 2.1.5)
449
450* Wed Aug 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
451- correct License tag from GPL to GPL/FTL dual license
452  - FTL: The FreeType Project License
453
454* Wed Apr  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.4-0vl1
455- source upgrade
456
457* Sat Dec  7 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
458- source and patch upgrade
459
460* Thu Dec  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl3
461- rebuild with new toolchain
462
463* Wed Aug 21 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
464- add Patch0 to fix problem to Dyna-Font
465
466* Mon Jul 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl1
467- source upgrade
468- add %{_datadir}/aclocal/freetype2.m4 to -devel
469
470* Mon Jan 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.6-0vl2
471- modified %%build section
472
473* Wed Jan 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.6-0vl1
474- source update
475- add ftdocs
476
477* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.1-0vl5
478- small build fix
479
480* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl4
481- Added Requires for -devel
482- Fixed config path
483
484* Mon Apr 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.1-0vl3
485- add %{_bindir} in devel package's %file section.
486
487* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl2
488- Added %defattr.
489
490* Sun Dec 17 2000 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl1
491- Initial revision.
492
Note: See TracBrowser for help on using the repository browser.